RS485 TLC5000 sendet ohne Request

Alles über Photovoltaik Wechselrichter...

Moderator: Mod-Team

 

0.00 (0 Bewertungen)

RS485 TLC5000 sendet ohne Request

Beitragvon Knut1957 » 11.05.2018, 00:14

Hallo,
Ich möchte meinen Zeversolar TLC5000 über die RS485 Schnittstelle abhören und steuern.
Nach langem Suchen habe ich nun die internen Anschlüsse A und B gefunden.
Ich bekomme aber keine Kommunikation hin.
Für mich verwirrend ist, dass der Inverter, der ja eigentlich der Slave sein sollte, unaufgefordert un wiederholend sendet.
Was er sendet ist mir nicht klar.

Hat jemand einen Hinweis was da läuft, was ich ggf. falsch mache ?
Knut1957
Neu hier
Neu hier
 
- Threadstarter -
 
Beiträge: 2
Registriert: 10.05.2018, 23:57
PV-Anlage [kWp]: 5,4
Info: Betreiber

Re: RS485 TLC5000 sendet ohne Request

Beitragvon LumpiStefan » 11.05.2018, 00:19

Vielleicht hilft das weiter: https://github.com/solmoller/eversolar-monitor

Stefan
49 Sunways SM215 + SMA 10000 & 7 SF 150/10 & 6 Conergy + SMA 3000
516 Antaris ASM185 + Danfoss TLX15K
Willst du mir was gutes tun... --> http://www.stefan-bauer.net/daten/spende/
Benutzeravatar
LumpiStefan
Forum Genie
Forum Genie
 
Beiträge: 9238
Registriert: 16.03.2007, 18:28
Wohnort: Sindelfingen
PV-Anlage [kWp]: 109
Info: Betreiber

Re: RS485 TLC5000 sendet ohne Request

Beitragvon Knut1957 » 13.05.2018, 11:42

Vielen Dank für den Hinweis, aber dort habe ich keine Erklärung dafür gefunden.

Ich gehe davon aus, dass die RS485 Schnittstelle das Modbus Protkoll verwendet, und der Inverter (slave) nur antwortet, wenn der Master ihn aufgefordert hat.
Knut1957
Neu hier
Neu hier
 
- Threadstarter -
 
Beiträge: 2
Registriert: 10.05.2018, 23:57
PV-Anlage [kWp]: 5,4
Info: Betreiber


Zurück zu Wechselrichter



Ähnliche Beiträge


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste