Ausreißer Außen-Temperatur nach oben

Moderator: Mod-Team

 

0.00 (0 Bewertungen)

Re: Ausreißer Außen-Temperatur nach oben

Beitragvon sunpower-oeko » 16.01.2018, 08:22

Hallo Frank,

also ich verstehe das jetzt so:
1. Den roten Draht (aktuell 3,3V) wird jetzt auf den 5 V im PI gesetzt.

2. Dann einen zusätzlichen Draht auf den 3,3 V Pin im PI und in meinen Verteiler gezogen.

3. Danach entferne ich den Widerstand aus dem jetzt zu dem 5 Volt gewordenen Draht und klemme diesen dann an den
3,3 V Draht an.

4. Der Widerstand ist dann mit Data (weiss) und jetzt mit dem 3,3 V Pin verbunden.

5. Danach kann ich wieder Strom auf den PI geben und starten.

Habe ich jetzt noch was vergessen, oder falsch verstanden?
MfG

Sunpower-oeko
sunpower-oeko
Stammmitglied
Stammmitglied
 
- Threadstarter -
 
Beiträge: 72
Registriert: 01.09.2017, 17:05
Wohnort: Suedschwarzwald
PV-Anlage [kWp]: 5,4
Speicher [kWh]: 4,7
Info: Interessent

Re: Ausreißer Außen-Temperatur nach oben

Beitragvon frank-83 » 16.01.2018, 12:15

Ja, so passt es. Siehe z.B. hier: https://www.msxfaq.de/sonst/bastelbude/ ... -1wire.htm

Eigene Erfahrung mit dieser Beschaltung habe ich nicht, aber vielleicht ist es einen Versuch wert. Die Nachrüstung eines Busmasters erscheint mir aber eher erfolgversprechend.

Gruß
Frank
frank-83
Forumsinventar
Forumsinventar
 
Beiträge: 830
Registriert: 26.05.2015, 11:27
Info: Betreiber

Re: Ausreißer Außen-Temperatur nach oben

Beitragvon sunpower-oeko » 17.01.2018, 18:16

Hallo Frank,

habe den Aussensensor jetzt auf einem anderen Pi einzeln nach Deiner Vorgabe angeschlossen.
Also so sind die Ausreißer noch viel schlimmer.

Vorläufig erst mal wieder alles auf Anfang.

Versuch macht klug.

Aber trotzdem

:danke:
MfG

Sunpower-oeko
sunpower-oeko
Stammmitglied
Stammmitglied
 
- Threadstarter -
 
Beiträge: 72
Registriert: 01.09.2017, 17:05
Wohnort: Suedschwarzwald
PV-Anlage [kWp]: 5,4
Speicher [kWh]: 4,7
Info: Interessent

Re: Ausreißer Außen-Temperatur nach oben

Beitragvon frank-83 » 18.01.2018, 00:08

Schade! Hätte ja sein können, nachdem diese Variante gerade für längere Kabel angepriesen wird.

Kannst du ausschließen dass dein Außensensor selbst einen Schlag weg hat, d.h. kannst du den unkompliziert gegen einen anderen austauschen?

Ansonsten würde ich die Sache mit dem Busmaster angehen.

Gruß
Frank
frank-83
Forumsinventar
Forumsinventar
 
Beiträge: 830
Registriert: 26.05.2015, 11:27
Info: Betreiber

Re: Ausreißer Außen-Temperatur nach oben

Beitragvon sunpower-oeko » 18.01.2018, 17:52

Hallo Frank,

frank-83 hat geschrieben:Kannst du ausschließen dass dein Außensensor selbst einen Schlag weg hat, d.h. kannst du den unkompliziert gegen einen anderen austauschen?
Gruß Frank


Ich kann weder ausschliessen noch auf die schnelle austauschen.
Ersatz habe ich leider keinen mehr da. Und einen neuen möchte ich nicht kaufen.
Ich habe aber noch einen PT100 mit zwei Drähten ungenutzt hier liegen,
Müsste vermutlich dieser hier sein:
https://www.sika.net/produkte/mess-und- ... gsmerkmale

Kann man mit dem auch was probieren?
MfG

Sunpower-oeko
sunpower-oeko
Stammmitglied
Stammmitglied
 
- Threadstarter -
 
Beiträge: 72
Registriert: 01.09.2017, 17:05
Wohnort: Suedschwarzwald
PV-Anlage [kWp]: 5,4
Speicher [kWh]: 4,7
Info: Interessent

Re: Ausreißer Außen-Temperatur nach oben

Beitragvon frank-83 » 18.01.2018, 18:31

Ne, Pt100 ist eine völlig andere Baustelle...

Frank
frank-83
Forumsinventar
Forumsinventar
 
Beiträge: 830
Registriert: 26.05.2015, 11:27
Info: Betreiber

Re: Ausreißer Außen-Temperatur nach oben

Beitragvon sunpower-oeko » 18.01.2018, 18:47

Hallo Frank,

Danke für die schnelle Auskunft.

Ich glaube vorläufig lass ich das Teil einfach mal laufen.

Oder ich mach mal die Verkabelung 5V/3,3V mit allen Sensoren (9 kurzen Sensoren und 1 langer Sensor) am Raspi 3.
Habe mich bisher nicht getraut und nur den langen Sensor am Raspi 1 laufen gehabt.
MfG

Sunpower-oeko
sunpower-oeko
Stammmitglied
Stammmitglied
 
- Threadstarter -
 
Beiträge: 72
Registriert: 01.09.2017, 17:05
Wohnort: Suedschwarzwald
PV-Anlage [kWp]: 5,4
Speicher [kWh]: 4,7
Info: Interessent

Re: Ausreißer Außen-Temperatur nach oben

Beitragvon frank-83 » 19.01.2018, 13:24

Hi,

wenn die Ausreißer tatsächlich immer 85°C sind, könntest du sie auch regelmäßig mit einem kleinen Script aus der DB löschen. Ist zwar eigentlich Pfusch, aber zumindest sehen die Graphen dann besser aus.

Grüße
Frank
frank-83
Forumsinventar
Forumsinventar
 
Beiträge: 830
Registriert: 26.05.2015, 11:27
Info: Betreiber

Re: Ausreißer Außen-Temperatur nach oben

Beitragvon sunpower-oeko » 19.01.2018, 17:17

Hallo Frank,

das mit dem Skript klingt gut, nur ich habe persönlich noch keine Ahnung davon, wie das zu erstellen ist.

Bei der Tagesansicht sehen die Ausreisser wie ca. 5°C gegenüber der normalen ständig gemessenen Temperatur aus. Zoomt man dann den Ausreisser grösser, dann wird er zu 85°C.

Bei der Wochenansicht fallen die dann gar nicht mehr auf und sind nicht mehr zu sehen.

Ich denke man soll hier nicht päpstlicher sein als der Papst.
Augen zu und durch....
MfG

Sunpower-oeko
sunpower-oeko
Stammmitglied
Stammmitglied
 
- Threadstarter -
 
Beiträge: 72
Registriert: 01.09.2017, 17:05
Wohnort: Suedschwarzwald
PV-Anlage [kWp]: 5,4
Speicher [kWh]: 4,7
Info: Interessent

Re: Ausreißer Außen-Temperatur nach oben

Beitragvon themanfrommoon » 21.01.2018, 18:31

Bei der Tagesansicht sehen die Ausreisser wie ca. 5°C gegenüber der normalen ständig gemessenen Temperatur aus. Zoomt man dann den Ausreisser grösser, dann wird er zu 85°C.

Immer wieder schön wenn sich später herausstellt, dass man schon auf der richtigen Fährte war, der der Fragensteller diese Tipps und Nachfragen einfach ignoriert... Man könnte sich ja so viel Blindleistung ersparen...und man fühlt sich auch direkt Wertgeschätzt....
Ich hatte am 9.Januar folgendes geschrieben:
Achtung, du musst weit genug reinzoomen, damit du das siehst, ansonsten wird der Wert durch die Aggregation kleiner dargestellt als 85°C.

Wenn ja, dann liegt das (Achtung, möglicherweise laienhaftes Halbwissen, bitte korrigieren, wenn falsch) an der Stromversorgung des Sensors.
Dann musst du dort ansetzen.

Wenn die Fehler so selten und nur bei einem Sensor auftreten wird es wahrscheinlich reichen den Pull-Up Widerstand ein wenig anzupassen, so dass der Sensor ausreichend Spannung für das Wandeln und Senden bekommt.

wenn die Ausreißer tatsächlich immer 85°C sind, könntest du sie auch regelmäßig mit einem kleinen Script aus der DB löschen. Ist zwar eigentlich Pfusch, aber zumindest sehen die Graphen dann besser aus.

Das ist leider eine ganz schlechte Idee.
Denn wer weiss dann schon wie oft dieser Fehler auftritt?
Wenn der Fehler immer öfter auftritt und irgendwann dominiert, dann kommen gar keine brauchbaren Messwerte mehr an.
Bei mir macht z.B. ein Sensor seit einer Weile sowas:
T15ZirkulationKüche1.PNG

Der fing irgendwann mal an damit. Aber ich glaube nicht einfach so spontan, sondern nachdem ich in Etappen immer mehr Sensoren dem Bus hinzugefügt habe. So wächst die der Leitungswiderstand und Leitungskapazität und es sinkt die Spannung die für jeden Sensor zur Verfügung steht. Der Sensor mit der kritischsten Toleranzgrenze fängt dann langsam an rumzuspinnen.
Is aber auch nicht immer so:
T15ZirkulationKüche2.PNG

Vermutlich könnte ich mein Problem auch lösen in dem ich den Pull-Up Widerstand kleiner machen könnte. Ich werde es aber anders angehen, weil beim weiteren geplanten Ausbau das bei mir noch viel kritischer werden würde. (weitere Zweige mit Stern-Enden und somit immer mehr Reflexionen von den vielen Bus-Enden).
Bei mir liegt das an einem topografisch suboptimalem 1-Wire Bus.
Da werde ich mal bald beigehen und das Übel an der Wurzel bekämpfen.
Ein 8-port Busmaster hab ich schon hier.
Fehlt nur noch die Zeit den zu implementieren.
Dann sind bei mir wieder weniger 1-Wire Geräte an einem Bus dran, und jeder einzelne Bus ist kürzer und topologisch sauberer als der eine Bus.

Lieben Gruß,
Chris
themanfrommoon
Stammmitglied
Stammmitglied
 
Beiträge: 63
Registriert: 09.10.2016, 22:17
Info: Interessent

VorherigeNächste

Zurück zu volkszaehler.org



Ähnliche Beiträge


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste