Beiträge von spooky0815

    Hallo,


    aktuell bekomme ich von verschiedenen Anbietern PV-Module für kleines Geld angeboten, die kein Label hinten drauf haben. Begründung - angeblich aus Überproduktion. Ich kann mir das nicht so richtig vorstellen - Überproduktion ist ja eben trotzdem produziert. Warum also kein Label drauf? Eher Produktionsfehler?


    Bilder und Leistungsdaten aus einem Test in der Lichtkammer passen zu den angegebenen Modell-Linien. Gebrauchsspuren sind nicht zu finden - sehen wirklich neu aus.


    Ich hätte gern von Euch Hinweise, was hier faul läuft bzw. laufen könnte. Oder sind die Panels vlt. sogar bedenkenfrei einsetzbar?


    VG und danke

    So ich habe jetzt ein Passwort für die Ebene 0 (nur lesen) vom Energieversorger erhalten.


    hat jmd. bitte einen Tipp, wie die Befehlssequenz zur Anmeldung aussieht? ich habe bisher nichts finden können.


    hex --> 06 30 35 31 0D 0A .... also die 0x31 für den Programmiermodus... aber was folgt danach.


    Ich danke für alle Hinweise - würde die Lösung gerne für die Community danach kompakt zusammenschreiben.

    Also die Befehle des AS1440 funktionieren wie erwartet nicht, das HowTo ist aber top.


    Ich habe beim Recherchieren rausgefunden, dass mein Stromzähler 2 Passwortlevel hat, um Daten abzurufen. PW-Level 1 ist für den Kunden gedacht, genau für Smart Metering. Nur leider hab ich das Passwort nirgends gefunden.

    Zitat von JAU


    Bei 2 D0-Zählers im Wiki ist das etwas näher erläutert. Glaub der AS1440 und noch ein anderer...


    Ich stürz mich mal ins Reverse Engineering...


    Zitat von JAU

    Schick mir bitte noch ein Foto vom Zähler (gern per PN).


    done...

    JAU: kannst Du evtl. in der Wiki-Stromzähler-DB meinen Typ mit der vzlogger.conf mit der Community bereitstellen:


    EMH Drehstromzähler DMTZ-XC


    Hi,


    also mit der geänderten Startsequenz '\x2F\x32\x21\x0D\x0A' kommt folgende Ausgabe... endlos:



    ich komm aus dem Modus aber nicht mehr raus... scheinbar auch nur 300 Baud. Auslesen hat ca 40 Min gedauert und lieferte ausschließlich die P.01 Sequenzen für jeden Tag, insgesamt 40 Tage in die Vergangenheit.


    JAU: was hats mit diesen P1 Werten auf sich?


    Übrigens, die Nachkommastellen der Zählerwerte hatte ich durch ein manuelles Auslesen sowie durch die Logs vom vzlogger gesehen. Daher war ich mir zumindest sicher, dass diese eine Nachkommastelle ausgewertet werden kann.


    Der Service von EMH hat mit tel. mitgeteilt, dass man an die Momentverbrauchswerte herankommt, er mir aber nichts genaueres sagen darf. Es läuft aber über das IEC 62056-21 Protokoll und hat gesagt, ich soll mal auf die Suche gehen :?::shock:

    Hallo und guten morgen,


    also mein Zähler gibt zumindest eine Nachkommastelle aus.



    Was ist eigentlich die 2.6er Reihe? Scheinleistung?


    @Intervall: ich habe meine vzlogger angepasst und bekomme ein etwas besseres Bild:






    Ich habe aber immernoch das Problem der Auflösung im Diagramm ... alles springt nur zwischen 1000er Niveaus :(


    Und wie ich das jetzt gelesen habe, ist die Kombination von Interval = 10 und aggtime = 60 nicht sinnvoll, oder? Ich dachte, mit diesen Settings werden 6 Messungen zu einem Wert aggregiert.



    Zitat


    Danke auch für die Referenz zur vzlogger.conf - die Struktur der volkszaehler.org Seite könnte wirklich etwas besser gestaltet werden. Wiki ist leider häufig ein "Write-Only"-Speicher, wo man nur schwer Sachen gezielt wiederfindet.


    Das mit der Freischaltung des Zählers werde ich mal versuchen. Vlt. komme ich ja an die Momentverbräuche ran.


    Der Hinweis mit dem Impulsgeber war super ... dann fällt dieser Weg schon mal weg, da also Impulse für Einspeisung und Bezug ausgegeben werden, richtig?



    Ich danke Euch wie verrückt und freue mich auf ergänzende Hinweise bzgl. der Auflösungs- und Konfigurationsproblematik.

    Das leeren der Datentabelle funktioniert leider mit dem Std.Nutzer "vz" auch nicht:


    #1142 - DROP command denied to user 'vz'@'localhost' for table 'data'


    hat jmd eine Idee?


    *****geklärt - mit dem Nutzer "root" und dem Std.Raspi Passwort hats geklappt. ********* DANKE

    Hallo Frank,


    gibts eine kompekte Referenz zu den Settings im vzlogger? Die dublicates Option habe ich noch nicht wirklich verstanden... ich dachte, hier werden doppelte Werte ignoriert.


    Bzw. hast Du gleich die Stellschrauben, wie ich das Logger-Interval sinnvoll anpasse? ... scheinbar nicht via:


    "interval": ???


    Wie hoch sollte aggtime sinnvollerweise gesetzt werden?




    Zu Thema Momentverbrauch: muss ich hierfür die Impuls-Diode noch zusätzlich anzapfen oder kennt jmd. den IEC 62056-21 Befehlscode, um bei den EMH Zählern via D0-Schnittstelle den Momentverbrauch abzufragen. Die Standardtabelle liefert leider keine Momentverbrauchswerte. Ideal wäre ja ein Register, welches die Impulse hochzählt, aber das gibt's lt. Aussage des Herstellers wohl nicht.

    Hallo liebe PV-Community,


    ich habe bei mir einen EHM Stromzähler verbaut, der mir via D0 Daten zum aktuellen Verbrauch sowie die eingespeisten kWh meiner PV Anlage ausgibt.


    Im Stromkasten hängt ein Raspi mit Optischen Lesekopf am Stromzähler. Die Daten werden korrekt empfangen und mittels vzlogger verarbeitet.


    vzlogger.conf:



    im Log-File stehen plausible Ausgaben mit entsprechend korrekten Werten zu den Channels.


    Meine Fragen / Probleme beziehen sich auf die Middleware bzw. Visualisierung im Browser.


    Aktuell sieht das nämlich so aus:




    Die Kanalkonfig wie folgt:




    Nun die 1. Frage ... wo liegt der Fehler in der Darstellung. Ich bin über Tipps dankbar.


    2. Frage: ich kann vom Zähler scheinbar nur absolute Zählerwerte abfragen. Momentverbrauch, etc. gibt mir die D0 Schnittstelle nicht aus (auch sinnvoll, weil über die Zeit integriert werden muss). Wie bekomme ich aus den ausschließlich 2 bereitstehenden Absolutwerten (1.8.0 --> Verbrauch, 2.8.0 --> Einspeisung) Verbrauchswerte mit ggf. Negativ-Ausschlag wie hier:


    https://pixelchrome.org/blog/c…hler-org-web-frontend.png


    3. was ist der schnellste Weg, um die DB zu leeren, ohne die ganze Tabellenstruktur zu löschen... der ganze Datenmüll aus den ersten Experimenten soll ja bald wieder weg.


    Schon jetzt danke... und VG