Beiträge von DSchumacher

    Hallo!


    donnermeister1 :

    Vielen Dank. Der Vorschlag, die Rechte auch der übergeordneten Ordner anzupassen, hat zum Erfolg geführt.


    Zum Nachmachen: mit chmod im Terminal auf dem raspi nach folgendem Beispiel (Syntax oktal, andere Schreibweise als vorgeschlagen, führt zum selben Ergebnis) vorgehen:

    sudo chmod -v 755 /home/pi/svrpi/data

    Das aufsteigend für alle Ordner in der Hierarchie durchführen. Der Parameter -v gibt Rückmeldung aus.

    Danach Raspi neu starten und den Solarlogger Dienst auf dem PC neu starten.


    Danach läuft bei mir tatsächlich alles rund, auch die aktuellen Daten werden im eingestellten Intervall in Solarview@Windows dargestellt.


    Den Lösungsansatz von feli1 konnte ich dann nicht mehr verifizieren, da ich die Änderungen bei mir schon wie oben beschrieben vorgenommen hatte. Den kompletten Pfad wie vorgeschlagen in der datenlogger.ini einzutragen, wäre auf jeden Fall einen Versuch wert. Das wäre dann auch schneller zu bewerkstelligen, als die Anpassung der Ordnerrechte auf dem raspi vorzunehmen.


    Danke an alle!

    Zu früh gefreut! Die Daten werden nur bis zum Startzeitpunkt des Solarlogger-Dienstes nachgeholt, bei den aktuellen Werten ist es die alte Leier. Es sieht dann weiterhin so aus:


    11.02.2019 15:06:02 raspberrypi/svrpi/data/20190211.dat FtpGetFile [doFTPTransfer] Error: 6

    11.02.2019 15:07:01 D:\Solarview\web\months.js erzeugt.

    11.02.2019 15:07:02 D:\Solarview\web\days_hist.js erzeugt.

    11.02.2019 15:11:04 rcd Extd Err: 0 550 Failed to change directory.


    11.02.2019 15:11:04 raspberrypi/svrpi/data/20190211.dat FtpGetFile [doFTPTransfer] Error: 6

    11.02.2019 15:16:01 rcd Extd Err: 0 550 Failed to change directory.


    11.02.2019 15:16:01 raspberrypi/svrpi/data/20190211.dat FtpGetFile [doFTPTransfer] Error: 6

    11.02.2019 15:21:03 rcd Extd Err: 0 550 Failed to change directory.


    11.02.2019 15:21:03 raspberrypi/svrpi/data/20190211.dat FtpGetFile [doFTPTransfer] Error: 6


    Also weiterhin: Wer hat Tipps?

    Hallo,


    habe jetzt eine Lösung, die für mich das Problem behoben hat:


    In der datenlogger.ini die ip-Adresse des raspi durch den Namen des raspi ersetzen. In der Regel also folgendes:


    Vorher z.B.: ftp://192.168.0.159/svrpi/data/
    Nachher z.B.: ftp://raspberrypi/svrpi/data/


    Voila! Nach Neustart des Solarlogger-Dienstes funktioniert bei mir alles einwandfrei, die fehlenden Daten wurden anstandslos in die Datenbank übernommen. Warum die ip nicht akzeptiert wird, die Namensauflösung aber doch - verstehe wer will. Ich bin da raus.


    Bernd : Probier mal aus und berichte, ob es für dich auch funktioniert.

    Bernd ,


    die von dir beschriebene Umstellung im Pfad führt bei mir leider nicht weiter. Test in der datenlogger-Einstellung führt direkt zur Ausgabe von "550 Failed to change directory."
    In der Log-Datei sieht es dann so aus:


    11.02.2019 14:49:03 192.168.178.32/home/pi/svrpi/data/20190117.dat FtpGetFile [doFTPTransfer] Extd Err: 0 200 Switching to Binary mode.

    227 Entering Passive Mode (192,168,178,32,169,137).

    550 Could not get file size.

    550 Failed to open file.


    11.02.2019 14:49:05 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:49:05 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:49:05 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:49:05 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:49:05 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:49:05 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:49:05 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:49:05 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:49:05 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:49:05 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:49:52 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:49:52 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:49:57 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:49:57 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]


    Danke für den Tipp.
    Vielleicht hat ja noch jemand anderes eine Idee, ich komm hier jedenfalls mit meinen Kenntnissen nicht weiter.

    Hallo zusammen,


    ich bin vor kurzem mit Solarview von der Fritzbox auf einen Pi Zero W umgezogen, der ausschließlich die Portalüberwachung ausführt.

    Der Umzug hat reibungslos geklappt, alle Daten werden geloggt, die interne Hompage auf dem raspi ist problemlos erreichbar.

    Solarview@Windows zeigt mir allerdings keine neuen Daten nach dem Umzug mehr an. Die Daten werden im Verzeichnis /data auf dem Raspi abgelegt, können aber offensichtlich nicht importiert werden. Im Datenverzeichnis unter Windows sind keine Daten nach dem Umzug vorhanden. Demzufolge sind diese auch nicht in der Datenbank vorhanden. Die Einstellungen in Datenlogger.ini sind m.E. korrekt, und /data ist beim Test unter ftp://192.168.178.32/svrpi/data/ erreichbar.
    In der Log Datei wird ein Problem beim Import über ftp angezeigt. Einträge sehen wie folgt aus:


    09.02.2019 12:14:21 192.168.178.32/svrpi/data/20190117.dat

    FtpGetFile [doFTPTransfer] Error: 6

    09.02.2019 12:14:21 rcd Extd Err: 0 550 Failed to change

    directory.


    Ich habe bereits versucht die Berechtigungen des Ordners /data anzupassen, dies hat aber keine Abhilfe gebracht.

    Was kann ich tun, damit der Import wieder funktioniert?

    Dateien

    Hallo Manfred,


    nachdem der ganze Prozess etwa 12 h im Hintergrund gelaufen ist, sind alle Daten importiert und die Datenbank gefüllt. Anzeige im Browser funktioniert. Daten von ca . 2,5 Monaten sind geloggt und werden korrekt angezeigt. Die Datenbank ist dabei ca. 20 MB groß. Ist die Größe so ok (6 WR)? Unterwegs musste der USB-Stick der Fritzbox nochmal bereinigt werden, vielleicht lag es daran? Trotzdem schätze ich die Zeit für den Neuaufbau der Datenbank als viel zu lang ein. Ist da ggf. noch ein Hinweis auf ein behebbares Problem?


    Im Ergebnis läuft jetzt alles.
    Vielen Dank für den Support.

    Hallo Manfred,
    ich habe folgendes durchgeführt:


    Dat Verzeichnis enthält alle auf der Fitzbox verfügbaren Datensätze.
    Neu angelegte Datensätze werden von der Fritzbox geholt.
    Die angefragten Fehlermeldungen sind nicht im Logfile.
    Datenbank auf Import alter Daten überprüft. Datenbank ist "leer".
    Datenlogger Dienst beendet.
    Dat auf Fitzbox bis auf 2 letzte aktuelle Tage geleert. Dat im Solarview@windows Verzeichnis geleert.
    Dienst neu gestartet. => Daten werden von der fritzbox geholt. Daten werden weiterhin nicht in Datenbank geschrieben. Datenbank ist permanent gesperrt. Datenbank ist bis auf die übernommene Information, dass 6 WR ausgewertet werden, "leer".
    Auszug Logfile und Datenbankfile (umbenennen) angehängt.


    ???

    Dateien

    • solar.txt

      (380,93 kB, 42 Mal heruntergeladen, zuletzt: )
    • Logfile_Auszug.txt

      (6,97 kB, 63 Mal heruntergeladen, zuletzt: )

    Hallo,


    nach Neuinstallation weiterhin keine Lösung des Problems. Daten werden von der Fritzbox geholt und ins Verzeichnis Data geschrieben. Es werden keine Daten in die solar.mdb aus der Neuinstallation geschrieben. (Mit eingespielter, gesicherter Datenbank bei vorherigem Versuch das gleiche Problem.) Datenbank permanent gesperrt. solar.ldb liegt permanent im Inst.-Verzeichnis.


    Was kann ich da tun?

    Hallo,


    solarview@fritzbox übernimmt ab 01.07 keine Daten mehr aus der Fritzbox. Die Webseite (nur lokal) zeigt entsprechend keine Daten mehr an, WR sind angeblich offline. solarview@fritzbox funktioniert ohne Probleme. Dienste auf Rechner sind (neu) gestartet, Speicher auf FB ist über Test als FTP erreichbar. In der der solar.mdb für 01.07. Fehler. log-Datei enthält ebenfalls für mich nicht interpretierbare Fehler. USB-Stick auf Fehler geprüft, formatiert, gesicherte Daten aufgespielt-- keine Abhilfe.
    Dateien habe ich angehängt. Danke schon mal für Hinweise, wie ich das wieder ans Laufen bekomme...