Beiträge von boa

    Guten Morgen zusammen,


    ich habe im Zählerschrank den einen eHZ (mtr0) und im Zählerschrank der PV-Anlage den andren (mtr1) und bekomme
    folgende Daten daraus:


    [Jan 18 23:44:48][mtr0] Got 7 new readings from meter:
    [Jan 18 23:44:48][mtr0] Reading: id=1-0:1.8.0*255/ObisItentifier:1-0:1.8.0*255 value=23095290.20 ts=1453157088830
    [Jan 18 23:44:48][mtr0] Reading: id=1-0:2.8.0*255/ObisItentifier:1-0:2.8.0*255 value=12604492.50 ts=1453157088831
    [Jan 18 23:44:48][mtr0] Reading: id=1-0:1.8.1*255/ObisItentifier:1-0:1.8.1*255 value=23095290.20 ts=1453157088831
    [Jan 18 23:44:48][mtr0] Reading: id=1-0:2.8.1*255/ObisItentifier:1-0:2.8.1*255 value=12604492.50 ts=1453157088831
    [Jan 18 23:44:48][mtr0] Reading: id=1-0:1.8.2*255/ObisItentifier:1-0:1.8.2*255 value=0.00 ts=1453157088831
    [Jan 18 23:44:48][mtr0] Reading: id=1-0:2.8.2*255/ObisItentifier:1-0:2.8.2*255 value=0.00 ts=1453157088831
    [Jan 18 23:44:48][mtr0] Reading: id=1-0:16.7.0*255/ObisItentifier:1-0:16.7.0*255 value=1396.00 ts=1453157088831
    [Jan 18 23:44:49][mtr1] Got 4 new readings from meter:
    [Jan 18 23:44:49][mtr1] Reading: id=1-0:2.8.0*255/ObisItentifier:1-0:2.8.0*255 value=24291719.40 ts=1453157089184
    [Jan 18 23:44:49][mtr1] Reading: id=1-0:2.8.1*255/ObisItentifier:1-0:2.8.1*255 value=24291719.40 ts=1453157089184
    [Jan 18 23:44:49][mtr1] Reading: id=1-0:2.8.2*255/ObisItentifier:1-0:2.8.2*255 value=0.00 ts=1453157089184
    [Jan 18 23:44:49][mtr1] Reading: id=1-0:16.7.0*255/ObisItentifier:1-0:16.7.0*255 value=0.00 ts=1453157089184


    Diese möchte ich nun korrekt im Middleware/Frontend darstellen.
    Orientiert habe ich mich hier: http://wiki.volkszaehler.org/howto/emh_pv-anlage


    mtr0 1.8.0 Haus Bezug (A+)--> el. Energie (Zählerstände), Auflösung 1000
    mtr0 2.8.0 Haus Lieferung (A-) --> el. Energie (Zählerstande), Auflösung 1000
    mtr0 16.7.0 aktuelle Leistung (vom Haus) --> el. Energie (Leistungswerte)


    mtr1 2.8.1 PV Erzeugung (A-) --> el. Energie (Zählerstände), Auflösung 1000
    mtr1 16.7.0 PV Leistung --> el. Energie (Leistungswerte)


    (Komisch find ich, das ich zwei mal 16.7.0 hab)


    Liege ich hier richtig, wenn ich folgende Berechnungen mache:


    Gesamtverbrauch = Bezug + Erzeugung - Lieferung
    Direktverbrauch (aus PV) = Erzeugung - Lieferung


    Sonnige Grüße
    Martin

    Hallo JAU und Danke für den Tip..... das hat erstmal weitergeholfen..... und das vzlogger-make läuft nun etwas länger, bis zu diesem Fehler:


    [ 32%] Built target vz
    make -f src/api/CMakeFiles/vz-api.dir/build.make src/api/CMakeFiles/vz-api.dir/depend
    make[2]: Entering directory `/opt/src/vzlogger'
    cd /opt/src/vzlogger && /usr/bin/cmake -E cmake_depends "Unix Makefiles" /opt/src/vzlogger /opt/src/vzlogger/src/api /opt/src/vzlogger /opt/src/vzlogger/src/api /opt/src/vzlogger/src/api/CMakeFiles/vz-api.dir/DependInfo.cmake --color=
    Scanning dependencies of target vz-api
    make[2]: Leaving directory `/opt/src/vzlogger'
    make -f src/api/CMakeFiles/vz-api.dir/build.make src/api/CMakeFiles/vz-api.dir/build
    make[2]: Entering directory `/opt/src/vzlogger'
    /usr/bin/cmake -E cmake_progress_report /opt/src/vzlogger/CMakeFiles 20
    [ 35%] Building CXX object src/api/CMakeFiles/vz-api.dir/Volkszaehler.cpp.o
    cd /opt/src/vzlogger/src/api && /usr/bin/c++ -DHAVE_CONFIG_HPP -W -Wall -Wextra -Werror -Wnon-virtual-dtor -Wno-system-headers -Winit-self -Wmissing-include-dirs -Wno-pragmas -Wredundant-decls -Wno-unused-parameter -std=c++11 -fpermissive -Wno-error=redundant-decls -I/usr/local/include -I/opt/src/vzlogger -I/opt/src/vzlogger/include -g3 -o CMakeFiles/vz-api.dir/Volkszaehler.cpp.o -c /opt/src/vzlogger/src/api/Volkszaehler.cpp
    /usr/bin/cmake -E cmake_progress_report /opt/src/vzlogger/CMakeFiles 21
    [ 38%] Building CXX object src/api/CMakeFiles/vz-api.dir/MySmartGrid.cpp.o
    cd /opt/src/vzlogger/src/api && /usr/bin/c++ -DHAVE_CONFIG_HPP -W -Wall -Wextra -Werror -Wnon-virtual-dtor -Wno-system-headers -Winit-self -Wmissing-include-dirs -Wno-pragmas -Wredundant-decls -Wno-unused-parameter -std=c++11 -fpermissive -Wno-error=redundant-decls -I/usr/local/include -I/opt/src/vzlogger -I/opt/src/vzlogger/include -g3 -o CMakeFiles/vz-api.dir/MySmartGrid.cpp.o -c /opt/src/vzlogger/src/api/MySmartGrid.cpp
    /opt/src/vzlogger/src/api/MySmartGrid.cpp:34:25: fatal error: openssl/ssl.h: Datei oder Verzeichnis nicht gefunden
    compilation terminated.
    make[2]: *** [src/api/CMakeFiles/vz-api.dir/MySmartGrid.cpp.o] Fehler 1
    make[2]: Leaving directory `/opt/src/vzlogger'
    make[1]: *** [src/api/CMakeFiles/vz-api.dir/all] Fehler 2
    make[1]: Leaving directory `/opt/src/vzlogger'
    make: *** [all] Fehler 2


    --> fatal error: openssl/ssl.h: Datei oder Verzeichnis nicht gefunden --> openssl habe ich aber installiert..... stimmt hier ein Verweis oder sowas nicht?


    Sonnige Grüße
    Martin

    Hallo zusammen,


    ich brauche einen vzlogger auf einer NSLU2, da ich in einem entfernten Zählerkasten die Stände erfassen möchte.


    Wenn ich mir über git den vzlogger ziehe und dort die install.sh starte, dann werden die libsml und die libjson gleich mitinstalliert.
    Kommts dann als letztes zur Installation des vzloggers kommt, wird mit folgender Meldung abgebrochen:


    building and installing vzlogger


    building vzlogger
    Compiling for target ''
    -- using gcc compiler GNU
    -- checking if -Wno-ignored-qualifiers works
    -- FindSml check
    -- checking for module 'sml>=0.9'
    -- package 'sml>=0.9' not found
    -- SML_HOME env is not set, setting it to /usr/local
    -- Looking for sml in /usr/local
    -- FindMBus check
    -- checking for module 'libmbus>=0.8.0'
    -- found libmbus, version 0.8.0
    -- Looking for libmbus in /usr/local/include
    libmbus found: '/usr/local/include'
    -- FindMicrohttpd check
    -- checking for module 'microhttpd>=0.9'
    -- package 'microhttpd>=0.9' not found
    -- MICROHTTPD_HOME env is not set, setting it to /usr/local
    -- Looking for microhttpd in /usr/local
    -- FindJson check
    -- JSON_HOME env is not set, setting it to /usr/local
    -- Looking for json in /usr/local
    Json-c search: '/usr/local/include;/usr/local/include;/usr/local/include;/usr/include'
    Json-c found: '/usr/local/include'
    -- FindGnuTls check
    -- ==> ''
    -- GNUTLS_HOME env is not set, setting it to /usr/local
    -- Looking for gnutls in /usr/local
    ==> GNUTLS_LIBRARIES='/usr/lib/arm-linux-gnueabi/libgnutls.a;/lib/arm-linux-gnueabi/libgcrypt.a;/usr/lib/arm-linux-gnueabi/libgpg-error.a;/usr/lib/arm-linux-gnueabi/libtasn1.a;/usr/lib/arm-linux-gnueabi/libz.a;-lp11-kit;-lsasl2;/lib/arm-linux-gnueabi/libgcrypt.a'
    CMake Warning at CMakeLists.txt:171 (message):
    Disabled googlemock/-test tests due to GCC version < 4.8!




    ***** Configuration parameters *****
    prefix: /usr/local
    json: -L/usr/local/lib/libjson-c.a;-lrt -I/usr/local/include
    sml: -L/usr/lib/libsml.a;-lrt -I/usr/include
    microhttpd: -L/usr/lib/arm-linux-gnueabi/libmicrohttpd.a;-lrt -I/usr/include
    libmbus: -L/usr/local/lib/libmbus.so;-lm -I/usr/local/include
    -- Configuring done
    -- Generating done
    -- Build files have been written to: /opt/src/vzlogger
    /usr/bin/cmake -H/opt/src/vzlogger -B/opt/src/vzlogger --check-build-system CMakeFiles/Makefile.cmake 0
    /usr/bin/cmake -E cmake_progress_start /opt/src/vzlogger/CMakeFiles /opt/src/vzlogger/CMakeFiles/progress.marks
    make -f CMakeFiles/Makefile2 all
    make[1]: Entering directory `/opt/src/vzlogger'
    make -f src/CMakeFiles/vz.dir/build.make src/CMakeFiles/vz.dir/depend
    make[2]: Entering directory `/opt/src/vzlogger'
    cd /opt/src/vzlogger && /usr/bin/cmake -E cmake_depends "Unix Makefiles" /opt/src/vzlogger /opt/src/vzlogger/src /opt/src/vzlogger /opt/src/vzlogger/src /opt/src/vzlogger/src/CMakeFiles/vz.dir/DependInfo.cmake --color=
    make[2]: Leaving directory `/opt/src/vzlogger'
    make -f src/CMakeFiles/vz.dir/build.make src/CMakeFiles/vz.dir/build
    make[2]: Entering directory `/opt/src/vzlogger'
    /usr/bin/cmake -E cmake_progress_report /opt/src/vzlogger/CMakeFiles 10
    [ 3%] Building CXX object src/CMakeFiles/vz.dir/Channel.cpp.o
    cd /opt/src/vzlogger/src && /usr/bin/c++ -DHAVE_CONFIG_HPP -W -Wall -Wextra -Werror -Wnon-virtual-dtor -Wno-system-headers -Winit-self -Wmissing-include-dirs -Wno-pragmas -Wredundant-decls -Wno-unused-parameter -std=c++11 -fpermissive -Wno-error=redundant-decls -I/usr/local/include -I/opt/src/vzlogger -I/opt/src/vzlogger/include -g3 -o CMakeFiles/vz.dir/Channel.cpp.o -c /opt/src/vzlogger/src/Channel.cpp
    cc1plus: error: unrecognized command line option ‘-std=c++11’
    make[2]: *** [src/CMakeFiles/vz.dir/Channel.cpp.o] Fehler 1
    make[2]: Leaving directory `/opt/src/vzlogger'
    make[1]: *** [src/CMakeFiles/vz.dir/all] Fehler 2
    make[1]: Leaving directory `/opt/src/vzlogger'
    make: *** [all] Fehler 2


    libjson und libmbus werden gefunden, jedoch "modul sml" nicht (obwohl es installiert wurde) und den microhttpd (der auch auf dem Rechner ist)


    cc1plus: error: unrecognized command line option ‘-std=c++11’ (hängt das mit der gcc-version zusammen?)


    Vielleicht kommt das ja jemand bekannt vor?


    Nächtliche Grüße
    Martin

    Danke Udo für die schnelle Antwort.


    Ich habe das Problem rausgefunden! Ich hatte das zwar das fertige Image genutzt, jedoch hätte ich nach dem Schreiben
    auf die SD-Karte mittels raspi-config --> expand-filesystem das Ganze für meine 8GB Karte aufbohren sollen.
    Ohne dies war das vorhandene Filesystem sofort auf 100% voll.


    Bis zum nächsten mal
    Martin

    Hallo zusammen,


    ich habe meinen Volkszähler auf RaspberryPi-Basis nach diese Anleitung angefangen aufzusetzen:


    http://wiki.volkszaehler.org//…rect=1#aufbau_des_loggers


    Ich hab sogar den USB-IR-Lesekopf von Udo mit dem vzlogger zum Laufen gebracht.


    Nur wenn ich jetzt einen Kanal anlegen möchte, bekomm immer folgende Meldung:


    undefined is not an object (evaluating 'a.indexOf')


    Und übers phyadmin webfrontend kann ich mich mit den in der Anleitung gegebenen Passwörtern auch nicht einloggen.


    Ist schon mal jemand anders auf diese Problematik gestoßen und hat evtl. ne Lösung?


    Besten Dank schon mal im Voraus für Euer Unterstützung.


    Herzliche Grüße
    Martin