Beiträge von fesojski

    Hallo all,
    nun hat sich die Mühe mit Eurer Hilfe gelohnt. Unglaublich, dass ein Komma (,) dies alles verursacht hat.
    Die Daten werden nun im Frontend angezeigt, allerdings nicht richtig. Z.B. 1.64 GWh statt ca. 1 kWh.
    Mein Hager eHZ sendet 10.000 Impulse pro kWh.
    An welcher Schraube muss nun noch gedreht werden?


    Mi 5. Apr 2017 18:23 - Mi 5. Apr 2017 19:23 Export... 
    Kanäle Titel Typ Min. Max. ∅ aktuell Verbrauch Aktion  1.8.0 El. Energie (S0-Impulse) 1.21 GW 1.32 GW 1.26 GW 1.26 GW 1.31 GWh  2.8.0 El. Energie (S0-Impulse) 1.52 GW 1.66 GW 1.59 GW 1.59 GW 1.64 GWh

    Viele Grüße
    Josef

    Danke für Eure Hilfe.
    Das fehlende Komma habe ich tatsächlich übersehen. Wurde eingefügt.
    Fehler war weg.


    pi@raspberrypi:~ $ sudo systemctl disable vzlogger
    Removed symlink /etc/systemd/system/multi-user.target.wants/vzlogger.service.


    Opto-Kopf wurde mit Kabel unten richtig angebracht.
    Werde heute Abend alles überprüfen.

    Hallo Frank,
    hier die Informationen:
    pi@raspberrypi:~ $ systemctl status vzlogger
    ● vzlogger.service - vzlogger
    Loaded: loaded (/etc/systemd/system/vzlogger.service; enabled)
    Active: failed (Result: exit-code) since Wed 2017-04-05 11:11:07 CEST; 5h 28min ago
    Process: 26171 ExecStart=/usr/local/bin/vzlogger -c /etc/vzlogger.conf (code=exited, status=1/FAILURE


    File: /etc/vzlogger.conf
    {
    "retry": 0,
    "daemon": true,
    "verbosity": 15,
    "log": "/var/log/vzlogger.log",
    "push": [],
    "local": {
    "enabled": false,
    "port": 8080,
    "index": false,
    "timeout": 0,
    "buffer": 0
    },
    "meters": [
    {
    "enabled": true,
    "allowskip": false,
    "interval": -1,
    "aggtime": 60,
    "aggfixedinterval": false,
    "channels": [
    {
    "uuid": "8ce53dd0-1919-11e7-af53-3f8bba7cd727",
    "identifier": "1-0:1.8.0",
    "api": "volkszaehler",
    "middleware": "http://localhost/middleware.php",
    "aggmode": "max",
    "duplicates": 0
    },
    {
    "uuid": "b84532a0-1919-11e7-b16c-836ed0522349",
    "identifier": "1-0:2.8.0",
    "api": "volkszaehler",
    "middleware": "http://localhost/middleware.php",
    "aggmode": "max",
    "duplicates": 0
    }
    ],
    "protocol": "sml"
    "device": "/dev/ttyUSB0",
    "pullseq": "",
    "baudrate": 9600,
    "parity": "8n1"
    }
    ]
    }


    Gruß
    Josef

    Liebes Forum,
    nun habe ich den USB-Schreib-Lesekopf von Udo installiert.
    Sind die empfangenen Daten mit "xxd </dev/ttyUSB0" nun so richtig?
    Letzte Spalte jetzt ohne Hieroglyphen.


    0004240: 21b5 0177 0701 0002 0802 ff01 0162 1e52 !..w.........b.R
    0004250: ff53 2710 0177 0701 0010 0700 ff01 0162 .S'..w.........b
    0004260: 1b52 0053 f13a 0177 0781 81c7 8205 ff01 .R.S.:.w........
    0004270: 0101 0183 024f d1b4 74a6 928a e175 2eac .....O..t....u..
    0004280: bd88 3e32 20b1 13e0 d8cc b86b 0600 8c9e ..>2 ......k....
    0004290: 0629 d69b 2412 89ae 2516 a4a2 4447 826a .)..$...%...DG.j
    00042a0: f96e ec3a 1f01 0101 6310 c400 7609 0000 .n.:....c...v...
    00042b0: 0000 0f15 19e1 6201 6200 7263 0201 7101 ......b.b.rc..q.
    ^C
    Die folgenden Fehler tauchen nun auf: (Habe sie auch schon früher gesehen)


    pi@raspberrypi:~ $ sudo vzlogger
    [Apr 05 15:38:19][main] vzlogger v0.6.0 based on heads/master-0-g1484f9aad1 from Mon, 22 Aug 2016 22:32:51 +0200 started.
    [Apr 05 15:38:19] Error in /etc/vzlogger.conf:40 object value separator ',' expected at offset 6
    [Apr 05 15:38:19] Failed to parse configuration due to: Parse configuaration failed.


    Ich nehme an, dass der erste Fehler in der Zeile 40 steckt ["device": "/dev/ttyUSB0",] , kann aber mit Offset 6 nichts anfangen.
    Die vzlogger.conf habe ich von Frank übernommen und mit Nano modifiziert.


    Gruß
    Josef

    Hallo Frank,
    standhaft ignorieren ist ein wenig hart ausgedrückt, denn Deine Beiträge schätze ich sehr.
    Leider weiß ich nicht, wie ich ein "Invertiertes Signal" prüfen kann, Auf dem IR-Kopf gibt es keine Angaben, weder Hersteller noch techn. Daten.
    Wenn ich nicht weiterkomme, werde ich am Montag zur Firma EMH nach Mannheim fahren, denn getestet wurde der Sensor angeblich mit eHZ-Zähler und EMH.
    Angefreundet habe ich mich mit WinSCP, da ich nun die gewohnte Datei-Struktur sehen kann. Bei der Umstellung von AMA0 auf USB0 mit Nano sehe ich noch in WinSCP nach dem Einloggen AMA0 in der vzlogger.conf, mit Datum von gestern, was ja auch stimmt aber aktuell falsch ist. Wie kann ich die aktuellen Daten in WinSCP sehen?


    Viele Grüße
    Josef

    Liebes Forum,
    nun nach weiteren Lernerfolgen und Umbau des IR-Opto-Kopfes auf USB mit USB to TTL gibt es noch keinen Erfolg zu vermelden.


    pi@raspberrypi:~ $ cat /var/log/vzlogger.log
    [Mar 24 16:19:37][main] vzlogger v0.6.0 based on heads/master-0-g1484f9aad1 from Mon, 22 Aug 2016 22:32:51 +0200 started.
    [Mar 24 16:19:37][push] Ignoring push entry due to empty array or duplicate section
    [Mar 24 16:19:37][main] log level is 0
    [Mar 24 16:26:53][main] vzlogger v0.6.0 based on heads/master-0-g1484f9aad1 from Mon, 22 Aug 2016 22:32:51 +0200 started.
    [Mar 24 16:26:53][push] Ignoring push entry due to empty array or duplicate section
    [Mar 24 16:26:53][main] log level is 0
    [Mar 24 16:46:41][main] vzlogger v0.6.0 based on heads/master-0-g1484f9aad1 from Mon, 22 Aug 2016 22:32:51 +0200 started.
    [Mar 24 16:46:41][push] Ignoring push entry due to empty array or duplicate section
    [Mar 24 16:46:41][main] log level is 0


    Mit:
    pi@raspberrypi:~ $ cat /dev/ttyUSB0 | od -tx1
    0000000 27 00 23 4e 7c 7f 44 7f 7a 3e 0b 5f 5c 7f 7c 15
    0000020 08 0a 1b 7c 7f 00 27 3d 00 00 23 27 7f 4d 3e 32
    0000040 16 79 21 44 7c 3f 3f 1c 1f 7e 00 7f 7f 7f 7f 1f
    0000060 0b 5f 5c 7f 44 7c 7f 00 00 00 7b 00 7f 7f 7f 7f
    0000100 7a 3e 0b 5f 5c 7f 7c 15 08 0a 1b 7f 44 7c 7f 00
    0000120 7f 0f 00 00 27 17 7f 27 38 2b 00 55 7b 01 1e 5b
    0000140 7f 44 7c 7f 00 7f 0f 7f 00 7f 7f 27 38 2b 00 55
    0000160 7b 01 0c 63 7f 44 7c 7f 00 7f 0f 3f 00 7f 7f 27
    0000200 38 2b 00 56 6c 07 7f 44 7c 7f 00 3f 0f 00 00 27
    Aber:
    pi@raspberrypi:~ $ xxd </dev/ttyUSB0
    0000000: 7272 7272 7f7f 7f7f 227b 0000 0000 3c03 rrrr...."{....<.
    0000010: 6a05 277f 2700 234e 7f7f 227f 7f7b 0000 j.'.'.#N.."..{..
    0000020: 0000 1f02 4e03 7a3e 0b5f 5c7f 7c15 080a ....N.z>._\.|...
    0000030: 1b7f 7f4e 362f 0022 7b00 0000 003c 036a ...N6/."{....<.j
    0000040: 2b27 7f27 0023 4e7c 7f44 7f7a 3e0b 5f5c +'.'.#N|.D.z>._\
    0000050: 7f7c 1508 0a1b 7c7f 0027 3d00 0023 277f .|....|..'=..#'.
    0000060: 4d3e 3257 5521 447c 3f3f 1c1f 7e00 7f7f M>2WU!D|??..~...
    0000070: 7f7f 1f0b 5f5c 7f44 7c7f 0000 007b 007f ...._\.D|....{..


    Kann daraus der Fehler der fehlenden log-Datei näher spezifiziert werden?
    Viel Dank im Voraus.
    jo

    Hallo Frank,
    zunächst recht herzlichen Dank für Deine wertvollen Hilfen.
    Gibt es wieder den IR-Kopf von Udo, ich würde mit diesem Sensor weiter fortfahren.
    Doch noch einen Versuch mit USB to TTL möchte ich noch starten.
    Dazu noch eine Frage: wie bekomme ich in eleganter Weise Deine vzlogger.txt in den RPI?


    Nochmals vielen Dank und mit freundlichen Grüßen


    Josef