Beiträge von Solaropa

    ESP32 WLAN ein: Wifi 1 auf der Konsole

    ESP32 WLAN: aus: Wifi 0 auf der Konsole


    WT32-ETH01 (mit WLan und LAN)

    WLAN wie oben

    WT32-ETH01 LAN ein: Ethernet 1

    WT32-ETH01 LAN aus: Ethernet 0

    Auf der Hauptseite eingeben: Console dann Consoles

    Hallo Manfred,

    kurz vor Dienstschluss gestern von Solarview installierte ich die neue steca-fb". Es wurde der gesamte Monat Oktober in die Grafiken übertragen, auch der Tagesertrag war plausibel. Es sieht sehr gut aus.

    Vielen Dank für Deine Unterstützung, jetzt kann es mit einem 64 bit OS auf dem Raspberry Pi weitergehen.

    Eine Frage habe ich noch: Wo kommt dieser Eintrag her:

    Code
    !=7390

    Hallo Manfred,

    ich lasse seit dem Morgen debug_steca laufen. "unplausibel" habe ich nicht gefunden. Der Tagesertrag bleibt aktuell bei 1 kWh stehen, der WR hat aktuell mehr als 3 kWh produziert. steca_debug hat schon 5,5 MB. Der letzte Zugriff auf month.dat war gestern 20.00 Uhr, aber eben null Ertrag.

    Code
    CRC Calc (len: 64): 4d 4d 91 91
    RequestOK
    78
    !=7390
    KMT: 224.938004

    KMT entspricht dem aktuellen Monatsertrag. Wo allerdings !=7390 herkommt, weis ich nicht. Diese FB habe ich schon seit Jahren nicht mehr.

    Und dann gibt es das auch noch:

    Code
    KYR plausibel
    KMT plausibel
    KDY plausibel

    Sieht für mich auch nicht nach Fehler aus.

    Das ist aktuell mein Betriebssystem:

    Code
    Linux Pi4 6.1.0-rpi4-rpi-v8 #1 SMP PREEMPT Debian 1:6.1.54-1+rpt2 (2023-10-05) a                    arch64 GNU/Linux

    Und das dürfte mein OS sein:

    Raspberry Pi OS with desktop

    • Release date: October 10th 2023
    • System: 64-bit
    • Kernel version: 6.1
    • Debian version: 12 (bookworm)
    • Size: 1,093MB

    Und das habe ich gerade auch gefunden:

    Code
    CRC Calc (len: 20): a6 a6 ac ac
    RequestOK
    78
    !=7390
    KDY: 2.823000

    Auch der Tagesertrag sieht gut aus.

    Hallo Manfred,

    hier ist nun das heutige Tagesergebnis.

    Was auffällt ist, dass der Tageswert ohne Nachkomma angezeigt wird. Der WR brachte heute 1,8 kWh.

    Der Monatswert wird nicht aktualisiert und steht weiterhin bei null.

    Der Jahreswert und der Gesamtertrag über die Laufzeit werden jedoch aktualisiert.

    In der month.dat steht für Oktober ebenfalls null.

    Hallo Manfred,

    es scheint noch ein Problem mit der Mathematik zu geben.

    Seit Stunden steht der Tagesertrag bei 1 kWh, die aktuelle Leistung des WR scheint im Diagramm zu stimmen.

    Der WR bringt heute 3,2 kWh, abzüglich der verpassten Leistung am Morgen. Auch steht der Monatswert auf 0. Es scheint also noch zu klemmen. Ich habe mehrere Neustarts gemacht, brachte aber keine Besserung.

    Noch eine Grafik zur Veranschaulichung des Sachverhaltes:

    Hallo Gexle,

    ich vermute, du hast einen digitalen EVU Zähler. Dieser misst in 2 Richtungen:

    - bezogene Energie (dein eigener Verbrauch )

    - gelieferte Energie (Energie kommt von der Solaranlage)

    Nun saldiert der Zähler:

    bezogene Energie - gelieferte Energie ergibt eine gelieferte kWh

    Wenn du Volleinspeiser bist, dann muss der Solarenergiezähler parallel (!!!) zum EVU-Zähler angechlossen sein (geht nur über Elektriker mit Zulassung vom jeweiligen Energieversorger).

    Im Klartext: du brauchst im Zählerschrank 2 Zählerplätze und 2 Zähler für getrennte Stromkreisläufe.

    Hallo rudis,

    in HA nutzt du sicherlich die Entitäten.

    Diese kannst du in der config.yaml konfigurieren. Bei mir steht z. B. für den Tagesertrag folgendes in selbiger Datei:


    - name: "Tagesertrag SV"

    unique_id: pv1

    state_topic: "solarview/WR1/KDY"

    unit_of_measurement: "kWh"

    device_class: energy

    state_class: total_increasing


    "total_increasing" sorgt dafür, dass der Wert um Mitternacht genullt wird. Auf korrekte Schreibweise achten, das Forum gibt das nicht richtig wieder!

    Hallo Manfred,

    mit der neuen Version läuft es nun. Ich sehe nun den Anfang der Kurven.

    Kleiner Hinweis: Vielleicht kannst Du auch Datum und Dateiversion im Downloadbereich anpassen.

    Vielen herzlichen Dank, das ist ein Superservice von Dir.


    Kleiner Nachtrag: Ich nutze Solarview schon seit 2009 (das war meine älteste zu findende Dateiversion), also schon 14 Jahre. Und das mit all den Problemchen, die es in den ersten Jahren gab.

    Du hast eigentlich ein "Goldenes Byte" verdient.

    Hallo Manfred,

    lange habe ich hier im Forum nichts mehr von mir hören lassen, weil SV perfekt lief.

    Nun habe ich ebenfalls auf Raspi 4 64 bit umgestellt. Das vorhandene Programmpaket kopiert und ein Update auf die aktuelle Version SV mit RPI64 gemacht. Ich habe selbiges Problem, wie im obigen Post beschrieben. Hier mal einige Bildchen:

    Prozesse:

    Fehlermeldung:

    Ich denke, es wird nach Umstellung auf 64 bit weitere WR betreffen.