Beiträge von ReRo

    Hallo,


    danke für die neue Version. Habe sie gerade installiert. Was ich schonmal sagen kann: die D0-Werte werden wieder geliefert und der DPAC-Wert reagiert jetzt auch schnell, d. h. keine Mittelwert-Bildung mehr. Ob es noch Aussetzer in PAC-Wert gibt, werde ich dann morgen im Laufe des Tages beobachten und melde mich dann wieder.


    Viele Grüße
    René

    Hallo Manfred,


    danke für die Bereitstellung der Testversion. Leider besteht das Problem damit bei mir weiterhin unverändert. Soll ich noch einmal ein Debug-Log erzeugen und bereitstellen?

    Außerdem werden mit dieser Version keine D0-Werte mehr über MQTT geliefert (bei unveränderter Konfiguration). Das ist schade, da ich diese auch benötige.

    In der letzten Version wurden übrigens anscheinend die DPAC-Werte immer noch über 5 Minuten gemittelt. Wäre es evtl. möglich, auch dieser Werte ohne Mittelwert-Bildung bereitzustellen?


    Danke

    René

    Hallo dj3110,

    GKYR ist auf beiden screenshots gleich, die anderen werden regelmässig auf null gesetzt.

    GKT0 & BKT0 werden zudem alternierend mit unterschiedlichen werten pubished. 42115 & 11466 stimmen, die beiden anderen werte bei den nullwerten leider nicht.

    ...

    MQTTWR=WR0,WR1

    Hast du denn wirklich zwei Wechselrichter? Hast du mal ausprobiert, was passiert, wenn du hier nur einen Wechselrichter einträgst?

    zudem habe ich, wenn MQTT publishing läuft, sonderbare einbrüche in den loggerwerten, siehe ebenfalls angefügten screenshot

    was läuft hier falsch?

    Tja, das Problem habe ich auch, wenn auch bei anderen Werten, siehe mein vorheriger Beitrag. Manfred hat dazu ja schon etwas geschrieben bzgl. Debug-Modus. Heute lief bei mir aber alles durch ohne Einbrüche durch. Ich werde den Debug-Modus mal aktivieren und schauen, was morgen passiert.

    zudem noch eine frage:
    was bedeutet TKK in der zeichenkette MQTTPublishVals? diese steht in der bedienungsanleitung. ich habe sie herausgenommen in meinem solarview_cfg.txt file

    Laut Doku steht TKK für die Wechselrichter-Temperatur.


    Viele Grüße
    René

    Hallo Manfred,

    super, danke, das ging ja schnell mit der neuen Version! Ich habe sie gerade getestet und jetzt werden die Werte korrekt geliefert.
    Allerdings habe ich gestern und heute ein neues Problem festgestellt. In unregelmäßigen Abständen zeigt Solarview ein AC-Leistung (PAC) von 0 an, obwohl die Anlage gerade gut läuft. Und das sowohl über MQTT als auch über TCP als auch in der Weboberfläche. Alle anderen Werte sind ok und die D0-Werte vom Zähler zeigen auch, dass weiterhin Strom erzeugt wird. Hier mal eine Beispielgrafik von gestern:

    Man sieht drei Einbrüche der PAC auf 0, obwohl die DC-Leistungen der beiden Generatoren "normal" weiterlaufen und auch der Ertrag weiter anwächst. Ich habe es heute einmal ausprobiert und in solch einer Phase Solarview neugestartet, das brachte aber keine Besserung. Ich habe es dann nochmal gestoppt und die alte Version (hatte das gesamte Verzeichnis vor dem Update kopiert) gestartet, die hat sofort die richtige Leistung angezeigt. Als ich dann wieder die neue Version gestartet habe, stand da wieder 0. Das lässt mich vermuten, dass es an der neuen Version (tritt ab 2.25 auf) liegt und nicht z. B. an meiner Konfiguration oder am Wechselrichter (der in seiner Weboberfläche die Leistung auch korrekt anzeigt). Kann man das noch irgendwie debuggen, indem man die Rohdaten vom Wechselrichter irgenwo ausgeben lässt? Ich habe einen SMA STP 10.0, den ich über Speedwire abfrage und ein SMA Energy Meter, der die Daten über Multicast liefert. Hier meine start.sh:

    Wer hat eine Idee, was da schief geht?


    Danke!

    René

    Hallo Manfred,

    der Eintrag lautet:

    Code
    1. MQTTPublishVals=PAC,UDC,UDCB,IDC,IDCB,UL1,UL2,UL3,IL1,IL2,IL3,KDY,KMT,KYR,KT0,TKK,BKDY,BKMT,BKYR,BKT0,GKDY,GKMT,GKYR,GKT0,DPAC

    Vielen Dank für deine Bemühungen!

    Die neue Version habe ich installiert, das Probelm mit BKYR besteht aber weiterhin. PAC ist momentan 0, werde ich morgen mal sehen, wie sich die Werte verhalten. Bei DPAC habe ich aber den Eindruck, dass immer noch 5-Minuten-Mittelwerte verwendet werden. Wie kann ich denn zweifelsfrei prüfen, welche Version ich installiert habe? Auf der Tagesseite steht unten immer noch "Überwacht mit SolarView für Linux V 2.25 mit Plot Version 2.25". Ich hätte da jetzt 2.25a erwartet? Für das Update habe ich svfbinst-fb ausgeführt, das lief auch ohne Fehlermeldung durch.


    Danke!

    René

    Hallo Manfred,


    ja, "überschrieben" war vielleicht nicht der richtige Ausdruck. Was passiert ist, dass für den Wert D0/BKYR immer zwei Werte direkt hintereinander übermittelt werden, erst der korrekte Wert und dann der falsche (und der falsche ist m. E. der, der eigentlich nach D0/GKYR gehört - dieser wird dafür aber gar nicht übermittelt).:

    Dumm ist halt, dass der falsche Wert zuletzt übermittelt wird, so dass er dann z. B. in FHEM immer stehen bleibt, bis ca. 12 Sekunden später wieder der richtige und dann sofort wieder der falsche Wert kommt.


    Die zwei Werte (PIN und PDC), die nicht übermittelt werden, lassen sich sicherlich verschmerzen. Ich dachte nur, wenn es schon konfigurierbar ist, könnte man auch aus allen Werten auswählen.


    Danke

    René

    Hallo,

    kann es eigentlich sein, dass die aktuellen Werte (wie PAC und DPAC), die per MQTT geliefert werden, immer über ein 5-Minuten-Intervall gemittelt werden? Ich beobachte, dass sich Änderungen immer nur sehr verzögert auf die Werte auswirken. Immer zu einer 5-Minuten-Uhrzeit (xx:00, xx:05, xx:10, xx:15, xx:20 Uhr usw.) gibt es dann plötzlich einen Sprung und danach wieder über 5 Minuten nur eine sehr langsame Änderung.

    Super Sache, mit MQTT kann man die Werte perfekt in Tools zur Heimautomatisierung übernehmen (z. B. FHEM). Man muss nicht mehr wie bisher per Telnet pollen sondern bekommt die Werte schön per MQTT in Echtzeit gepushed. Gefällt mir gut!

    Zwei Sachen sind mir aber noch aufgefallen:

    1. Der Wert für "BKYR" stimmt bei mir nicht. Das scheint daran zu liegen, dass dort immer erst einmal der korrekte Wert geliefert wird. Dieser wird aber sofort wieder mit dem falschen Wert überschrieben. Das scheint der Wert für "GKYR" zu sein. Dieser fehlt dafür. Evtl. wurde hier bei der Implementierung etwas vertauscht?
    2. Auch, wenn ich sie zusätzlich in MQTTPublishVals aufnehme, bekommt ich die Werte für PDC und PIN nicht geliefert (obwohl diese unter "Legende / Werte" aufgeführt sind).