Beiträge von Kurtow187

    Hallo Ewilli,


    Ich frage die Pylontech mit einem ESP32 (Arduino) ab.

    Kann man diese Verbindung dann im Dauerbetrieb laufen lassen und damit z.b. jede Sekunde den SOC abfragen?


    Ja kann man!

    Das schnellste, was ich bis her geschafft habe, war ca. 1 Sekunde.


    Ich frage aber nur in einem Intervall von ca. 3 Sekunden ab, weil ich festgestellt habe, dass (neue) Werte intern auch nicht schneller aktualisiert werden.

    Man muss bedenken, dass die Batterie bei bestimmten Konsolenbefehlen immer einen ganzen Rutsch an Daten

    rüberschiebt. (z. B. mit "getpwr")


    (Ich hab noch nichts mit RS485 oder CAN an der Batterie gemacht, vielleicht geht es da schneller, da man gezielt

    einen bestimmten Wert abrufen kann).


    Grüße Kurtow187

    Probier doch mal mit 115200 Baud ein paarmal nur


    0x0D; das ist das Zeichen 'CR' (13)

    0x0A);das ist das Zeichen 'LF' (10)



    Also


    0x0D,0X0A 2 Sekunden Pause


    0x0D,0X0A 2 Sekunden Pause


    0x0D,0X0A 2 Sekunden Pause


    ....


    Bei mir antwortet die Batterie nach 4 bis 5 mal mit 'pylon debug' .


    Dann kannst Du loslegen.


    z. B. mit dem Befehl 'getpwr' + CR

    Ich habe von Greenakku das originale Battery View Programm von Pylontech zugeschickt bekommen und damit versuche ich es.


    Wenn Du das originale "Batterie View" hast, brauchst Du nur unter "Connect" die richtige Com-Schnittstelle auswählen und die Baudrate auf 115200 setzen. Dann muss das (an der Konsolenschnitstelle) funktionieren.


    (Ich weiß allerdings nicht, ob das BIOS-anbhängig sein könnte. Ich habe Version b63)



    Prüf mal das Kabel.


    Masse (GND) angeschlossen?


    RX / TX vertauscht ?


    Grüße


    Kurtow187

    Hallo Emhopa,


    Alles klar, das habe ich verstanden!


    Ich will jetzt aber doch mal probieren einen 'alten' Aeconversion mit Batteriestrom laufen zu lassen.


    Ich habe eine ziemlich kräftige Teilinsel (Inselphase) im Haus.

    Da ich eine (Baumarkt)-Splitklimaanlage habe, könnte die im Sommer gut kühlen und in der Übergangszeit heizen.

    Leider schaffen es meine Inselwechselrichter nicht, den Anlaufstrom aufzubringen.

    Jetzt schaue ich mal, ob ich nicht doch die WP am Netz laufen lasse, und bei Gelegenheit Inselstrom 'dazumische'.


    (ich habe das schon mit Ansteuerung über RS485 gemacht (auch über nen Arduino), aber Deine Hardwarelösung gefällt mir besser.


    Grüße


    Kurtow187

    Hallo Ewilli,


    Ich frage die Pylontech mit einem ESP32 (Arduino) ab.


    Ich habe eine Baudrate von 115200 eingestellt und sende zur Eröffnung der Übertragung
    in einer Schleife bis zu 10 mal die Bytes (etwa alle 2 Sekunden)


    0x0D, 0x0A an den Konsolenport.


    beim 3.ten ode 4.ten Senden antwortet die Pylon mit
    "pylon_debug>"
    Ab jetzt kannst Du Befehle an die Batterie senden und bekommst die entsprechenden Antwortstrings.
    Die Fuckelei mit 1200 Baud usw. ist (zumindest bei der Firmware meiner Batterie) nicht erforderlich.


    Grüße Kurtow187


    Zitat von pezibaer

    Wenn wir da schon mal das Thema haben.. Was mich schon lange beschäftigt aber ich dann aufgegeben hab war das ich ewig gesucht hab nach einer Splitklima die ich Leistungstechnisch per Modubus, Mbus, Mqtt oder was auch ansteuern kann. Bei großen LWP hab ichs gefunden. Nur bei Splitklimas vermisse ich durch die Bank die Möglichkeit.


    Also mich würde das auch interessieren.


    Ich habe auch eine Insel, und möchte gern den Überschuss in der Übergangszeit mit ner Wärmepumpe verheizen.
    Aber auch nur z. Beispiel 260 Watt, wenn nicht mehr da ist.
    Mir wäre Alles egal von ModBus bis 0-10 Volt.


    Ich hab da aber noch nichts Passendes (Kleineres) gefunden, wo man aus dem Prospekt sicher rauslesen kann,
    dass eine Leistungsregelung möglich ist.


    Grüße Kurtow187

    Zitat von Toni1965


    Hallo, ob der durch den WR bewirkte 100Hz Rippel bei diesem Ladezustand des Ladereglers einen negativen oder nur pulsierenden Batteriestrom erzeugt kannst du nur mit einem Osci messen. Die Frage stellt sich ja ob der Laderegler schnell genug (100Hz) die Spannung stabil halten kann, ich denke aber nicht. Abhilfe für das Aliasing Problem (40mV) könnte ein großer Kondensator nahe dem WR und eine Drossel in der Batterieleitung schaffen.
    Grüße Toni.


    Hallo Toni1965,


    Genau das habe ich inzwischen gemacht.


    Ergebnisse siehe hier! https://www.photovoltaikforum.…rom-drossel--t124743.html


    Das Aliasing Problem (40mV) ist damit weg.


    Grüße
    Kurtow187