Probleme mit SunnyDataControl (SDC) und autom. Datenabfrage

  • Hallo Datenlog-Spezies,
    meine Ertragsdaten werden auf meinen SunnyBeam gefunkt und von dort geht's via USB auf meinen PC und von dort ins Web.


    Auf meinem PC habe ich in der "Autostart"-Gruppe das Programm "SunnyDataControl" + das Program "SunnyReport".
    Die Programme werden nach Einschalten des PCs auch korrekt gestartet.


    In den Einstellungen habe ich einen 1/2 stündigen Zyklus der Datenabfrage (SDC) bzw. des Reportaufbaus+FTP (SunnyReport) konfiguriert.


    SunnyReport arbeitet auch korrekt, nur mit dem SDC habe ich ein kleines Problem:
    Die SDC-Daten werden erst dann automatisch (bei mir dann alle 30 min) auf die Platte geschrieben, nachdem ich 1x per Hand die Tagesdaten + die aktuellen Messwertdaten abgerufen habe.
    Wird das Programm also NUR automatisch gestartet, werden definitiv keine(!) Daten auf die Festplatte (Verzeichnis ../plants/...) geschrieben.


    Also, wer verrät mir, was ich so alles falsch gemacht habe?


    Gruß, Markus.

    Einmal editiert, zuletzt von MK ()

  • Hallo MK,


    also ich starte das genauso, wie du und es funktioniert. Allerdings musst du bei dir erst eine halbe Stunde warten, bis die ersten Daten geschrieben werden. Ich habe 15min eingestellt, da dauerts dann 15min bis SunnyReport die ersten Daten bekommt.


    Kato

    15,54 Kwp
    2xSB5000 mit je 32 Stück Suntechnics STM185
    1xSB3300 mit 20 Stück Suntechnics STM185
    SunnyBoyControl mit Netzleitungsmodem

  • Die automatische Datenabfrage bezieht sich auf Archivkanäle, also
    auf Historiedaten, die ein Datenlogger aufgezeichnet hat.


    Momentanwert meint aktuelle Messwerte ein Anlage.


    Die beiden Dinge haben nichts gemein. Daher spielt es überhaupt keine
    Rolle, ob bei der Archivdatenabfrage der Schalter
    "Momentanwerte/Datenübergabedatei schreiben" angekreuzt ist
    oder nicht.


    Das muss also andere Gründe haben....


    MK
    Welche Wechselrichtertypen hast Du denn?


    Gruß,
    Heiko

    4,32 kWp, SMA Sunny Boy 4000 TL-20, Ausrichtung WSW, Aleo S16 (Poly)

  • ... in der Tat ist es so, dass der sich zunächst "richtungsweisende" Tipp (trotzdem: "Danke") nicht als Lösung gezeigt hat.
    Ich habe immer noch das Problem, dass ich initial 1x die Daten per cntrl-M und cntrl-T schreiben muss, dann läuft aber der eingestellte Automatismus.


    Wechselrichtertypen: 2x Sunnybeam 3300TL ... mit Funk Piggybacks ausgestattet und SunnyBeam wie oben beschrieben ...


    Wäre schon schön, wenn sich das Problemchen (auf)lösen lassen würde ...


    viele Grüße, Markus.

  • Wenn dir Herr Prüssing nimmer helfen kann, kanns keiner mehr.


    Mir fällt noch was ein. Starte SDC mal manuell ( ohne autostart ) Und schau was dann passiert.
    Vielleicht liegt da der Fehler.
    SDC muß im eigenen Ordner gestartet werden. Vielleicht liegt hier der Fehler.

  • Findet denn eine Datenübertragung das erste Mal
    nach dem Autostart statt (optisch)?
    Werden die Datendateien im Plants-Unterverzeichnis dann verändert
    (Datum der Datei)?


    Der Tipp mit dem Arbeitsverzeichnis könnte sein, dann sollte aber
    niemals eine Datei geschrieben werden können, auch nach einer manuellen
    Abfrage nicht.


    Gruß,
    Heiko

    4,32 kWp, SMA Sunny Boy 4000 TL-20, Ausrichtung WSW, Aleo S16 (Poly)

  • .. es ist nach Start optisch weder etwas zu erkennen, noch werden im plants-Directory Dateien aktualisiert


    bei Programmstart wird lediglich die Sunny-Beam/USB Kommunikation aufgebaut - SBeam mit den 3 Messwerten Ertrag, Pac und CO2 steht im "OK-Status", auch die Momentanwerte meines SBeam werden korrekt angezeigt


    Gibt's da vielleicht noch irgendetwas in den Optionen->Einstellungen ??
    Timing-Einstellungen stehen auf Auslieferstand, Datenabfrage steht auf "zyklisch" alle 10 Minuten, Abfragetyp= "alle Werte"


    Gute Nacht ;-),


    Markus.

  • nochmal nachgefragt: Es sollte folgendes passieren am PC:


    - SDC wird gestartet (Windows-Autostart)
    - Der "SDC Splash-Screen" erscheint (das Bild mit dem (noch) SBC)
    - Die "Busy-Dialog" geht auf (Datenabfrage mit dem "Sonnenanimation"). Es werden einige Dinge zur Zeitbereichsabfrage übertragen...
    - irgendwann in der nächsten 1/2-Stunde sollte dann wieder der "Busy-Dialog" aufgehen. Dann aber mit dem Titel "Automatische Datenabfrage"...


    Ist dem so? Wo weicht das bei Ihnen ab?


    Gruß,
    HP

    4,32 kWp, SMA Sunny Boy 4000 TL-20, Ausrichtung WSW, Aleo S16 (Poly)