SB5000TL-20 Display nachts plötzlich tot

  • Halo Daniel,
    ich hatte bei SMA angerufen, die kamen auf das Netzteil.
    Ich habe den WR geöffnet (SB 4000TL20)


    rechts unten ist die Verbindung zum Netz. Links daneben das Netzteil, mit Trafo usw.


    leider noch nichts neues...
    Gruß Silbersonne


    Du hast ne PN

  • Hallo,
    zu dem Thema gibt es hier noch einen weiteren Thread. Reparatur SB 5000TL-20 -> Nachts Display tot


    Es gibt auf der Hauptplatine des WR ein Bauteil vom Typ TNY276 "Energy Efficient, Off-Line Switcher with Enhanced Flexibility and Extended Power Range".
    Das Datenblatt dazu ist im Internet zu finden. In diesem Datenblatt gibt es auch ein "Applications Example" aus dem die prinzipielle Verschaltung hervor geht.
    Diverse Bauteile aus dem Anwendungsbeispiel wie Transformator, Dioden, Optokoppler, Gleichrichter, ect. findet man auch im Umfeld des TNY276 wieder.
    Möglicherweise ist diese Schaltung das Netzteil welches den WR nachts mit Strom versorgt.


    Vielleicht ist das ein Ansatzpunkt das fehlerhafte Bauteil einzugrenzen.

    Viele Grüße von
    Strom aus Sonne
    8,40 kWp - 170° bei 35° Dachneigung - 40 x Kyocera KD210GH-2PU - 2 x SMA SB 4000TL-20 - SolarLog500
    solarlog-home.de

  • Hallo Strom aus Sonne,
    Danke für den Tipp!!
    Im Elektronicforum wurde beschrieben, dass dieses Bauteil gern defekt ist. Dann ist zwischen den Anschlüssen D und S ein Kurzschluss.
    Leider ist meins heile, kein Kurzschluss.
    In dem Umfeld (Trafo, C...) sieht es sehr schön aus (nichts angeschmort oder so).
    Leider kann ich keine (kaum) Messungen durchführen. Bei mehreren Stromquellen, bis 1000V Spannung habe ich keine Möglichkeit die Hauptplatine von der Lötseite her zu messen.
    Ansonsten, für jeden Tipp dankbar...
    Gruß Silbersonne

  • Hallo Silbersonne,


    Kein Kurzschluss zwischen D und S des TNY276 bedeutet nicht zwangsläufig dass das Teil noch in Ordnung ist. :wink:
    Das kann ja auch auf andere Art defekt sein.


    Ich würde auch erst mal den WR komplett spannungslos machen und die anderen Bauteile die man auf der Bestückungsseite der Hauptplatine sieht, ohmisch durchmessen. Das sollte zumindest bei einigen Dioden die Aussage zulassen ob ok. oder defekt. Beim Optokoppler könnte man vermutlich auch die Sendeseite so prüfen. Dann ist da noch ein größerer Elko und rechts daneben ein Gleichrichter, auch den könnte man ohmisch (Diodentest) prüfen.


    Den WR zerlegen um an die Lötseite der Hauptplatine zu kommen würde ich erst mal nicht machen. Dafür ist der Schaden zu nebensächlich.


    Ich habe leider nur ein Foto mit dem Bereich um dieses Netzteil aus dem ich die Infos habe die ich hier poste.
    An den WR selbst komme ich derzeit nicht ran.

    Viele Grüße von
    Strom aus Sonne
    8,40 kWp - 170° bei 35° Dachneigung - 40 x Kyocera KD210GH-2PU - 2 x SMA SB 4000TL-20 - SolarLog500
    solarlog-home.de

  • Hallo,
    Ich hatte heute die Gelegenheit an meinem defekten WR ein paar Bauteile zu messen, soweit das im eingebauten Zustand möglich war. Also nur ohmisch bzw. Diodentest beim Multimeter und spannungslosem WR.
    Ich konnte dabei eine defekte Diode ausmachen. Mit beiden möglichen Polungen zeigte das Multimeter einen satten Schluss an. Also 0 Ohm bei Widerstandsmessung bzw. 0mV beim Diodentest.


    Defekt ist das Bauteil mit dem roten Pfeil.


    Beim zweiten WR, der noch funktioniert, messe ich an der gleichen Diode eine Durchlassspannung von 255mV.
    Das Bauteil ist mit Schutzlack überzogen sodass die Bezeichnung kaum lesbar ist.
    Ich konnte:
    V3H
    P937L

    entziffern. Ich glaube auf dem rechten Lötpad sieht man auch leichte "Brandspuren". :evil:


    Mit dieser Typenbezeichnung kann ich aber leider nichts anfangen. :x Ich konnte im WWW nichts finden oder bin einfach nur zu ... zum suchen. Vielleicht kennt sich damit jemand besser aus als ich und kann einen Tipp beisteuern.


    Ob dies das einzige defekte Bauteil ist kann ich nicht sagen, es könnte ja sein dass diese Diode "gestorben" ist weil zuvor etwas anderes kaputt gegangen ist.
    Hier noch der Link zum Datenblatt des TNY276.
    Auf Seite 8 (Figure 14) in diesem Datenblatt ist eine Beispielbeschaltung gezeigt. Meine Vermutung ist, dass die defekte Diode die D7 aus dieser Schaltung ist.

  • habe mich im Parallelthread schon mal geäußert und vermutet, dass eine Diode die Ursache sein könnte. Mit deiner Messung der 0V Durchlassspannung hast du eigentlich den Hauptübeltäter schon gefunden.
    Die Vergleichsmessung an der intakten Diode zeigt, dass es sich um eine Schottky Leistungsdiode handelt, würde da einfach mal eine in der Baugröße gleiche Schottkydiode einsetzen, passieren kann eigentlich nicht viel. Vorher mal prüfen ob ein Parallelschluß an der defekten Diode vorliegt und evtl. ein anderes Bauteil die 0 Volt hervorruft. Ebenfalls sollte mal der dahinterliegende Elko auf Kapazitätsverlust geprüft werden, ist diese schlecht wird die neue Diode zu heiß und wird irgendwann wider sterben. In der Spannungszuführung zur Diode könnte wegen des Kurzschlusses auch noch ein defekter Vorwiderstand
    möglich sein.

  • Hallo wadoe,


    ich weiß ja nicht wirklich viel über die Diode. Dass es sich um eine Schottky-Diode handelt ist bei der Durchlassspannung sehr wahrscheinlich, zumal in Schaltnetzteilen üblicherweise aus div. Gründen Schottky-Dioden einesetzt werden. Das Gehäuse ist möglicherweise DO-214AB, aber da gibt es auch viele Gehäuse mit anderen Bezeichnungen die optisch sehr ähnlich aussehen.


    Für den TNY276 wird bei einer Eingangsspannung von 230V~ eine Spitzenleistung von 19W angegeben. Ich kenne aber auch die Ausgangsspannung des Hilfsnetzteils nicht. Wären es 12V, dann müsste die Diode ca. 1,6A vertragen. Bei 5V wären es rein rechnerisch 3,8A.


    Wie man im ersten Bild sieht, sind die Elkos mit:
    K4
    220V
    UD

    beschriftet.
    Ich vermute mal dass die 220µF haben und dass es Low-ESR Typen sind. Die Spannungsfestigkeit kann man auch nur entschlüsseln wenn man den Hersteller kennt und das Datenblatt hat.


    Mir ist es zu heiß diese Bauteile gegen andere auszutauschen nur weil die Bauform passt.
    Für die Diode wäre zumindest eine verlässliche Angabe für IF und für die Sperrspannung nötig.
    Für die Elkos wäre eine Bestätigung der Kapazität von 220µF nötig, mit der Spannung kann man dann so weit nach oben gehen dass die Baugröße noch auf die Platine passt.


    Vielleicht könnte ein Admin die verschiedenen Threads zu diesem Thema mal zusammenführen. Das könnte der Sache dienlich sein.

    Viele Grüße von
    Strom aus Sonne
    8,40 kWp - 170° bei 35° Dachneigung - 40 x Kyocera KD210GH-2PU - 2 x SMA SB 4000TL-20 - SolarLog500
    solarlog-home.de

  • Eine andere Diode ist doch das kleinste Problem.


    Vll. kann ja mal jemand messen wieviel Spannung da am Ausgang anliegen.
    Kann man wohl auch an der Z-Diode links daneben schlußfolgern


    Dann erstmal die Diode raus, Ausgang auf Kurzschluß prüfen und mit Labornetzteil fremdspeisen und schauen ob der WR "aufwacht"

  • Das Problem ist doch dass das Display nachts nicht mehr geht. Also wenn keine DC-Spannung anliegt.
    Ich würde nur die Wechselspannung anschließen. Dann kann doch gemessen werden wie es sich mit dieser Stand-by Spannung verhält.


    Rantanplan

  • Zitat von rantanplan

    Das Problem ist doch dass das Display nachts nicht mehr geht. Also wenn keine DC-Spannung anliegt.
    Ich würde nur die Wechselspannung anschließen. Dann kann doch gemessen werden wie es sich mit dieser Stand-by Spannung verhält.


    Rantanplan


    Gemeint ist hier hinter der Diode (kathodeseitig) die 5V oder 12V DC per Netzteil anschließen. Es soll nicht die DC-Spannung von den Strings per Netzteil ersetzt werden.

    WSW Dach 70°: Gauben 20x HIT-N240SE10 DN 25°, String auf A1+A2 STP8000TL-10; First 10x HIT-N240SE10 DN 45° auf SB3000TL-21
    ONO Dach -110°: First 10 x HIT-N240SE10 DN 45° teilverschattete Strings auf B STP8000TL-10
    Solar-Log 300, 70% Begrenzung fest