FreeSol Fragen und Probleme

  • In diesem Thread werden Fragen zu Installation und Betrieb von FreeSol beantwortet und hoffentlich wird auch Neueinsteigern bei Problemen geholfen.


    Antworten finden sich übrigens auch bei http://www.freesol.de, besonders im Wiki. Insbesondere sollte man sich die FAQ dort zunächst mal durchlesen.


    Viel Spass mit FreeSol!


    Thomas

  • Hallo Thomas,


    ich finde dein "freesol datenlogger" super und werde ihn auch installieren :danke:


    nun hätte ich die erste frage:
    1. kann ich von meinem zähler (landis+gyr ZMF120ACdM13) werte auslesen ?;
    der zähler hat nur eine led, welche anscheindend mit verbrauchsschwankungen auch unterschiedlich lange pausendauer zwischen den ledimpulsen erzeugt; ich habe eine pv mit überschusseinspeisung, dieser zähler arbeitet in beide richtungen; nun kann ich auch beide werte erfassen ?


    zum auslesen der SML-signale werde ich den auf freesol aufgeführten schaltplan... verwenden, (teile in bestellung);


    Danke im Voraus !


    eragon

  • eragon


    Im Moment erwartet der Eingang für den Solarzähler ein S0-Signal und der Eingang für Bezugs/Einspeisezähler eine SML Signal
    Das S0-Signal kann auch aus einer blinkenden LED kommen.


    Fangen wir doch mal einfach und mit Deinem Solarzähler an: Ist das der mit der blinkenden LED, oder der mit SML? Vermutlich ist das bei Dir genau andersrum als bisher immer benötigt, da muss ich erst ein bisschen erweitern, weil Du der erste bist. Sorry, das geht dann nicht ganz sofort.


    tfv

  • hallo tfv,


    solarzähler:
    meine pv hat einen umformer, welcher einen s0 ausgang besitzt, diesen würde ich als s0 - signal verwenden


    bezugs/einspeisezähler (landis+gyr ZMF120ACdM13)
    so weit ich getestet habe (lt. euren anweisungen handy display....) blinkt diese led anscheindend mit dem verbrauch unterschiedlich,


    was ich nicht herausfinden konnte (+suche im internet), was (Verbrauch) hier eigentlich angezeigt wird;
    meine stromversorgung im haus besteht zum teil aus der pv und dem öffentlichen netz, bzw. mein überschuss wird ins netz eingespeist;


    nun vielleicht weis jemand, was genau durch die led impulse angezeigt wird, oder ist es doch "verschlüsselt" und er wird alles irgendwie erfasst --> als SML information ausgegeben und ist auch für den freesol-datenlogger verwendbar;


    danke für die infos


    eragon

  • eragon


    Ich würde vorschlagen, erstmal die Solarleistung mit dem S0-Zähler stabil zum Laufen zu bekommen.


    Eine LED, die mit Vrebrauch unterschiedlich blinkt, ist KEIN SML Ausgang, sondern im Prinzip auch ein S0-Ausgang.
    Ich arbeite im Moment daran, diesen auch für Bezug/Einspeisung umzusetzen, das dauert aber. Die SML Schaltung brauchst Du dann natürlich nicht.


    Dafür brauchst Du aber eine Aussage, in welcher Richtung der Strom gerade fließt. Weitere LED vorhanden?


    In den Wiki FAQ habe ich gerade je eine Antwort zu "Was ist ein SML-Signal?" und "Was ist ein S0-Signal?" eingefügt.
    http://wiki.freesol.de/index.p…#Was_ist_ein_S0-Signal.3F


    tfv

  • Hallo TFV,


    werde mir nun den Volkszähler-IR-Kopf über "UDO" zulegen.
    Zunächst muss ich dann mal mit meinem ITRON ACE3000 ein bischen "üben", damit dieser hoffentlich zu reden anfängt (Kennt einer die Aufwachsequenz). Hierzu brauche ich einen TTL auf USB Adapter für den PC - kann man das Teil von Pollin da nehmen? (ist doch 232 (nicht TTL) auf USB) bzw hat jemanden einen Hinweis? (Ich selbst habe schon einen RS232 auf USB Adpater)


    Weiterhin wie schließe ich den TTL-IR-Kopf an das I/O-Board (kommt erst später aber Hinweis wäre schön - ggf benötige SUB-D9-Buchse). Übrigens scheint es so, dass der ACE3000 fix mit 300BAUD arbeitet macht das ein Problem?


    Das wärs zunächst!
    Gruß Lippe

  • Hallo,


    ich habe mir den Datenlogger nach der Anleitung zusammengebaut und auch die Software eingespielt.
    Jetzt habe ich den Logger an meinen Zähler über S0 angeklemmt und das Netzwerkkabel eingesteckt.
    Über die IP-Adresse erreiche ich den Logger, aber ich bekomme kein S0-Signal zustande.
    Ich habe folgenden Stromzähler: eltako dsz12d-3x65a.
    Ich habe alle Kabel kontrolliert und konnte keinen Fehler finden.
    In der Konfiguration des Loggers habe ich alles gemacht wie beschrieben.
    Im Display zeigt er mir auch die Version usw. an.
    Der Logger gleicht sich nicht mit dem ntp-Server ab und verschickt auch keine Mails.


    Wie fange ich jetzt an den Fehler mit dem S0-Signal zu finden und was kann ich bei den Konfig.-Einstellung falsch gemacht haben.

  • Zitat von Lippe


    werde mir nun den Volkszähler-IR-Kopf über "UDO" zulegen.
    Zunächst muss ich dann mal mit meinem ITRON ACE3000 ein bischen "üben", damit dieser hoffentlich zu reden anfängt (Kennt einer die Aufwachsequenz). Hierzu brauche ich einen TTL auf USB Adapter für den PC - kann man das Teil von Pollin da nehmen? (ist doch 232 (nicht TTL) auf USB) bzw hat jemanden einen Hinweis? (Ich selbst habe schon einen RS232 auf USB Adpater)


    FAQ eingefügt: http://wiki.freesol.de/index.p…al_mit_dem_PC_auslesen.3F


    Wenn Deine Lösung läuft, lass es uns dort detailliert ergänzen. Ich selbst habe auch nur einen RS232-Adapter und Zusatzschaltungen.


    Ich glaube, Udo's "Kopf" kann das Signal invertieren, das wirst Du vielleicht brauchen.


    Zitat


    Weiterhin wie schließe ich den TTL-IR-Kopf an das I/O-Board (kommt erst später aber Hinweis wäre schön - ggf benötige SUB-D9-Buchse). Übrigens scheint es so, dass der ACE3000 fix mit 300BAUD arbeitet macht das ein Problem?


    FAQ hinzugefügt: Die Baudrate ist im Moment fest auf 9600 Baud eingestellt.


    Wenn Du hier eine Änderung brauchst geht dass, ich weiss aber nicht, ob das flexibel ohne Neucompilieren einstellbar sein wird, muss ich prüfen.


    Viele Grüße,


    tfv


  • Halo SkySven,


    hatst Du beim Konfiguruieren zunächst auf den Knopf Defaultwerte gedrückt, um sinnvolle Startwerte zu bekommen?


    Ich habe neu zwei FAQ-Antworten eingefügt, die dir vielleicht helfen:


    5.2 Freesol führt keine Zeitsynchronisation durch
    http://wiki.freesol.de/index.p…Zeitsynchronisation_durch


    5.3 FreeSol zählt keine S0-Pulse
    http://wiki.freesol.de/index.p…z.C3.A4hlt_keine_S0-Pulse


    Bitte mit dem Ergebnis nochmal melden.


    tfv

  • hallo, kleiner hinweis zum ntp server: ich habe einen arcor-anschluß, da geht der default-ntp nicht. musst dir einen anderen per google suchen und den anpingen, um zu testen, das er funktioniert und dir eine antwort schickt.


    Thomas : vielleicht im wiki eine ergänzung zu der arcor geschichte...

    Gruß aus Wachtberg
    Marc


    9,66 KW, Flimpex PVEP-D1 230 mit Q.CELLS, 3 SMA WR,
    Ausr.: 30 Mod.-60° Ost, 12 M.+30° W , Dach 35°seit 21.5.2010
    ___________________________________________________________
    http://m.jaeger-wachtberg.de/