komme von außen nicht auf die Webbox

  • Hallo Leute,


    ich wollte gern von außerhalb meines Heimnetzwerkes auf die Webbox zugreifen können.


    Leider bekomme ich das auf Teufel komm raus nicht hin! Ich war schon bei DynDNS.com und habe eine Hostadresse eingerichtet. Und im Router habe ich dies unter dynDNS-Einstellungen eingetragen mit username und passwort meines Accouts bei dyndns.com.
    Dann war ich in den Port forwarding Einstellungen und habe dort die lokale IP der Webbox eingetragen. Und den Port 80.


    So, wenn ich jetzt zu Hause an meinem PC diese Host-Adresse eingebe, dann komme ich auf die Webbox. Jedoch von außerhalb geht es nicht! Was kann das sein?


    Ich habe auch noch nicht verstanden, was das mit dem Port Forwarding auf sich hat! Dort steht ja nur ein freier, von mir gewählter Name (ich habe "Webbox" gewählt), dann der Start-Port 80 und der End-Port 80 und dann noch die lokale IP: 192.168.0.168
    Wenn man von Extern die host-Adresse der Webbox eingibt, dann wird ja irgendwie dem Router mitgeteilt, dass da jemand auf die Webbox will. Aber auf der Seite DynDNS.com habe ich doch nichts von der Webbox und auch nicht von Port 80 eingegeben!?
    Wie weiß jetzt der Router, dass die Webbox gefragt ist und nicht ein anderes Gerät/Computer in meinem Netzwerk?


    Kann es sein, dass im Router auch noch eine Firewall existiert? Wie geht man da dann vor?


    Danke für Eure Tips im Voraus!


    Gruß,


    Micha

  • wie versuchst du den auf deine box zu kommen ??


    einfach 192.168.0.168 im Browser eingeben ??


    oder nimmste deine ****.dyndns.de:80 Adresse ??

    MfG Heiko

    seit 27.06.19 noch mal 29,76kWp

    seit 11.1.19 nen Hyundai Kona Elektro, als Speicher :D

    seit 15.9.09 - 15,17kWp am laufen :)
    Meine Anlage

  • Hallo Heiko,


    mit 192.168.0.168 komm ich ja gut drauf, auf die Box! Und an meinem PC zu hause auch über
    http://****.dyndns-at-home.com (ohne "www" und hinten ohne :80)


    Aber von außen geht die host adresse nicht.


    Und hier gleich noch etwas: Aus mir unbegreiflichen Gründen geht die LED "Data Upload" manchmal einfach so auf rot. Dann ist die Box auch vom internen PC nicht ansprechbar. Dann muß ich den Repeater (an dem habe ich die Webbox angestöpselt) aus- und wieder anschalten und dann wird sie wieder grün. Das ist auch total rätselhaft.
    z.B. ich gehe morgens zur Arbeit und schalte vorher noch Router und Repeater an. Alles ist grün und ich kann auf Arbeit den ganzen Tag sehen, die im Sunny Portal die Daten (zwar bis zu 2 Stunden verspätet) ankommen. Wenn ich dann abends nach hause komme sehe ich sofort: Mist die Lampe "Data Upload" ist schon wieder rot!


    Die Webbox ist ja per LAN-Kabel mit dem Repeater verbunden. Und der ist den ganzen Tag über eingeschaltet. Warum ist die Lampe immer mal wieder rot?
    Jetzt auch grade wieder: Router und Repeater sind voll da (volle grüne Balken, also starkes signal) dennoch Data Upload ist rot!


    EDIT: Übrigens:


    Im Router steht unter Device's IP Address
    Get Dynamically IP Address From Router.


    Ist eine statische IP nicht besser? Also evtl dann mal 192.168.0.2

  • Der 80 Port ist der Security Port, der wird bei manchen Routern geblockt.


    mach mal ein 8000 Port draus, sollte dann klappen...


    Gruesse Ron

    Hybrid Anlage:1,5 kWp Solar Swiss Ag/Astom Ag Solar Panel,WR: 3000 W reiner Si Fraron,2500 W Fraron modi,
    SMA SI2224,Steca PR3030,Phocos MPPT 100/30,Phocos CXN40-1.1 mit CMX 1.2,IVTSC30

  • Hi Micha369 (wir kennen uns ja schon)


    bei Dyndns habe ich diese Adresse registriert : <myname>.homeip.net
    Die Portweiterleitung ist wie folgt eingestellt:
    Um im Büro oder auch zu Hause auf die Webbox zu kommen, gibt man folgendes ein:

    Code
    1. http://<myname>.homeip.net


    Ein Umleiten mit unterschiedlichen Einträgen bei "von Port" und an Port" habe ich auch noch nie hinbekommen.

  • Hallo Leute,


    Also ich komme immer noch nicht auf die Box drauf! Ich weiß nicht, was ich noch machen soll!


    Also ich habe mal im cmd pings probiert:


    ping http://www.webbox.....dyndns-at-home.com
    konnte host nicht finden!


    aber das hier geht:


    ping webbox.....dyndns-at-home.com
    ping ausgeführt (Zeit 1ms)



    in meiner Browseradresszeile kann ich jedoch eintragen was ich will, da geht nichts!
    das einzige, was geht ist:
    http://192.168.0.168
    (aber das ist ja nur die lokale IP, wie ich ja nun schon weiß).


    Windows Firewall habe ich jetzt auch schon mal ausgeschaltet.
    geht trotzdem nichts vom Firefox aus.



    Ich weiß nicht, ob dascmit den Ports zusammenhängt.
    Jemand sagte mir, ich solle mal den Port 8000 versuchen.


    Habe also im Port forwarding Start- und End Port auf 8000 gesetzt.


    Wie muß ich denn nun die host-adress im Browser aufrufen:


    hinten mit :8000 oder ohne?


    Saftwerk schreibt mir, dass er immer nur auf die Box geht mit:


    http://webbox...dyndns-at-home.com
    aber er hat ja auch den Port 80 gelassen und nicht auf 8000 verändert.


    hier:
    http://files.sma.de/dl/7680/DynDNS-UDE094111.pdf


    schreibt SMA, wie man auf die Webbox von extern draufkommt.
    Nur verstehe ich den Punkt 9 auf Seite 13 nicht!
    Was muß ich denn da noch alles machen unter Porrt forwarding?
    Da schreiben sie was von von FTP, HTTP und TCP!? siehe Bild!


    Was kann ich denn mal tun, um den Fehler systematisch einzugrenzen?


    Gruß,


    Micha

  • Hallo Micha,
    bitte kein Doppel-Posting....



    Das www geht nicht, das darfst du nicht davor schreiben.


    Zitat von Micha369


    in meiner Browseradresszeile kann ich jedoch eintragen was ich will, da geht nichts!
    das einzige, was geht ist:
    http://192.168.0.168
    (aber das ist ja nur die lokale IP, wie ich ja nun schon weiß).


    Hast du die lokale Adresse im Router eingetragen? Das musst du nämlich machen.


    Zitat von Micha369


    Windows Firewall habe ich jetzt auch schon mal ausgeschaltet.
    geht trotzdem nichts vom Firefox aus.


    Anschalten, besser ist das. Das ist auch nicht das Problem.


    Zitat von Micha369


    Ich weiß nicht, ob dascmit den Ports zusammenhängt.
    Jemand sagte mir, ich solle mal den Port 8000 versuchen.


    Habe also im Port forwarding Start- und End Port auf 8000 gesetzt.


    Startport ist 80! Den Endport kannst du so lassen.


    Zitat von Micha369


    Wie muß ich denn nun die host-adress im Browser aufrufen:


    hinten mit :8000 oder ohne?


    Mit :8000



    Da steht ja im Grunde alles. Portforwarding für die WebBox von Port 80 auf Port 80 und dann die IP der WebBox (bei dir 192.168.0.168), fertig! Alles andere interessiert dich jetzt nicht.

  • HI,


    Teil 1: Das mit Dyndns läuft so:
    Du hast einen Namen webbox auf einer Webadresse dyndns-at-home.com reserviert.
    Also gibt es ab sofort auch webbox.dyndns-at-home.com


    Wenn jetzt jemand http://www.webbox.dyndns-at-home.com eingibt, dann läuft folgende Kette an:
    1. com gibt dir die Antwort wer dyndns-at-home reserviert hat. (com ist die Topleveldomain)
    2. dyndns-at-home gibt dir die Antwort wer webbox reserviert hat.
    3. webbox gibt dir die Antwort wer www reserviert hat. (den Namen webbox hast du für deine Fritzbox = deinen DSL-Anschluss herausgesucht)
    Bei (3) kommt ein Fehler, weil in der Fritzbox der Name www nicht registriert ist (das kann die auch nicht)


    Also geht kein http://www.webbox.dyndns-at-home.com sondern nur webbox.dyndns-at-home.com
    (INFO: Das war eine stark vereinfachte Erklärung, denn in Wirklichkeit werden keine 3 Anfragen nacheinander gestellt, sondern nur eine. Und das geht, weil die Fritzbox ihre aktuelle IP regelmäßig an eine art IP-Telefonbuch schickt.)
    Teil 1 beendet: Jetzt must du wissen warum kein www geht.


    Teil 2: Das mit den Ports läuft so:
    Wenn Du im Browser "http://..." schreibst, dann wird automatisch Port 80 angenommen.
    Wenn Du im Browser "ftp://..." schreibst, dann wird automatisch Port 21 angenommen.
    Wenn Du im Browser "http://..." vorne dran einfach weg lässt, dann fügt es der Browser unsichtbar wieder hinzu.
    Wenn Du den automatischen Port nicht willst, sondern Beispielsweise Port 81, dann kann man das so eintippen:

    Zitat

    Die korrekte Schreibweise hat am Ende des Servernamens immer ein / aber der Browser regelt das automatisch für Dich. Und so gibt es etliche TAUSEND verschiedene Ports, aber die Server sind zum ansurfen fast alle einheitlich auf 80 eingestellt.


    Du willst nun mit der SMA Webbox auch so einen Server "ins Internet bringen".
    Das geht aber erstmal nicht, weil du vom Provider nur eine öffentliche IP-Adresse bekommst und die hat die Fritzbox.
    Und hier kommen jetzt die Ports:


    Die Fritzbox hat 2 Seiten: Die öffentliche DSL-Seite und die private LAN-Seite.
    In der Fritzbox horcht auf der LAN-Seite ein Server auf Port 80 - und der antwortet wenn du fritz.box eintippst.
    Auf der öffentlichen Seite horcht erst mal niemand auf Port 80 und eine Anfrage von der öffentlichen Seite wird unbeantwortet verworfen.
    Wenn du in die Fritzbox ein Portforwarding von Port 80 auf Port 80 an die Webbox eingetragen hast, wird die Anfrage unbeantwortet an die Webbox weitergeleitet. Jetzt wird in der Webbox der Server die Anfrage von Port 80 beantworten.
    Und das tut er auch (zumindest bei mir)
    Wenn Du vom internen LAN auf die Webbox kommst, z.B. 192.168.178.4 dann geht's jetzt auch von der öffentlichen Seite.


    Teil 2 beendet:
    Jetzt weißt du, warum das öffnen der Ports gefährlich sein kann: Alle möglichen gültigen und ungültigen Anfragen(=Netzwerkpakete) werden vom öffentlichen Port 80 ins LAN zu der Webbox gelassen. Wenn die Webbox eine vor Angriffen sichere Firmware hat, dann kann man den Port ruhig offen lassen.
    Leider ist sie das nicht : http://www.photovoltaikforum.c…ermi-p566135.html#p566135


    Ich kann leider nicht erklären, warum mit der Frizbox keine Portänderung funktioniert:
    Also eine öffentliche Anfrage von außen mit Port 80 an einen privaten LAN-Server mit Port 81 weiterleiten => geht bei mir nicht.

  • Zitat von datenmuehle

    Hallo Micha,
    bitte kein Doppel-Posting....


    ok, ich dachte, dass dieses Posting vielleicht wieder von anderen gelesen wird, sodaß ich dadurch mehr Leute erreiche, die sich auskennen.
    Sorry!


    Zitat von datenmuehle


    Hast du die lokale Adresse im Router eingetragen? Das musst du nämlich machen.


    Ja, das war schon. Aber nur unter Webbox (also HTTP oder TCP) in der Portweiterleitung


    Jetzt kommt es aber: ich habe nun auch unter FTP die lokale Webbox-IP eingetragen und nun kann ich plötzlich mit
    http://webbox...dyndnss-at-home.com
    die Webbox aufrufen. Das verstehe wer will! Jetzt geht es!


    Port für HTTP/TCP habe ich wieder auf 80 zurückgesetzt. Windows Firewall ist an und es geht vom Rechner aus!
    Port bei FTP wurde auf 20/21 gesetzt.
    Was aber überhaupt nicht gehen will:
    Der Zugriff auf die Webbox von Deinem Handy-Programm!
    Dort kommt immer nur: HTTP Status:0
    In der Config steht aktuell:
    http://webbox...dyndns-at-home.com
    Nun noch ein Ergebnis:
    Immer wenn ich das Programm starte, dann fragt mich das Handy, ob eine Verbindung zugelassen werden soll. Dann sag ich ja und er zeigt mir mein wlan-Heimmnetz an und das langsame funknetz (GSM oder Edge oder wie das heisst). Ich habe immer dieses Netz gewählt und NICHT mein wlan, weil die Abfrage ja von extern aus gehen soll. Geht jedoch, wie gesagt, immer nicht! Nun habe ich mir mal gesagt, ich versuche es mal mit meinem wlan. Und da hat mir Dein Programm die Werte sofort angezeigt.
    Also: über mein lwan geht es jetzt, aber über das edge anscheinend nicht.
    Hast Du eine Ahnung, warum nicht?


    Gruß,


    Micha