Yasdi: Konverter erkennt RS-485 Module nicht

  • Hallo,


    ich habe hier 2 SMA 3300-TL mit zwei Originalmodulen für RS-485. Als Konverter benutze ich einen ATC-1000.


    Wenn ich in der Fritzbox (Solarview) die yasdishell starte, dann bekomme ich folgende Meldung: "Switching driver 'IP0' on...success". Ich kann also auf den Konverter per TCP/IP zugreifen.


    Leider findet Yasdi die beiden Konverter nicht.


    Verkabelt sind die Module mit jeweils + und - an den KOnverter. GND ist nicht verbunden. Dieses Anschlussschema habe ich aus der Bedienungsanleitung des Konverters (siehe Anhang). Der Widerstand ist in beiden Modulen noch gesteckt, die rechte Klemme wird nicht benutzt.


    Ich habe UDP enabled, local port =24272, remote port (fritz.box)=24273


    Auch bei Reduktion auf 1 WR-Modul am Bus bekomme ich keine Anzeige.


    Was mache ich falsch?

    Dateien

    • ATC-1000-UM.pdf

      (337,77 kB, 287 Mal heruntergeladen, zuletzt: )
  • Hmm, kann vielleicht ja auch damit zusammenhängen, dass die WRs noch nicht an das Netz angeschlossen sind (Zähler fehlt).


    Aber eigentlich sollten doch wenigstens die Statusdaten übertragen werden, oder?

  • Um es nochmals zu betonen, Terminierung NUR da drin wo die RS485 Leitungen enden (letzter WR und Konverter, aber nicht in dem WR mit den ankommeneden und rausgehenden WR).
    Sollte ein Ohmmeter (Multimeter) zur Verfügung stehen, sollte man an einem offenen Ende (z.B. Konverter) zwischen DATA+ und DATA- etwas um die 120 Ohm (+-30%) messen. Wenn die Längen zwischen Konverter und WRs beträchtlich sind (mehr als 50m), sollten auf jeden Fall die Data- und Data+ Adern im Kabel miteinander verdrillt sein (in einem Pärchen).
    Nur ein paar weitere Tipps.
    Grüße

  • Ich habe jetzt auch den zweiten WR am Laufen.


    Verkabelt habe ich das ganze aber als Stern mit aktiver Terminierung bei beiden WRs.


    Es sind bei mir nur ca. 50cm bis zum Adapter, angeschlossen ist das nach der Anleitung vom ATC-1000, auch wenn das eigentlich keine Bus-Verkabelung ist...


    Nun ja, es funktioniert :D:D:D