Sunways Wechselrichter mit Solarview betreiben (SMP)

  • Wenn Du smp ohne Parameter im Telnet-Fenster aufrufst, dann erhälst Du die möglichen Parameter mit einer kurzen Erklärung dazu. Testen kannst Du wie folgt (evtl. laufende smp-Prozesse zuvor mit killall -9 smp beenden), also einfach -d zu Deinen Startparameter hinzufügen:
    ./smp -h 192.168.178.36 -p 1470 -c 6 -l 10000 -d


    Die Wechselrichter haben keine IP-Adresse, daher ja der EX-Konverter. Auf der RS485 Seite kannst Du die beiden Leitungen gefahrlos tauschen (A, B, oder TX, RX etc), leider ist die Bezeichnung zwischen den Herstellern nicht identlisch. Die Wechselrichter müssen einspeisen, damit Daten kommen.
    Grüsse,
    Manfred

  • Hallo Zusammen,
    so ich habe jetzt mal die Einstellungen angepasst. Verschiedene Ports durchprobiert, leider kein Erfolg.


    Meine Einstellungen
    solarview-fb -nodatexport -i 127.0.0.1 -p 10000 -c 6 -a 0.9953 -w 6000,6000,6000,6000,6000,6000
    ./busybox httpd -p 88 -h homepage
    ./smp -h 192.168.178.200 -p 6753 -c 6 -l 10000 -f smp.log -r ids.log -d


    Das Logfile von smp gib das aus, was im Anhang hängt.


    Offenbar habe ich keine Verbindung zu den Konvertern oder?
    Warum klappt es dann mit dem NT-Monitor (also über virtuellen Port)?


    Eine Frage noch: Welche IP soll ich dem Konverter geben? Zum einen lese ich hier, eine IP Adresse, die im Bereich der Fritzbox liegt- Meine Anleitung vom Konverter sagt, eine IP die außerhalb des Bereichs liegt.
    Wenn ich jetzt eine Adresse außerhalb nehme, kann ich nicht mehr darauf zugreifen und auch komme auch per Browser nicht mehr auf die Oberfläche des Konverters.
    Im Handbuch steht für RS 485 D+ und D- verwenden. Die Verkabelung sollte also passen.


    Ich komme nicht mehr weiter!


    Ich hoffe Ihr könnt mir helfen.


    VG
    Josef

    Dateien

    • smp.log

      (416,84 kB, 72 Mal heruntergeladen, zuletzt: )
  • Die IP Adresse des Konverters muss mit dem Bereich der Fritzbox übereinstimmen. Wenn Die Fritzbox 192.168.178.1 hat (Standard), dann kannst Du dem Konverter eine freie Adresse zwischen 192.168.178.2 und 192.168.178.255 zuordnen. Den Port, den Du auf dem Konverter eingestellt hast, den musst Du beim Parameter -p beim Aufruf von smp mitgeben, die müssen übereinstimmen. Im ganzen Protokoll kam genau einmal eine passende Antwort zurück mit der korrekten Länge von 13 byte, da warst Du aber so schnell mit dem Abschiessen von smp, dass die Antwort nicht ausgewertet werden konnte:


    Du hattest smp mit den Parametern -h 192.168.178.200 -p 2000 aufgerufen...


    Grüsse,
    Manfred

  • Hallo Manfred,
    Danke für die rasche Antwort.


    Ja dass ich Parameter p als Port vom Konverter eintragen muss, weiß ich.


    Ich habe den Port immer wieder gewechselt, weil es auf der Website immer offline angezeigt hat.


    Ich habe zuletzt auf Port 6753 eingestellt und auch so in smp eingetragen. Das läuft jetzt noch. Morgen Nachmittag schau ich dann einmal, was auf der Website angekommen ist, weil jetzt sind die WR ja im Nachtmodus.


    Also müssen immer 13 bytes ankommen, um ein verwertbares Signal zu erhalten?


    Ich warte mal bis morgen.


    Viele Grüße
    Josef