Abbruch Kommunikation Sunny Island M4.4

  • Wenn die IP im Home Manager fest eingestellt ist, dann ist das egal. Lass ruhig IGMP Version 3 drinnen stehen.


    Stell den Messintervall ruhig auf 600ms. 1000ms ist schon ziemlich ungenau.

    21 x Q.PEAK DUO BLK-G5 320
    1 x STP 6000TL-20 Tripower

    1 x SI 4.4-13 + 14,4kWh Speicher (Batrium)

    Sunny Home Manager 2.0

  • Trotz aller Maßnahmen, Tests und Einstellungen kam es heute vermehrt hintereinander zu Verbindungsabbrüchen.

    Erst ließ es sich per Netzwerkkabel beheben, dann musste ich 2x den Island aus-/einschalten und dann wieder nur Kabel abstecken.

    Ich bin inzwischen echt ratlos, zumal trotz aktivem WLAN auch darüber kein Zugriff möglich ist.

    SMA will mich scheinbar nicht weiter supporten und drängt auf einen Installateureinsatz.

    Dabei habe ich schon mehr ausprobiert als SMA als Lösungsansätze angibt.

    Nun kam mir noch eine Idee, und zwar beeinflusse ich die Laderegelung per Node-Red über Modbus.

    Nicht, dass der Traffic vielleicht deswegen grenzwertig ist und der Island irgendwann abschaltet.

    Gruß Thorsten


    44 Module mit insg. 14,75kWh

    SMA SunnyBoy 3.0 für Ost/West (6/8 Stück)

    SMA SunnyBoy 2.5 für Süd (8 Stück)

    SMA Tripower 6.0 für Ost (10/12 Stück)

    SMA Sunny Island 6.0H-13 mit LG ESS Batteriemodule (insg. 19,2 kWh)

  • War der Zugriff über WLAN denn zwischendurch möglich?

    Wie lange hat der Island denn ohne Fehler funktioniert?


    Ich hatte auch mal das Phänomen beobachtet, dass er nur sauber läuft, wenn man sich nicht andauernd auf sein webinterface verbindet. Also einfach in Ruhe lassen. Was wiederum dafür sprechen könnte dass node-red evtl. Probleme machen könnte. Soll ich dir mal ein Backup meiner setting schicken?


    Mit welchen Fehlern schaltet der SI denn eigentlich ab?

    21 x Q.PEAK DUO BLK-G5 320
    1 x STP 6000TL-20 Tripower

    1 x SI 4.4-13 + 14,4kWh Speicher (Batrium)

    Sunny Home Manager 2.0

  • Hi.


    Im SunnyPortal steht "Kommunikation gestört" und wenn ich den Zustand wieder behoben habe "Zustand ok".

    Im Ereignisprotokoll des Island steht bedeutend mehr Einträge, aber nicht jeder führt zu dem Problem, dass der Island nicht mehr erreichbar ist.

    Wenn er erreichbar ist, dann über LAN und WLAN. Im Fehlerfall überhaupt nicht, weder LAN noch WLAN.

    Laut Portal-Logbuch trat der Fehler gestern nur einmal auf, es waren aber 5x, dass er nicht erreichbar war.


    Ich habe gestern die Anbindung von Node-Red gekappt und werde es jetzt mal eine Weile ohne laufen lassen. Aber Einträge gab es dennoch schon, nur noch keinen Fehler.

    Die Integration von Home Assistant habe ich aktiv gelassen, da die erst seit Jahresanfang läuft und der Fehler ja schon seit Jahren ist.

    Dies steht in der Anweisung von SMA: "Aus Gründen der Systemstabilität soll der zeitliche Abstand zwischen Datentransfers über das Modbus-Protokoll mindestens 10 Sekunden betragen. Dabei sollen gleichzeitig nicht mehr als 5 Parameter und Messwerte pro SMA Wechselrichter übertragen werden."

    Bei mir sind es 6 Parameter, weil man die für eine Regelung per Modbus braucht und dann eben alle 10s.

    Und ja, bitte schick mir mal Deine Konfig. Vielleicht gibt es ja Aufschluss.

  • Bitte halte uns auf dem Laufenden! Ich versuche auch schon seit einem Jahr von SMA und meinem Installateur eine Lösung zu bekommen aber bisher kam NIX. SMA hat echt den schlechtesten Support, den ich je erlebt habe. Meine Tickets werden einfach geschlossen und auf den Installateur verwiesen, der sich wiederum an SMA wendet und keine Lösung bekommt...


    Ich habe glücklicherweise ein Workaround für meinen Fall gefunden. Bei mir lässt sich die Kommunikationsunterbrechung mit einem Neustart des Switches beheben. Habe damals auch extra zwei Zyxel GS1200-8 gekauft aber auch mit denen sind die Kommunikationsunterbrechungen aufgetreten. Ich hab jetzt ein Shelly vor den Switch gehängt und sobald eine Kommunikationsunterbrechung auftritt, schaltet der Shelly den Switch aus und wieder an. Somit kann ich zumindest die Unterbrechung auf ca. 1 Minute oder so automatisiert minimieren. Dieser Workaround funktioniert bei mir einwandfrei, ist aber natürlich keine Lösung und ich finde es eine bodenlose Frechheit, dass man hier keine Hilfe seitens SMA bekommt. Mit derzeitigem Stand würde ich nie wieder SMA verbauen und kann es auch niemandem empfehlen.


    Da du deinen Sunny Island mit Node-Red steuerst, weißt du ob es ein Register gibt mit dem ich dem Wechselrichter sagen kann: "Du sollst jetzt Überschussladen!" Bei mir ist nämlich oft das Problem, dass er an Schlechtwettertagen vom Vormittag einfach alles einspeist anstatt zu laden und am Nachmittag dann nicht mehr genug Sonne zum Vollladen vorhanden ist.

    Ich möchte jetzt aber keine Regelung basteln mit Wirkleistungsvorgabe zum Laden... Einfach nur eine Funktion, die Einspeisen deaktiviert und Überschussladen aktiviert. Weißst du ob es sowas gibt?


    LG Tobi

    20kWp Enphase Microwechselrichter PV-Anlage

    24kWh BYD LVS Batteriespeicher

    3x Sunny Island 6.0h-13 Batteriewechselrichter

  • Hi tobik176

    Wie Du selbst schreibst, grauenvoller Support von SMA.

    Da erklärt man denen, was schon alles gemacht wurde und die kommen mit ihrer Standardantwort.

    Bei jeder Antwort von denen hat man das Gefühl, dass die überhaupt nicht lesen, was man vorher geschrieben hat.


    In meinem Fall reicht ein/aus vom Switch nicht immer, muss dann schon den Island komplett ausschalten. Sonst hätte ich schon längst ein Skript geschrieben, dass den Switch neu startet. Hatte allerdings schon mal festgestellt, dass noch Traffic läuft, obwohl der Island nicht erreichbar ist, als wenn nur das Webinterface abschmiert. Man bekommt dann allerdings auch keine Daten mehr.


    Beim Island ist es leider so, dass Du das BMS auf manuelle Steuerung setzen musst, um dann die Lade- bzw. Entladeleistung vorgeben zu können. Dies muss dann mit einem Intervall von 10 bis max. 60s erfolgen.

    Aber bei Dir hört es sich so an, als wäre im Portal das prognosebasierte Laden aktiv, das müsste deaktiviert werden.

    Der Vorteil der Steuerung über Node-Red ist aber auch, dass die Batterie nur über Netz geladen wird, wenn Erhaltungsgrenze erreicht wurde und nicht auch dann, wenn unterer Schwellwert erreicht wurde.


    Ich habe es so gelöst, dass ich nicht immer mit der vollen Leistung lade, sondern dies vom Ladezustand abhängig mache und sollte binnen 3h Regen bevorstehen, wird mit voller Leistung geladen. Außerdem lade ich sie nur einmal im Monat auf 100%, ansonsten immer auf 97%. Dies schont auch die Batterie.

    Gruß Thorsten


    44 Module mit insg. 14,75kWh

    SMA SunnyBoy 3.0 für Ost/West (6/8 Stück)

    SMA SunnyBoy 2.5 für Süd (8 Stück)

    SMA Tripower 6.0 für Ost (10/12 Stück)

    SMA Sunny Island 6.0H-13 mit LG ESS Batteriemodule (insg. 19,2 kWh)

  • Wenn du über Lan verbunden bist, schalte dein Wlan aus.


    Grund dafür ist, das du sonst 2 ip adressen für den sunny island hast. da beginnt es zu hacken.

    Matthias_Roeschinger

    Ich habe im Island zwei statische IPs eingestellt.

    Aber zum Verbindungsabbruch kam es auch schon, bevor ich WLAN aktiviert hatte.


    @all

    Fehler ist heute wieder aufgetreten bei einem Ladungszustand von 97%.

    Netzwerkkabel ziehen reichte nicht, Gerät musste aus- und wieder eingeschaltet werden.

    Heute ging allerdings der Fehler 7619 voraus.

    Und am Modbus-Zugriff lag es also auch nicht.

    Gruß Thorsten


    44 Module mit insg. 14,75kWh

    SMA SunnyBoy 3.0 für Ost/West (6/8 Stück)

    SMA SunnyBoy 2.5 für Süd (8 Stück)

    SMA Tripower 6.0 für Ost (10/12 Stück)

    SMA Sunny Island 6.0H-13 mit LG ESS Batteriemodule (insg. 19,2 kWh)

  • Bei jeder Antwort von denen hat man das Gefühl, dass die überhaupt nicht lesen, was man vorher geschrieben hat.

    bei fast allen so, herstellerübergreifend, das sind callcenter die in pakistan oder wer weis wo nur textbausteine abspulen.



    Fehler ist heute wieder aufgetreten bei einem Ladungszustand von 97%.

    kommunikation mit lifepo ?

    da sollte das bms regieren, überspannungsproblem, bms oder und si schalten dann ab.

    als lipo kann man sinniger weise die parameter im si nicht bearbeiten.

    was für ein lipo ist das ? 15zeller oder 16zeller ?

    16zeller sollte besser funktionieren, bei 15zeller fehlen einfach 3,6v, ladeschluss ist dann 51,5v ,

    kann man im si aber nicht runterdrehen.

    macht ja angeblich die kommunikation mit bms....... wenn sie dann vorhanden.

  • Der Fehler betrifft die Kommunikation mit dem Home Manager bzw. die Verbindung direkt zum Island.

    Was hat das mit dem BMS zu tun?

    Außerdem sind alle drei LEDs grün wenn das passiert.

    Gruß Thorsten


    44 Module mit insg. 14,75kWh

    SMA SunnyBoy 3.0 für Ost/West (6/8 Stück)

    SMA SunnyBoy 2.5 für Süd (8 Stück)

    SMA Tripower 6.0 für Ost (10/12 Stück)

    SMA Sunny Island 6.0H-13 mit LG ESS Batteriemodule (insg. 19,2 kWh)