prpd - NEDAP PowerRouter via HTTP und RS485 auslesen

  • Vielen Dank. Gerade von Arbeit heim, dein Image aufgespielt. Soweit so gut. Was schreibe ich bei powerinterface login ?

    Falls du da noch dran hängst... Wenn du unbedingt via SSH drauf willst, dann ist das "pi" und "raspberry". Gib mal die IP im Browser ein und häng ein :3000 dran. also 192.168.1.27:3000 (nur als Beispiel, ich kenn deine IP nicht), dann müsstest du in Grafana landen (Benutzer: admin, Passwort: admin). Ein mal auf "Home" klicken, und das Dashboard auswählen, dass du sehen möchtest.


    FreakErn: Kann man auf einen Raspi4 das dein Powerrouterprogramm und Pihole zusammen laufen lassen? Oder brauch ich 2 Raspi?

    Neue Raspis sind ende der Woche da, meine alte Raspis schaffen noch nicht mal das herunterladen von einen Update von Noobs in eine halbe Stunde ;-)

    Wie hallo000de schon schrieb, dass wird nicht funktionieren. Es läuft AdGuard drauf, was das gleiche macht wie pihole. Du könntest AdGuard durch pihole ersetzen, aber das würde nur funktionieren, wenn du deinen gesamten Traffic durch den PI jagen würdest...

    Der PI ist als Router konfiguriert. Alles geht nur in eine Richtung. Von der USB-Netzwerkkarte zu der Onboard Netzwerkkarte.

    Ich hatte meinen Rechner schon an der USB-Netzwerkbuchse und bin über den PI ins internet gegangen und AdGuard hat alles mit Protokolliert und hätte auch Werbung geblockt, wenn ich das konfiguriert hätte. Geht, aber ob man das will ist eine andere Sache.

  • Vielleicht könnte man die Zonen ändern in der Firewall und zumindest dns erlauben, dann könnte man AdGuard durch pihole ersetzen. Dann könnte man auch von der Onboard Netzwerkbuchse eine DNS Anfrage an den PI stellen. Ich überlege mal drauf rum. Eigentlich will die Firewall das nicht :D - aber vielleicht lässt sie sich überreden.

  • Vielen Dank an alle, besonders an hallo000de für seine persönliche Betreuung. Läuft alles :)

    PR37SB-BS/S240, erst Enersys SBS 190F jetzt Enersys PC1800-FT

  • Mal eine Frage abseits der verwendeten Frontends.

    Ich nutze ja das Plugin für FHEM, aber das ist ja nur die Darstellung, die ermittelten Werte sind ja die, die der Powerrouter per umgebogenen DNS postet.


    Hat es schon jemand geschafft, die Verbrauchs- und Ertragswerte von mypowerrouter.com irgendwie nachzustellen? Ich dachte bisher, das wären die Differenzen der Gesamtmengen (Modul 16, Param 4&5, Modul 12, Param 11 sowie Modul 136, Param 3&4) Ich habe die Daten jetzt 2 Wochen im minutentakt erhoben, allerdings habe ich für alle gewählten Zeiträume *immer* Abweichungen in der Größenordnung 10% ..


    Hat das jemand schon mal nachgerechnet?

  • Das ist mir auch schon aufgefallen, ich kann gerade nur Vermutungen anstellen... Ich gehe davon aus, dass die Nedap Leute den Verbrauch anhand der Last, die sie minütlich bekommen berechnen, statt die Fix Werte zu nehmen und dadurch ergeben sich Abweichungen. Könnte man vielleicht mal testen und den Powerrouter vom Internet nehmen, wenn gerade sehr hoher oder sehr niedriger Wert an die Powerrouter Seite übermittelt wurde und schauen ob die Differenz sich dann weiter auseinander bewegt, oder so.

  • Das ist mir auch schon aufgefallen, ich kann gerade nur Vermutungen anstellen... Ich gehe davon aus, dass die Nedap Leute den Verbrauch anhand der Last, die sie minütlich bekommen berechnen, statt die Fix Werte zu nehmen und dadurch ergeben sich Abweichungen. Könnte man vielleicht mal testen und den Powerrouter vom Internet nehmen, wenn gerade sehr hoher oder sehr niedriger Wert an die Powerrouter Seite übermittelt wurde und schauen ob die Differenz sich dann weiter auseinander bewegt, oder so.

    Ne, das kann nicht sein. Durch meine Programmierung an FHEM war mein Wechselrichter mehrfach offline. Im Portal war dann der Verbrauch in der Zeit, in der der Wechselrichter offline war, immer 0 und in der Stunde, wo der wieder online ging, ware der gesamte Verbrauch dann auf diese Stunde gebucht. Das lässt eher vermuten, dass die nur die Differenz der Kummulierten Werte betrachten. Und genau diese werte ich auch aus und bekomme diese mindestens 10% Abweichung ...


    Siehe auch den Screenshot, zwischen 11 und 19 Uhr war mein Wechselrichter (wegen meiner Experimente) offline ..

  • Das ist mir auch schon aufgefallen, ich kann gerade nur Vermutungen anstellen... Ich gehe davon aus, dass die Nedap Leute den Verbrauch anhand der Last, die sie minütlich bekommen berechnen, statt die Fix Werte zu nehmen und dadurch ergeben sich Abweichungen. Könnte man vielleicht mal testen und den Powerrouter vom Internet nehmen, wenn gerade sehr hoher oder sehr niedriger Wert an die Powerrouter Seite übermittelt wurde und schauen ob die Differenz sich dann weiter auseinander bewegt, oder so.

    Ne, das kann nicht sein. Durch meine Programmierung an FHEM war mein Wechselrichter mehrfach offline. Im Portal war dann der Verbrauch in der Zeit, in der der Wechselrichter offline war, immer 0 und in der Stunde, wo der wieder online ging, ware der gesamte Verbrauch dann auf diese Stunde gebucht. Das lässt eher vermuten, dass die nur die Differenz der Kummulierten Werte betrachten. Und genau diese werte ich auch aus und bekomme diese mindestens 10% Abweichung ...


    Siehe auch den Screenshot, zwischen 11 und 19 Uhr war mein Wechselrichter (wegen meiner Experimente) offline ..

    Man darf auch nicht vergessen das der Powerrouter ca. 60-95 Watt/h Watt selber verbraucht für sein System (wenn er läuft)...nur mal so ein Gedanke, denn das sagt Nedap nicht----------- ich glaube sogar 100 Watt wenn er läuft---- Online ist.

    Das bedeutet im besten 60 Watt Fall 1,44 KwH Verbrauch am Tag 24 H... nur mal so ein Gedanke... und ja wieder mal.

    Dies kann man nur erkennen in der Summe vom 3 Phasen-Sensor.

  • Ich habe die letzten beiden Tage mit den beiden Bei mir eingesetzten Raspiversionen und der Nedapseite verglichen. Die ermittelten Werte für Verbrauch und Einspeisung aus dem Netz (Plattform condumed und produced) decken sich nahezu komplett. Man muss allerdings in Grafana die Differenz für 24 Std. wählen. Da so wie ich vermute die Auswertung von Nedap ca. 15 Minuten verzögert ermittelt wird, ergeben sich minimale Abweichung, sagen wir 50 Watt o.ä.). Ebenso stimmen die Werte für das Batterie laden und entladen, auch hier muss man mit Grafana die Einstellung als Differenz ermitteln (Battery consumed bzw produced) . Dann passt das 100%. Nur der Solarertrag weicht ungefähr um die 1,4KW ab. Das könnte die von hallo000de gemachte Ursache sein. Dann passt alles. Das einzige Problem wie schon erwähnt ist, das man den direkten Eigenverbrauch in Grafana nicht anzeigen kann. Dafür müsste man in Influx eine Berechnungsspalte einbauen. Ebenso für die Aurarkieberechnung. Das sind meine Erfahrungen der letzten beiden Tage.

    Gruss Frank

    Frank