prognosebasierte Ladung mittels ioBroker

  • ich habe ja nur den Vorgänger Battery Box HV , aber bei 3,3V / Zelle ist mein SOC bei über 70%

    hat sich die Zellchemie geändert? sonst würde ich jetzt mal diese 21% SOC anzweifeln

    29,44kWp, 16 Südost, 9,6 Südwest, 3,84 Nordwest

    6,4kWh BYD B-Box HV (KfW40plus Haus, Abregelung bei 68%)

    SMA SHM 2.0, STP 20000-30, SB 5.0-41, SBS 2.5-10

    optimierte Batterieladung mittels Script über Modbus

  • Maverick78 , BigTom91 die genannten modbus.1-Register (SBS) haben vernünftige Werte, nur die modbus.0-Register (SB5.0) in dem anderen Screenshot nicht...


    Aber wenn es ein prinzipielles Problem mit dem Laden gibt, muss ich wohl da erst mal den Fehler suchen.

    Vielen Dank für den Hinweis!

    5,9kWp West-Ost

    SMA SB5.0 + SHM2

    SBS 2.5 + BYD HVS 5.2kWh

  • Gibt es beim SMA nicht eine Option, das anhand der Erfahrung der Speicher nur nichtsozialistischen voll geladen wird, dass der erwartete Verbrauch gedeckt wird.

    Sieht mir nach diesem Prinzip aus.


    Stefan

    Ich finde auch dass es so aussieht, dass der SHM die Akkuladung "optimiert" bzw. überoptimiert. Ich finde aber keine Option, um ihm das abzugewöhnen. Ich möchte einfach nur, dass der Akku erst mal voll gemacht wird, deswegen auch der Versuch mit dem Skript.

    Im Sunny Portal habe ich seit Januar nichts verändert (Eigenverbrauch, ökologische Optimierung), nur das prognosebasierte Laden habe ich jetzt ausgeschaltet.


    Vielen Dank,

    Christian

  • Im Sunny Portal habe ich seit Januar nichts verändert (Eigenverbrauch, ökologische Optimierung), nur das prognosebasierte Laden habe ich jetzt ausgeschaltet.

    Was verstehst Du unter jetzt?

    Das wäre nämlich genau diese Verhalten...

    https://sma-sunny.com/prognose…speichern-statt-abregeln/


    Stefan

  • LumpiStefan mit "jetzt" meinte ich vor ein paar Tagen, als ich gesehen habe, dass der Akku jeden Tag weniger aufgeladen wird.

    5,9kWp West-Ost

    SMA SB5.0 + SHM2

    SBS 2.5 + BYD HVS 5.2kWh

  • Ich finde auch dass es so aussieht, dass der SHM die Akkuladung "optimiert" bzw. überoptimiert. Ich finde aber keine Option, um ihm das abzugewöhnen. Ich möchte einfach nur, dass der Akku erst mal voll gemacht wird, deswegen auch der Versuch mit dem Skript.


    Das Script kann aber keine Ladung erzwingen wenn es an anderer Stelle klemmt.

    Schalte einmal alles aus, scripte, Wechselrichter und Batterie und starte alles neu. Erst mal WR und Batterie und schau dann ob überhaupt etwas lädt. Wenn es dann immer noch nicht geht, muss wohl der Fachmann ran.

  • Mir sieht das auch nach einem Defekt an der Anlage aus. Ich kann mich nur den Vorrednern anschließen: Prognosebasiertes Laden aus, Maverick's Script anhalten. Bei ausreichend Sonne muss die Batterie ohne Wenn und Aber schnellstmöglich bis 100% geladen werden, sonst ist etwas grundsätzliches faul.


    BTW: Nachdem mein ioBroker ein paar Monate Pause hatte, habe ich vor ein paar Tagen eine neue Installation mit dem aktuellen Script von Maverick78 an den Start gebracht. Lief alles auf Anhieb, wie geschmiert.


    Falk

    8,1 kWp Süd-West mit großer Gaube
    30 x Trinasmart 270Wp, SMA STP 8000TL-20
    Sunny Island 4.4, Sony Fortelion 9,6 kWh

  • ich habe ja nur den Vorgänger Battery Box HV , aber bei 3,3V / Zelle ist mein SOC bei über 70%

    hat sich die Zellchemie geändert? sonst würde ich jetzt mal diese 21% SOC anzweifeln

    psy35i deine Zweifel sind berechtigt:

    Ich habe wie hier empfohlen die Parametertabellen auf V9.2 upgedatet und daraufhin hat sich der SOC heute nach knapp 1kWh Ladung von 6 auf 100% verändert ;-)

    Ich bin gespannt, ob es jetzt wieder läuft.

    5,9kWp West-Ost

    SMA SB5.0 + SHM2

    SBS 2.5 + BYD HVS 5.2kWh

  • Mal eine Frage an alle:


    Nachdem meine neue ioBroker - Installation ein paar Tage problemlos lief, habe ich seit gestern wieder ständig die Fehlermeldungen vom modbus adapter:


    Code
    modbus.0    2021-04-12 12:14:57.544    warn    (2707) Poll error count: 1 code: {"err":"timeout","timeout":5000}
    modbus.0    2021-04-12 12:14:57.543    error    (2707) Client in error state.
    modbus.0    2021-04-12 12:14:57.542    error    (2707) Request timed out.
    modbus.0    2021-04-12 12:14:57.542    warn    (2707) Error: undefined

    Hat das von euch auch jemand (gehabt) oder kennt jemand eine Lösung dafür?


    Falk

    8,1 kWp Süd-West mit großer Gaube
    30 x Trinasmart 270Wp, SMA STP 8000TL-20
    Sunny Island 4.4, Sony Fortelion 9,6 kWh

  • Ich habe das unter 2 Konstellationen gesehen:

    1. Das Script läuft 2x, da iobroker intern irgendwas schief gelaufen ist. EIn Indiz dafür sind doppelte Log Einträge -> Abhilfe: Javascript Adapter neustarten, dann modbus Adapter neu starten

    2. Das Poll Intervall vom Modbus Adapter ist zu kurz und der WR ausgelastet. -> Abhilfe: Poll Zeit erhöhen (ich habe z.b. 4000ms stabil in Betrieb)