Installation volkszaehler, bei Start Frontend Network error: not found

  • Mein Vorschlag wäre: Hau mal den anderen Server raus und schau ob der VZ mit Beispielkonfig läuft (wovon ich ausgehe).



    mfg JAU

    No Shift - No Service

  • Habe jetzt nur Beispielkofig für den Volkszähler in der nginx Konfig.


    Bei Aufruf des Frontends kommt weiter die Fehlermeldung "network error: not found".


    Dafür liefert der aufruf "http://192.168.178.200/middleware.php/capabilities/database.json" etwas zurück (s. Anhang):

    "An exception occurred in driver: SQLSTATE[HY000] [1045] Access denied for user 'vz'@'localhost' (using password: YES)"

  • Wenn ich die root Angabe in der nginx Konfig kürze auf "root /var/www/html" bekomme ich beim Aufruf des Frontends diese Meldung:



    Also irgendetwas pass noch nicht mit meinem User "vz".


    Gruß Jens

  • Stop.


    Im Eingangsposting hattest du geschrieben du hattest Fehler "not found". Ich bin davon ausgegagen das wäre ein HTTP Errorcode 404. Es scheint aber die Meldungsbox vom Frontend selbst zu sein. Dann ist der Webserver erstmal ok und nicht total vergurkt.


    Dafür liefert der aufruf "http://192.168.178.200/middleware.php/capabilities/database.json" etwas zurück (s. Anhang):

    "An exception occurred in driver: SQLSTATE[HY000] [1045] Access denied for user 'vz'@'localhost' (using password: YES)"

    Das bedeutet die Middleware hat keinen Zugriff auf die Datenbank. Da geht es auch nicht unbedingt um Zugriffsrechte sondern die Frage ob der korrekte Datenbankserver mit korrektem User und korrektem Passwort von eine zugelassene Host angesprochen wird.



    mfg JAU

    No Shift - No Service

  • Das war die Meldung zu meinem Eingangspost bei Aufruf des Frontends:



    Die Meldung bzgl. User "vz" kam erst im Frontend, als ich nur die Konfig für den Volkszähler in der Konfig für den nginx Webserver stehen hatte.


    Daher denke ich, dass ich an der Konfig für den Webserver arbeietn muss (wie von Jau vorgeschlagen). Für den Zugriff auf die Datenbank mit User "vz" könnte ich noch Tipps gebrauchen, wo ich nachschauen bzw. etwas ändern kann


    Danke

    Jens

  • Jetzt habe ich in der Datenbank das Passwort für den User "vz" nochmal gesetzt auf "demo".


    Dann liefert der aufruf "http://192.168.178.200/middleware.php/capabilities/database.json" etwas sinnvolles zurück (s. Anhang). Dazu hatte ich die nginx Konfig wieder auf die Volkszaehler Einstellungen gesetzt (am Thema Subdomain arbeite ich noch).


    Die oben zitierte Fehlermeldung "Network Error: Not found" beim Öffnen des Frontends ist aber weiter vorhanden.

  • Versuch mal diese Serverconfig:


    Alternativer Ansatz wäre options.js auf

    Code
    url: 'middleware.php'

    zu setzen.



    mfg JAU


    P.S. Ja, das hieße Fehler im Wiki.

    No Shift - No Service

  • Für den Zugriff auf die Datenbank mit User "vz" könnte ich noch Tipps gebrauchen, wo ich nachschauen bzw. etwas ändern kann

    Wird in ./etc/config.yaml konfiguriert. User und Passwort müssen natürlich zu dem passen was im Datenbankserver gesetzt ist.



    mfg JAU

    No Shift - No Service