PIKO Solar Portal shows no monitoring data

  • Dear forum users,


    first of all, please excuse me if I do not speak German, but this is the only forum I have found on the subject.


    We have 11 Piko 10.1 Dcs inverters with firmware 3.70 + 1 Piko 4.2 Dcs inverter with firmware 3.60 that were added to the piko-solar-portal.com monitoring portal on 20/04/2019 using a new account.


    All inverters are connected to the internet via a switch and a router that allows any outgoing connection so, the monitoring server http://www.pikoloop.de is correctly reachable and the message "PIKO Server, v2.1.0.0" is displayed on a client pc.


    From the internal inverter webserver I have specified an unique ip address for each inverter, the router ip address on the gateway field an made various test using different dns from Opens dns, Google and the standard 145.253.2.203 dns.


    After entering the portal code P3421 all inverter were successfully added to the portal by entering the corresponding item number and serial number: this seems to mean that tcp/ip connectivity with the portal has been established successfully.


    The problem is that no inverter has ever transmitted monitoring data and the history of the piko-solar-portal.com portal is empty even after the “go online” command.


    Any help would be much appreciated.


    Regards

  • No.

    I've never heard of the PikoOp.de and the PikoOP.com server, but according to the whois information they both belong to Leopold Kostal GmbH u. Co. KG.

    If you did register your inverters succesfully, the data should appear on the website, unless you did things like clicking on one of the the three symbols on the right

    https://www.piko-solar-portal.…rterHasPlantShowGrid.aspx

    You should never do this unless you you have to replace an inverter, and if you did, you have to contact customer support.

    Guess why I know about this fact.

    Anlagenstandort Köln. in allen Strings verteilt insgesamt 12x TIGO TS4-O mit Monitoring

    2018 31x 320W Q-Cells an Kostal Piko 8.3

    2019 30x 325W Q-Cells an Kostal Plenticore plus 7.0

    2019 2x 325W Q-Cells plus 1x 320W Q-Cells mit je einem Tigo direkt per DC am WW Boiler.

  • Broadcasttechniker thanks for your answer.


    No action was performed using the symbols to the right of the inverter.


    The official Kostal support told me that it was necessary to enable the firewall to allow connections to the hostname www.pikoloop.de (IP 85.25.121.29, Port TCP 80 (HTTP)) so that the inverters can send data to the monitoring server accessible via web from www.piko-solar-portal.com


    After configuring the inverters, they have been added to the portal www.piko-solar-portal.com and are correctly visible, as can be seen from the image link here


    If, as I think, the fact that the inverters have been added to the portal means that they have successfully established a tcp connection, then the problem could be in the server itself.


    Perhaps the Kostal technicians who attend this forum will be able to say something about this.

  • The portal had a lot of problems in the past, an it it is still not running perfectly.

    But at least you should see your inverters by clicking on "Consumo, Rendimento e Potenza"

    There you should see RESOCONTO POTENZA GIORNALIERA

    Under "Misura" click on "Rendimento [kWh]" and chose "Anno"

    Still nothing to see?


    After sending the “go online” command, what does the info site on your Piko tell you?

    Last connection 1 minute would be the correct answer.


    On my router I checked the option "Device can manage ports on it's own".

    Anlagenstandort Köln. in allen Strings verteilt insgesamt 12x TIGO TS4-O mit Monitoring

    2018 31x 320W Q-Cells an Kostal Piko 8.3

    2019 30x 325W Q-Cells an Kostal Plenticore plus 7.0

    2019 2x 325W Q-Cells plus 1x 320W Q-Cells mit je einem Tigo direkt per DC am WW Boiler.

  • The portal had a lot of problems in the past, an it it is still not running perfectly.

    But at least you should see your inverters by clicking on "Consumo, Rendimento e Potenza"

    There you should see RESOCONTO POTENZA GIORNALIERA

    Under "Misura" click on "Rendimento [kWh]" and chose "Anno"

    Still nothing to see?

    Not a single monitoring data ever appeared under those section that were and actually are always empty.


    Zitat

    After sending the “go online” command, what does the info site on your Piko tell you?

    Last connection 1 minute would be the correct answer.

    I do not remember the exact message, but the Kostal manual says that after entering the portal code on the inverter webserver, you should wait 20 minutes for the inverter to log in on the portal before manually entering its serial number on the portal itself.


    Therefore, if the inverter has successfully logged in and was successfully added on the portal, this means that is not a client side connection problem.


    Zitat

    On my router I checked the option "Device can manage ports on it's own".

    All outgoing connections to all ports are allowed on my router

  • Can someone please suggest an alternative portal other than piko-solar-portal.com ?


    I think that the problem is clearly not client side, but portal side related.

  • Please change in the plant options how often they could send the data. If they are older, they had a lot of data. With every command "go online" you will send the next package or the portal will manage it and it takes time. Could you send me one of the serial numbers via PN to check something.

    Bei Service-Fragen wenden Sie sich bitte an service-solar@kostal.com oder rufen Sie unsere Hotline +49 761 47744 – 222 an.

  • Please change in the plant options how often they could send the data. If they are older, they had a lot of data.

    Thank You for your answer.


    In the portal, the option to send data is configured with the shortest available time interval of one hour.

    Zitat
    With every command "go online" you will send the next package or the portal will manage it and it takes time.

    The first portal configuration was made on 20/04/2019 adding all the inverters to the piko-solar-portal.com monitoring portal using a new account.

    Zitat

    Could you send me one of the serial numbers via PN to check something.

    Pm sent.

  • I saw that in the piko-solar-portal.com, in the plant section, there is a tab called "Events" which shows the entries "Event class = Inverter: Communication Failure" and "Event Code = 10000" for each inverter on a daily basis.


    See photo: https://i.imgur.com/hP5mlOf.png


    Can someone tell me where to find the meaning of these events or explain the meaning of these events ?