Solarview für Linux unterstützt nun MQTT

  • Hallo, habe das noch einmal neu aufsetzen müssen, weil der Raspi zu viel zu tun hatte und bei einer Anwendung ins Stolpern kam. Solarview läuft nun mit RPIEasy zusammen auf einen Raspi3. Apache ist auf Port81 wo das PHP-Script für die obis Datei liegt. Solarview ist in einem Verzeichnis einer Netzwerkverbindung auf einer Diskstation installiert, die Autostart ist angepasst. . Es läuft, doch ich bekomme eine Fehlermeldung: "/var/tmp/tmp.html: Keine Berechtigung," Auch die Erzeugung der obis.txt funkioniert noch nicht. Da gibt es wohl auch Probleme mit den Rechten. Wie kann ich es einrichten, dass die /var/www/html/obis.php als www-data in das Verzeichnis /home/pi/svrpi/obis schreiben darf?

  • Hallo Manfred,

    ich habe heute die MQTT Übertragung zum FHEM in Betrieb genommen.

    Daten kommen an - wunderbar, Konsistenzen muss ich die Tage mal testen.


    Eine Frage oder ein Wunsch zur Erweiterung.

    Der d0 Anschluss sendet alle 10 Sekunden neue Daten, die jetzt auch in FHEM ankommen. Das Timing hängt demnach nicht nur von den angeschlossenen Wechselrichtern ab.


    Ließe sich das Intervall verlängern? Eventuell durch einen zusätzlichen Parameter in deiner Def?

    Ich brauche die Daten wirklich nicht in diesen kurzen Abständen und das würde auch die Systembelastung verringern.


    So in dieser Art vielleicht:

    MQTTPublishVals=.........
    MQTTTopic=solarview
    MQTTPort=1883
    MQTTHost=...........

    MQTTUpdate=600 (für alle 10 Minuten)


    VG Helmut

  • Hallo,

    ich benutze den ioBroker als MQTT-Server. Komischerweise kommen nicht alle Werte an von Solarview an, siehe Grafik:

    IDC, PAC und UDC stehen auf Null. Hat sich irgend etwas an den Benennungen geändert, oder muss eine bestimmte Reihenfolge im Transfer eingehalten werden?

    Code
    MQTTPublishVals=PAC,UDC,IDC,KDY,KMT,KYR,KT0,PAC
    MQTTWR=WR0
    MQTTTopic=solarview
    MQTTPort=1883
    MQTTHost=192.168.....
  • MQTT: IDC und UDC haben nach wie vor eine 0 als Wert im ioBroker, während PAC nun einen Wert liefert.

    Solarviewdatareader: Obige Variable bringen im ioBroker einen Wert mit, allerdings sind die Namen klein geshrieben.

    Gibt es irgendwelche weitergehenden Einstellungen für MQTT, damit die Werte geliefert werden können?

  • Ich habe das selbst gelöst und schreibe nun direkt in www, wo sich Solarview die Daten abholen kann. Habe www-data und pi in einer Gruppe.

  • Hallo Manfred. Es funktioniert jetzt, doch werden die Daten zwar graphisch dargestellt, fehlen aber als Textausgabe.