Solarlog 300 Bootreset Schleife ?

  • Hallo zusammen


    habe hier einen Solarlog 300 der sich ständig während dem boot reseted. Im Chiptool war er immer kurz sichtbar.

    Wollte das RTOS neu flashen jedoch hat er reseted während dem transfer bei ca. 56%.

    Nun kann er gar nicht mehr starten und ist auch nicht mehr im Chiptool zu finden.

    Was hat man noch für Möglichkeiten die RTOS wieder auf den Chip zu bringen ?


    Grüsse

  • Über Ethernet hatte ich es versucht, FW sollte älter als 3.5 gewesen sein.


    Gehts dann nur noch serielle ? Oder gibt es auch eine Möglichkeit das Hex File per SDCard zu flashen ?

  • Hallo,


    Hast du beim booten die reset Taste gedrückt

    Und erst losgelassen als chiptools den SL gefunden hat?


    Sonst geht es ab der 3.5 per Ethernet nicht.


    Kannst ja mal nur das RTOS auf die SD Kopieren,

    Wenn FW ok ist installiert er das RTOS auch von der Karte,

    Aber nur wenn es neuer ist.


    Gruß Verona

    7,995 kWp - 37 IBC 215TS - Solarmax + Mastervolt
    2,160 kWp - 12 Day4 180 - Solarmax
    2,250 kWp - 10 Sanyo HIP225 - Solarmax
    1,890 kWp - 06 Sunpower 315 - Mastervolt
    6,000 kWp - 24 Yingli 250 - 2 Steca
    12 kW ESS Peus-Testing
    http://www.solarlog-heckmann.de

  • Bin jetzt mal für ca. 5min auf dem Reset Knopf nach Poweron draufgeblieben, leider taucht er nicht mehr auf im Chiptool.


    Die SD Karte war defekt und nicht mehr lesbar, schätze mal die ist Teil der FW ?

    Oder geht das Update per SDCard auch mit dem HEX File auf ner leeren neuen SDCard ?

    Braucht das HEX File einen speziellen Namen wie auch das FW Upgrade Prozess ?

  • Hallo,


    Nicht nach sondern vorher reset drücken denn Strom einschalten,

    So ca 30 sek. Drauf bleiben...


    Das RTOS einfach wie es ist auf die SD Karte, nix umbenennen.

    Im Display erschein dann RTOS wenn es übertragen wird.


    Was zeigt das Display den beim booten an?


    Gruß Verona

    7,995 kWp - 37 IBC 215TS - Solarmax + Mastervolt
    2,160 kWp - 12 Day4 180 - Solarmax
    2,250 kWp - 10 Sanyo HIP225 - Solarmax
    1,890 kWp - 06 Sunpower 315 - Mastervolt
    6,000 kWp - 24 Yingli 250 - 2 Steca
    12 kW ESS Peus-Testing
    http://www.solarlog-heckmann.de

  • Jepp genau vorher schon aufm Reset drauf dann Power rein, hab das nur doof geschrieben.


    Im Display steht seit dem Fehlversuch per Chiptool gar nichts mehr.


    Auch jetzt mit SDCard und dem HEX ändert sich leider nichts.


    Es scheint ihm ganz früh im Bootvorgang zu schmerzen.

  • Hallo,


    Dann hast du den Flash leer gemacht...


    Schick mir das Ding, dann spiele ich das Image

    wieder auf...


    Gruß Verona

    7,995 kWp - 37 IBC 215TS - Solarmax + Mastervolt
    2,160 kWp - 12 Day4 180 - Solarmax
    2,250 kWp - 10 Sanyo HIP225 - Solarmax
    1,890 kWp - 06 Sunpower 315 - Mastervolt
    6,000 kWp - 24 Yingli 250 - 2 Steca
    12 kW ESS Peus-Testing
    http://www.solarlog-heckmann.de

  • Meinst du mit dem Image das RTOS ? Das scheint man immer über das serielle Interface neu flashen zu können bei diesem Chip, gibt es das denn auch auf dem 300 Board ?


    Habe hier auch noch einen 500er wo entweder das LAN Interface defekt oder er ein RTOS Problem hat, da habe ich vor die RS232 einzubauen um das mal zu versuchen.

  • Hallo,


    Mit Image meine ich den Inhalt vom

    Flash also RTOS, FW, Seriennummer, Hardwareconfig usw.

    Wenn du das generieren kannst kein Problem.

    Zum flashen brauchst du die RS232 nicht nachrüsten,

    es reichen drei Drähte und ein USB-TTL Adapter für 1€.


    Gruß Verona

    7,995 kWp - 37 IBC 215TS - Solarmax + Mastervolt
    2,160 kWp - 12 Day4 180 - Solarmax
    2,250 kWp - 10 Sanyo HIP225 - Solarmax
    1,890 kWp - 06 Sunpower 315 - Mastervolt
    6,000 kWp - 24 Yingli 250 - 2 Steca
    12 kW ESS Peus-Testing
    http://www.solarlog-heckmann.de