Volkszähler Spikes bei Zählerstand

  • Hallo zusammen nach vielen Hin und her und Hardwaretausch steht mein SmartHome Konzept nun.

    Leider funktioniert eine Sache noch nicht wirklich ich hoffe ihr habt einen Tipp.

    Ich habe nun einen Server mit mehreren virtuellen Maschienen. Dort läuft unter anderem der VZ.

    Ich mess mit einem Raspberry meinen Hausanschlusspunkt, wo sich ein 2 Richtungszähler befindet. Desweiterenhabe ich noch einen Zähler für die Hauslast. Dazwischen hängt eine PV Anlage.

    Diese ist auch mittels PHP skript angebunden und loggt die Date. Allerdings bekomme ich immer immer Spikes.

    das skript sieht folgerndermaßen aus

    Mit den Zeiten habe ich schon rumgespielt.

    Ich meine mich zu erinnern das hängt mit den Tuplles zusammen aber ich bekomme es nicht mehr zusammen.


    Gruß Nils

  • Sieht so aus als würde dein Script nach dem Intervall von 5 Minuten nochmal den alten und gleich darauf den neuen Zählerstand an die Middleware schicken, deswegen die schmalen Spikes bis 0W.


    Zeig mal die Rohdaten dazu.

  • Das was du angezeigt bekommst sind die berechneten Leistungswerte. Für die Rohdaten musst du &options=raw an die URL anhängen.


    Aber die Timestamps zeigen schon, dass da was schief läuft: du willst eigentlich alle 300s einen Wert loggen, schreibst aber einen nach 290s und dann nach nur 10s schon wieder...

  • Ja das Skript ist glaube ich etwa ungünstig um Zählerstände zu erfassen. Aber wie programmiere nur einen Wert mit dem richtigen Zählerstand zu bekommen ist mir nicht klar. Ich bräuchte ja nur den aktuellen timestamp und dann den Wert darauf, Skript dann einfach einmal alle 5min starten Habe mit den Einstellungen gespielt um nur einen Messwert zu bekommen. Und es funktioniert nicht schön aber es funktioniert. Danke für den Hinweis