IPPower visualisieren

  • Naja, da läuft der pigpiod Daemon, der den Zugriff blockiert. Der verwendet ebenfalls Port 8888 und wird vermutlich von Deinem Script gestartet, aber nie beendet. sudo killall -9 pigpiod sollte ihn beenden.

    Du hast zwei Möglichkeiten, entweder startest Du den pigpiod auf einem anderen Port (da gibt es einen Switch dafür) oder Du sorgst dafür, dass er nicht mehr gestartet wird, wenn du ihn nicht mehr benötigst.

    Du kannst auch mal versuchen, den Port für IPPower umzustellen, dazu den Parameter -gp 8889 beim Start von IPPower anhängen. Der Port darf zwischen 1024 und 32000 liegen.


    @Rainbow45:

    solarviewplot_functions.js und solarviewplot.js


    Grüsse,

    Manfred

  • Vielen Dank :thumbup::) - das war entscheidende Hinweis :danke: Damit komme ich weiter :danke:


    Wichtig ist, dass sich s0-fb dann den Port 8888 gekrallt hat, nachdem ich pigpiod stillgelegt habe. Mit dem zustätzlichen Parameter -gp 8889 in der start_ippower.sh scheint es zu klappen. Lässt sich auch für die S0-Erfassung der Port am Raspi ändern?

  • Nur mein Schalter schaltet nicht mehr, seit ich D0-Proxy installiert habe - ich hoffe, es liegt daran, dass noch kein Zähler abgefragt wird. Wechseltermin ist verschoben auf 16.4.2021. Hoffentlich läuft es dann wieder.

    das hab ich inzwischen auch gelöst. War mein Fehler - ich hatte mit der Solarview-fb-Startup.exe meine start.sh angepasst für D0-Start. Dabei hab ich den Haken für FHEM-Unterstützung aktivieren rausgenommen. Ich hab ja kein FHEM.
    Haken wieder rein, alles läuft wieder. Bin ich her zufällig in der Doku von IPPower drauf gestoßen, ist nicht eindeutig erklärt, finde ich.
    Jetzt läuft alles super.


    Danke an Manfred

    :danke:

  • Hallo zusammen,


    ich wollte heute die Schaltzustände visualisieren.

    Leider kommt bei mir kein neuer Tab.

    Im Verzeichnis werden aber Daten abgelegt !!

    Beim Start sieht es so aus, siehe Anhang:


    Es ist die interne Homepage.

    Wo liegt der Fehler?

  • Hallo Manfred,


    danke für die schnelle Antwort.

    Ich habe die Ordner "jqplot" und "icons" von Version 2.26 komplett nach "homepage" kopiert,

    die solarviewsettings.js habe ich zuvor "gerettet" und dann wieder zurückkopiert,

    SV gestoppt und neu gestartet.

    Die beiden Dateien werden minütlich aktualisiert.

    Ich habe jetzt:

    "Überwacht mit SolarView für Linux V 2.26 mit Plot Version 2.26"

    aber trotzdem keinen Tab mit "Schalter" ??

    Woran kann es noch liegen ?

  • Das kann ich so leider nicht beantworten, auf der externen Webseite von Dir wird noch die Plot-Version 2.22 angezeigt. Da werden definitiv keine Schalter dargestellt.

    Falls intern 2.26 angezeigt wird müsstest Du mal das Script-Debugging im Webbrowser aktivieren und nachschauen, ob dort ein Fehler angezeigt wird.


    Grüsse,

    Manfred