solarview@windows kann keine Daten vom raspberrypi holen, Fehler "Failed to change directory"

  • Hallo zusammen,


    ich bin vor kurzem mit Solarview von der Fritzbox auf einen Pi Zero W umgezogen, der ausschließlich die Portalüberwachung ausführt.

    Der Umzug hat reibungslos geklappt, alle Daten werden geloggt, die interne Hompage auf dem raspi ist problemlos erreichbar.

    Solarview@Windows zeigt mir allerdings keine neuen Daten nach dem Umzug mehr an. Die Daten werden im Verzeichnis /data auf dem Raspi abgelegt, können aber offensichtlich nicht importiert werden. Im Datenverzeichnis unter Windows sind keine Daten nach dem Umzug vorhanden. Demzufolge sind diese auch nicht in der Datenbank vorhanden. Die Einstellungen in Datenlogger.ini sind m.E. korrekt, und /data ist beim Test unter ftp://192.168.178.32/svrpi/data/ erreichbar.
    In der Log Datei wird ein Problem beim Import über ftp angezeigt. Einträge sehen wie folgt aus:


    09.02.2019 12:14:21 192.168.178.32/svrpi/data/20190117.dat

    FtpGetFile [doFTPTransfer] Error: 6

    09.02.2019 12:14:21 rcd Extd Err: 0 550 Failed to change

    directory.


    Ich habe bereits versucht die Berechtigungen des Ordners /data anzupassen, dies hat aber keine Abhilfe gebracht.

    Was kann ich tun, damit der Import wieder funktioniert?

    Dateien

    Gruß, Dirk
    PV 74,73 KWp aus 2010
    318 Yingli YL235P-29b 235W Polykristallin
    6 x Sinvert PVM 13 (Siemens / Refusol)

  • ...habe exakt das selbe Problem auf einem Raspi3, auch die gleichen Fehlermeldungen.

    Benutze solarview@windows schon seit vielen Jahren. Bin nun auf Raspi umgestiegen, funktioniert auch einwandfrei.

    Nur den Daten- Import nach solarview@windows bekomme ich nicht hin. Lese schon den ganzen Tag, komme aber nicht weiter. Bin für jeden Tip dankbar.


    Gruß, Bernd

  • ...ich bin ein bisschen weiter:

    Wenn ich in der Datenlogger.ini als FTP Pfad nicht nur ftp://192.168.0.159/svrpi/data/ eingebe, sondern den vollen Pfad ftp://192.168.0.159/home/pi/svrpi/data/ , werden die Daten korrekt importiert, und zwar vom aktuellen Datum an rückwärts bis zum Datum der ersten File auf dem Raspi (20181117), dann kommt diese Fehlermeldung im datenlogger.log:


    11.02.2019 13:38:24 192.168.0.159/home/pi/svrpi/data/20181116.dat FtpGetFile [doFTPTransfer] Extd Err: 0 200 Switching to Binary mode.

    227 Entering Passive Mode (192,168,0,159,29,182).

    550 Could not get file size.

    550 Failed to open file.


    11.02.2019 13:38:25 192.168.0.159/home/pi/svrpi/data/20181115.dat FtpGetFile [doFTPTransfer] Extd Err: 0 200 Switching to Binary mode.

    227 Entering Passive Mode (192,168,0,159,25,38).

    550 Could not get file size.

    550 Failed to open file.


    Das wiederholt sich für alle Files rückwärts bis zum 1. Januar 2010:


    11.02.2019 14:00:49 192.168.0.159/home/pi/svrpi/data/20100101.dat FtpGetFile [doFTPTransfer] Extd Err: 0 200 Switching to Binary mode.

    227 Entering Passive Mode (192,168,0,159,216,21).

    550 Could not get file size.

    550 Failed to open file.



    Anschließend kommt diese Meldung:


    11.02.2019 14:00:50 WR1-Änderung: TYP: 0 -> 20030 SWV: 0 -> 15 PIN: 0 -> 5000

    11.02.2019 14:00:50 WR2-Änderung: TYP: 0 -> 20020 SWV: 0 -> 15 PIN: 0 -> 3300

    11.02.2019 14:00:50 WR3-Änderung: TYP: 0 -> 20020 SWV: 0 -> 15 PIN: 0 -> 3300

    11.02.2019 14:00:50 WR4-Änderung: TYP: 0 -> 20020 SWV: 0 -> 15 PIN: 0 -> 3300

    11.02.2019 14:01:32 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:01:32 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:01:32 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:01:32 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:03:04 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:03:04 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:03:04 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:03:04 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:03:04 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:03:04 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:03:04 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:03:04 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]



    @DSchumacher

    Dirk, kannst du bitte mal ausprobieren, ob bei dir ähnliches passiert?


    Gruß, Bernd

  • Bernd ,


    die von dir beschriebene Umstellung im Pfad führt bei mir leider nicht weiter. Test in der datenlogger-Einstellung führt direkt zur Ausgabe von "550 Failed to change directory."
    In der Log-Datei sieht es dann so aus:


    11.02.2019 14:49:03 192.168.178.32/home/pi/svrpi/data/20190117.dat FtpGetFile [doFTPTransfer] Extd Err: 0 200 Switching to Binary mode.

    227 Entering Passive Mode (192,168,178,32,169,137).

    550 Could not get file size.

    550 Failed to open file.


    11.02.2019 14:49:05 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:49:05 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:49:05 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:49:05 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:49:05 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:49:05 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:49:05 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:49:05 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:49:05 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:49:05 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:49:52 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:49:52 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]

    11.02.2019 14:49:57 [13] Typen unverträglich erl: 0 [ParseResults]

    11.02.2019 14:49:57 [5] Ungültiger Prozeduraufruf oder ungültiges Argument erl: 0 [ParseResults]


    Danke für den Tipp.
    Vielleicht hat ja noch jemand anderes eine Idee, ich komm hier jedenfalls mit meinen Kenntnissen nicht weiter.

    Gruß, Dirk
    PV 74,73 KWp aus 2010
    318 Yingli YL235P-29b 235W Polykristallin
    6 x Sinvert PVM 13 (Siemens / Refusol)

  • Hallo,


    habe jetzt eine Lösung, die für mich das Problem behoben hat:


    In der datenlogger.ini die ip-Adresse des raspi durch den Namen des raspi ersetzen. In der Regel also folgendes:


    Vorher z.B.: ftp://192.168.0.159/svrpi/data/
    Nachher z.B.: ftp://raspberrypi/svrpi/data/


    Voila! Nach Neustart des Solarlogger-Dienstes funktioniert bei mir alles einwandfrei, die fehlenden Daten wurden anstandslos in die Datenbank übernommen. Warum die ip nicht akzeptiert wird, die Namensauflösung aber doch - verstehe wer will. Ich bin da raus.


    Bernd : Probier mal aus und berichte, ob es für dich auch funktioniert.

    Gruß, Dirk
    PV 74,73 KWp aus 2010
    318 Yingli YL235P-29b 235W Polykristallin
    6 x Sinvert PVM 13 (Siemens / Refusol)

  • Zu früh gefreut! Die Daten werden nur bis zum Startzeitpunkt des Solarlogger-Dienstes nachgeholt, bei den aktuellen Werten ist es die alte Leier. Es sieht dann weiterhin so aus:


    11.02.2019 15:06:02 raspberrypi/svrpi/data/20190211.dat FtpGetFile [doFTPTransfer] Error: 6

    11.02.2019 15:07:01 D:\Solarview\web\months.js erzeugt.

    11.02.2019 15:07:02 D:\Solarview\web\days_hist.js erzeugt.

    11.02.2019 15:11:04 rcd Extd Err: 0 550 Failed to change directory.


    11.02.2019 15:11:04 raspberrypi/svrpi/data/20190211.dat FtpGetFile [doFTPTransfer] Error: 6

    11.02.2019 15:16:01 rcd Extd Err: 0 550 Failed to change directory.


    11.02.2019 15:16:01 raspberrypi/svrpi/data/20190211.dat FtpGetFile [doFTPTransfer] Error: 6

    11.02.2019 15:21:03 rcd Extd Err: 0 550 Failed to change directory.


    11.02.2019 15:21:03 raspberrypi/svrpi/data/20190211.dat FtpGetFile [doFTPTransfer] Error: 6


    Also weiterhin: Wer hat Tipps?

    Gruß, Dirk
    PV 74,73 KWp aus 2010
    318 Yingli YL235P-29b 235W Polykristallin
    6 x Sinvert PVM 13 (Siemens / Refusol)

  • Ich habe bereits versucht die Berechtigungen des Ordners /data anzupassen, dies hat aber keine Abhilfe gebracht.

    Der User, der die Daten abholen will (bei ftp wohl ftpuser?) muss nicht nur für /data Rechte haben. Auch alles davor. Wenn der Pfad /home/pi/svrpi/data ist, dann muss er in /home, /home/pi, /home/pi/svrpi und /home/pi/svrpi/data wechseln dürfen. Bei Verzeichnisen ist das x von rwxrwxrwx die entscheidende Berechtigung.


    Z.B.

    Code
    1. drwxr-xr-x root root home
    2. drwxr-xr-x pi pi pi
    3. drwxr-xr-x pi pi svrpi
    4. drwxr-xr-x pi pi data

    hier bedeutet, dass jeder durch das letzte x in drwxr-xr-x das jeweilige Verzeichnis wechseln darf.

  • ...habe meinen Fehler gefunden:

    Ich hatte vor einiger Zeit nach SSD-Ausfall Windows neu installiert. Solarview lief zu dieser Zeit auf dem Raspi.

    Jetzt hatte ich Solarview@windows wieder installiert und versucht, die Daten vom Raspi zu übernehmen, was nicht gelang.

    Zwei Dinge haben den Erfolg verhindert:

    1. Die Daten wurden erst übernommen, nachdem ich in der datenloogger.ini den ganzen FTP- Pfad angegeben hatte: ftp://192.168.0.159/home/pi/svrpi/data/

    Der Test- Button in der DatenloggerSettings.exe hat damit zwar nicht mehr funktioniert, aber die Daten wurden nun übernommen. Sie wurden nur nicht angezeigt.

    Der Grund dafür war, daß ich bei der Solarview Installation vergessen hatte, die Office 2003 Web Components zu installieren, die waren nach der Windows Neuinstallation natürlich weg.

    2. Office 2003 Web Components und Update installiert und alles lief.


    Gruß, Bernd

  • Hallo!


    donnermeister1 :

    Vielen Dank. Der Vorschlag, die Rechte auch der übergeordneten Ordner anzupassen, hat zum Erfolg geführt.


    Zum Nachmachen: mit chmod im Terminal auf dem raspi nach folgendem Beispiel (Syntax oktal, andere Schreibweise als vorgeschlagen, führt zum selben Ergebnis) vorgehen:

    sudo chmod -v 755 /home/pi/svrpi/data

    Das aufsteigend für alle Ordner in der Hierarchie durchführen. Der Parameter -v gibt Rückmeldung aus.

    Danach Raspi neu starten und den Solarlogger Dienst auf dem PC neu starten.


    Danach läuft bei mir tatsächlich alles rund, auch die aktuellen Daten werden im eingestellten Intervall in Solarview@Windows dargestellt.


    Den Lösungsansatz von feli1 konnte ich dann nicht mehr verifizieren, da ich die Änderungen bei mir schon wie oben beschrieben vorgenommen hatte. Den kompletten Pfad wie vorgeschlagen in der datenlogger.ini einzutragen, wäre auf jeden Fall einen Versuch wert. Das wäre dann auch schneller zu bewerkstelligen, als die Anpassung der Ordnerrechte auf dem raspi vorzunehmen.


    Danke an alle!

    Gruß, Dirk
    PV 74,73 KWp aus 2010
    318 Yingli YL235P-29b 235W Polykristallin
    6 x Sinvert PVM 13 (Siemens / Refusol)