SolarLog 50 erkennt Wechselrichter nicht RS-485

  • Hallo!


    Ich versuche gerade einen SolarLog50 bei den Schwiegereltern nachzurüsten. Die Anlage besteht aus einem großen und einem kleinen SMA SunnyBoy Wechselrichtern (einer ist mit IBC gebranded) und es gab vorher schon eine RS485-Verdrahtung an der wohl vor Jahren ein SolarLog 40 hing.


    Die Verdrahtung besteht aus einem kurzen Kabel (80cm, 4-polig, ggf. Telefonleitung) vom kleinen zum großen Wechselrichter und einem weiteren 80cm CAT5e-Kabel zum SolarLog 50. Am kleinen Wechselrichter ist der Abschlusswiderstand aktiviert, ich habe durch die Leitung gemessen und habe 119,5Ohm, sieht also gut aus. Zwischen Data+/- und GND sind jeweils ca. 5MOhm.


    Anschluss am SoiarLog 50 (Sicht auf den Barcode, von links): 1: Data+, 2: leer, 3: GND, 4: Data-

    (aus Verzweiflung habe ich Data+ und - auch schonmal getauscht...)


    Der SolarLog 50 ist folgendermaßen eingestellt:

    * Geräteklasse: Wechselrichter | Sensor | Zähler

    * Hersteller: SMA

    * Typ: Data1

    * Schnittstelle: RS485-A (1200bps)


    Bei der Erkennung wird aber leider kein Wechselrichter erkannt. Kann es sein, dass die RS485-Module in den Wechselrichtern defekt sind? Im kleinen (ohne Display) ist ein 485PB-SMC-NR-Modul verbaut, im großen das Modul in dem Display. Gehen die häufig kaputt?


    VIelen Dank!


    Johannes

  • Hallo,


    Die ohmwerte sagen erst mal das zumindest ein Abschluss

    Widerstand vorhanden ist und kein Erd bzw. Kurzschluss vorliegt.

    Wenn du ein Oszi hast, dann schau dir die Signale mal an.


    Sonst wie Stefan sagt vorgehen.


    Wie groß ist denn die Gesammtleistung der Anlage?


    Gruß Verona

    7,995 kWp - 37 IBC 215TS - Solarmax + Mastervolt
    2,160 kWp - 12 Day4 180 - Solarmax
    2,250 kWp - 10 Sanyo HIP225 - Solarmax
    1,890 kWp - 06 Sunpower 315 - Mastervolt
    6,000 kWp - 24 Yingli 250 - 2 Steca
    12 kW ESS Peus-Testing
    http://www.solarlog-heckmann.de

  • Hallo zusammen!


    Danke für die Antworten. Ich habe jeden Wechselrichter einzeln probiert (natürlich mit entsprechender Terminierung) und auch extra in den zur Zeit kurzen Zeiträumen, wo eingespeist wird.


    Die Verdrahtung war im wesentlichen vorher schon so vorhanden, ich habe sie nochmal kontrolliert (und wahrscheinlich 10x an und wieder angeschlossen) aber einen Fehler konnte ich nicht wirklich finden. Ein einem Ende war auch noch der Stecker für den SolarLog40 dran, den musste ich für den SolarLog50 natürlich abschrauben.


    Sobald der Wechselrichter angeschaltet ist ändern sich die gemessenen Ohmwerte, vermute das ist normal...


    Oszi bzw. auch RS485 Adapter hätte ich, was würde ich dort erwarten und wie sollte ich es anschließen (mit oder ohne SolarLog?).


    [EDIT] Gesamtanlage hat 6KWp...zwei Wechselrichter 1x4kW, 1x2KW.


    Danke,

    Johannes

  • Bitte prüfe doch mal, welche RS485-Module tatsächlich verbaut sind. Sind es tatsächlich die original SMA?

    Es gibt auch von SDS welche, die erfordern aber eine 4-adrige Verkabelung, da hier der Strom vom SolarLog kommt...


    Stefan

  • Hallo Stefan!


    Es sind definitiv SMA-Module verbaut, für den SunnyBoy4000 (mit Display) gibt es meiner Meinung nach auch gar kein SDS-Modul.


    Gruß

    Johannes

  • Hallo,


    Sollte egal sein, das der 50er auch die 12V rausgibt.

    Messe es aber morgen zur Sicherheit noch mal nach.


    Denke eher der 50er hat was.

    Lief denn der 400er bis zum Schluss?


    Gruß Verona

    7,995 kWp - 37 IBC 215TS - Solarmax + Mastervolt
    2,160 kWp - 12 Day4 180 - Solarmax
    2,250 kWp - 10 Sanyo HIP225 - Solarmax
    1,890 kWp - 06 Sunpower 315 - Mastervolt
    6,000 kWp - 24 Yingli 250 - 2 Steca
    12 kW ESS Peus-Testing
    http://www.solarlog-heckmann.de

  • Hallo Verona!


    Es war am Ende keiner mehr dran, ich habe im SolarLog Portal von 2011 Daten gefunden, da schien es gelaufen zu sein und es war kein 400 sondern ein SolarLog 40e (das ist die antike Variante deren Flash-Speicher nach 4 Jahren stirbt...).


    Zurück zum Betrag darüber:

    * Was würde man am Oszi bzw. mit dem Rs485-Sniffer sehen? Senden die Wechselrichter zyklisch oder muss man die über ein Kommando "anstubsen". Wie oft wird etwas gesendet? Und was ist ungefähr der Dateninhalt?


    Danke!


    Gruß

    Johannes

  • Abschließend zu diesem Thema: RTFM


    Pin 1 ist halt einfach in der Mitte, wenn man es dann so anschließt funktioniert es auch. Habe den SolarLog 50 jetzt zwar für eine andere Anlage verwendet und da stürzt er nach dem Erkennen der Wechselrichter "Datenaufbereitung..." komplett ab, aber das ist vermutlich ein anderes Problem.