USB auf RS485 Adapter

  • Zitat von ManfredR

    Hi,
    wenn das nach 1-2 Monaten auftritt, dann hat der Konverter sich mal kurz ab- und wieder angemeldet. Dabei bekommt er bei Linux einen neuen Port zugewiesen. Den o.g. Test musst Du als sudo durchführen, also "sudo ./d0-fb -p /dev/serial/…"


    Viele Grüsse,
    Manfred


    Hallo Manfred


    Was meinst du genau zwecks Test ums Port auszulesen über SSH oder die Zeile in der start.sh??


    Das komische war dann auch das er über d0-fb testen mir die Daten ausgelesen hat aber in Solarview Weboberfläche nichts angezeigt hat...


    Ich werd mal das Netzteil tauschen ist zwar das von revolt das mit 2,5A und die Spannung kann man einstellen nun ja...


    Mfg

  • Zitat von ManfredR

    Hi,
    wenn das nach 1-2 Monaten auftritt, dann hat der Konverter sich mal kurz ab- und wieder angemeldet. Dabei bekommt er bei Linux einen neuen Port zugewiesen. Den o.g. Test musst Du als sudo durchführen, also "sudo ./d0-fb -p /dev/serial/…"


    Viele Grüsse,
    Manfred


    Hallo manfred


    Ich muss also das so in die start.sh das reinschreiben oder wie das es funktioniert??


    sudo ./d0-fb -p /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A9IZQAY1-if00-port0 -l 11000 -mb -ispeed 9600

  • Hallo


    Kann den solarview mit dem befehl in der start.sh was anfangen wenn ich den das so eintrage..??


    ./d0-fb -p /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A9IZQAY1-if00-port0 -l 11000 -mb -ispeed 9600




    Mfg

  • Der Befehl mit /dev/serial/by-id/ funktioniert anscheinend nicht, wenn man mehrere baugleiche Adapter hat, denn in dem Fall wird bei mir nur einer angezeigt.


    In dem Fall hilft "udev" weiter, damit kann man die verschiedenen USB-Geräte zur Not auch nach Steckplätzen verlinken. So hab ich das mit meinen billig-China-Adaptern gemacht, weil die nichtmal verschiedene Seriennummern hinterlegt haben ;-)

    sonnige Grüße,
    -Weidemann-

  • Hallo


    Habe heute wieder das Problem das Solarview mir nichts anzeigt obwohl Daten kommen konnte diese auslesen..


    sudo ./d0-fb -p /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A9IZQAY1-if00-port0 -l 11000 -mb -ispeed 9600


    Aber Solarview log nichts mit bzw. keine Darstellung des ganzen


    Was kann den da los sein???


    Stimmt mit der start.sh etwas nicht??




    Danke

    Dateien

    • rs485.rar

      (988 Byte, 49 Mal heruntergeladen, zuletzt: )
  • Hab noch was vergessen


    Bei Monat Jahr und Gesamt hats mit gezählt bei Tag ist nichts drinnen auch unten steht die 0...verstehe das nicht..


    Danke

  • Hallo


    Bin etwas weiter gekommen...nach Ertragserfassung läuft das Ding wieder über D0 wird alles wieder angezeigt..D0 V1.13


    Kann das sein das die wie soll ich sagen die Ertragserfassung bzw. nach 1/2 Monaten rücksetzt??


    Wie der Fehler auftratt habe ich geschaut per D0 Test ob Daten kommen das machten sie...


    Dann Ertragserfassnung gemacht und alles wa wieder da auch PAC die momentane Leistung...


    Vorher stand alles auf Null auch die momentane Leistung...kann das sein?


    Danke