REFUsol Advanced Energy AE PV Heater

  • Hallo Chris,


    da finden wir sicher eine Lösung.


    Was mir ungemein helfen würde wäre eine Beschreibung was bei welchem Punkt unklar ist.


    Gruß aus etwa 40km südlich von Nürnberg!

    21xSchüco 255W an SMA SB4000TL seit 2014

    9x Jurawatt 250W an Refusol DCLV PV Heater seit 2018

  • Hallo!
    Vielen Dank f3yb4la für die geniale Lösung des Monitoring Problems!
    Besser als das Original über AESitelink!

    Ich hatte jetzt einen Reset des Gesamtertrags bei (genau?) 2000kWh!?
    Kennt das hier jemand oder gab es das jetzt nur bei mir?
    Viele Grüße
    Chris

  • Hallo Chris,


    das mit dem Reset kenn ich. Ist bei mir nur unregelmäßiger.


    Hab mir dafür noch ein zweites Skript geschrieben welches mir jede Woche und am Monatsanfang eine E-Mail zuschickt und tatsächlich alle Tageserträge aufaddiert. Das passt dann immer.


    Bin noch nicht dahinter gekommen warum der Zählerstand zurückgesetzt wird.


    Tritt aber auch auf, wenn du den Heater über den Kippschalter aus/einschaltest.


    Freut mich jedoch, dass ich dir helfen konnte.


    In dem Zug hab ich auch die Anleitung aktualisiert (für alle die es selber probieren wollen)


    Gruß

    21xSchüco 255W an SMA SB4000TL seit 2014

    9x Jurawatt 250W an Refusol DCLV PV Heater seit 2018

  • Hallo f3yb4la,


    hab deine Step by Step Anleitung zum Auslesen der Heater Daten durchprobiert. Funktioniert soweit super. Danke dafür!

    jedoch schaffe ich es nicht die Daten auf meinen Thingspeak channel hochzuladen. Gibts da noch was zu beachten? Channel ID, Write/Readkey habe ich eingefügt, bekomme aber immer "connection failed".(Siehe Anhang)

    Muss ich in meinem Cannel ev. noch extra was konfigurieren, oder im Script was ändern? Hab von python keine Ahnung, deshalb hoffe ich auf deine Hilfe.


    Danke!

  • Hallo,


    da ich ja seit Monaten nicht mehr dazu gekommen bin:

    Habe gestern Abend (kein Licht mehr auf dem PV-Heater) und heute auf einen Ubuntu-Linux Container auf dem QNAP das Python3 heater.py Skript zum Laufen gebracht.

    Hatte erstmal nicht verstanden, das ich einen Channel auf Thingspeak erstellen muss.

    Auf diesem Channel sehe ich aber nur acht wilde Charts, verstehe die Config davon nicht.

    Desweiteren ruft er die Daten aus der Vergangenheit nicht mit ab, oder ich bin zu doof.

    Ich hänge Screenshots vom Linux Terminal und vom Thingspeak an.

    Ich bin mir sicher, dass ich der Fehler bin, weiß aber nicht wo.


    Danke für eure Hilfe

  • Hallo,


    also das Skript schießt die Daten so hoch:

    Kanalnummer 1: Aktuelle Gesamtleistung in W

    2: Wassertemperatur in °C

    3: Gesamtertrag in kWh (wird bei mir immer wieder auf 0 zurückgesetzt, unperiodisch)

    4: Tagesertrag in kWh

    5: interne Temperatur in °C

    6: Leistung Strang 1 in W

    7: Leistung Strang 2 in W

    8: Leistung Strang 3 in W


    Bist schon recht weit gekommen ;)


    Gruß!

    21xSchüco 255W an SMA SB4000TL seit 2014

    9x Jurawatt 250W an Refusol DCLV PV Heater seit 2018

  • Die Daten aus der Vergangenheit werden nicht geholt. Die Historie geht auch nicht zu Thingspeak. Hier kannst du nur zurück bis zu deinem ersten Eintrag.


    Stimmt in deinem Container Datum und Uhrzeit? Bitte stell die mal weg von 1970 dann müsstest du auch tagesaktuelle Daten kriegen.

    21xSchüco 255W an SMA SB4000TL seit 2014

    9x Jurawatt 250W an Refusol DCLV PV Heater seit 2018

  • Hallo,


    ich versuche mich jetzt schon seit 3 Wochen leider ohne Erfolg.

    Ich bekomme immer folgende fehler:


    Was kann das nur sein? :(

  • Kommst du aus Windows heraus auf deinen Heater?


    cmd

    ftp IP.IP.IP.IP

    user -> refu

    pw -> EE0129


    Nachtrag:

    Auf dem Gerät auf dem das Skript läuft probier mal über die Konsole folgendes

    python

    import ftplib

    kommt hier ein Fehler?

    21xSchüco 255W an SMA SB4000TL seit 2014

    9x Jurawatt 250W an Refusol DCLV PV Heater seit 2018

  • Hallo f3yb4la,


    ersteinmal vielen lieben Dank für die echt schnelle Reaktion.

    Ich habe das alles auf einen RaspberryPi laufen.

    Von Windows aus komme ich auf dem Heater.

    Ich kann auch mit einen abgeflachten (Python)-Skript die Logfiles einzeln auf das Raspberry kopieren lassen.

    -------------------------------------------------------------------------

    Bei python >>> import ftplib bekomme ich folgende meldung:


    pi@HeatRaspi:~ $ python

    Python 2.7.16 (default, Oct 10 2019, 22:02:15)

    [GCC 8.3.0] on linux2

    Type "help", "copyright", "credits" or "license" for more information.

    >>> import ftplib

    >>>

    pi@HeatRaspi:~ $ python3

    Python 3.7.3 (default, Jul 25 2020, 13:03:44)

    [GCC 8.3.0] on linux

    Type "help", "copyright", "credits" or "license" for more information.

    >>> import ftplib

    >>>


    Also keine Fehler.


    ---------------------------------------------------------------------------------------




    Bei dem Skript kommt kein Fehler und das Logfile wird kopiert.

    Ich Vermute das es irgendwas mit einen Datum oder mit dem Dateinamen /Ordnernamen zutun hat?? :(