EMH mit IR Lesekopf Konfiguration

  • Hallo zusammen,,
    ich habe mich nun einigermaßen ins Thema Einstieg in den Volkszähler eingelesen, eingearbeitet und habe folgendes Problem.
    Habe das Image installiert und soweit funktioniert alles.
    Ich kann die Seriennummer mit "udevadm info --query=all --name=/dev/ttyUSB0" auslesen.
    Wenn ich nun
    SUBSYSTEM=="tty", ENV{ID_SERIAL_SHORT}=="xxxxxx", SYMLINK+="usb-ir-lesekopf0"
    eingebe, erscheint:
    Komando nicht gefunden.(anstelle von xxxxxx natürlich die seriennummer)


    Was mache ich da falsch?
    Wenn ich
    cat /dev/ttyUSB0
    eingebe, erscheint im putty nichts aber der Stromzähler schaltet wie wild durchs Menü.


    Vielen Dank schonmal


    Gruß Daniel

  • Hallo Daniel,


    was für einen Zähler hast du und was für einen Lesekopf? Das Alias brauchst du nur für >1 Leseköpfe. Die udev-rule wird natürlich von der bash nicht erkannt, die gehört ja auch in das passende Config-File.


    Warum der Zähler bei cat reagiert, kapiere ich gerade nicht.


    Gruß
    Frank

  • Abend,


    Zitat von Tuba

    Wenn ich nun
    SUBSYSTEM=="tty", ENV{ID_SERIAL_SHORT}=="xxxxxx", SYMLINK+="usb-ir-lesekopf0"
    eingebe, erscheint:
    Komando nicht gefunden.(anstelle von xxxxxx natürlich die seriennummer)


    Du sollst das ja auch nicht an der Kommandozeile eingeben sondern eine Konfigdatei anlegen.


    http://wiki.volkszaehler.org/h…reib-lesekopf-usb-ausgang

    Zitat

    Nun kann man eine Datei „/etc/udev/rules.d/99-lesekopf.conf“ mit folgendem Inhalt anlegen:


    Zitat von Tuba

    Wenn ich
    cat /dev/ttyUSB0
    eingebe, erscheint im putty nichts aber der Stromzähler schaltet wie wild durchs Menü.


    Kabel des Leskopfs nach unten?


    Die Wikiseite zu deinem Zähler (wäre hilfreich gewesen wenn du den Typ auch hier erwähnt hättest): http://wiki.volkszaehler.org/h…s/power/edl-ehz/emh-ehz-k



    mfg JAU

    No Shift - No Service

  • also das ging jetz zu schnell, sorry....
    die datei
    /etc/udev/rules.d/99-lesekopf.conf
    habe ich angelegt und das reingeschrieben
    SUBSYSTEM=="tty", ATTRS{product}=="CP2104 USB to UART Bridge Controller", ATTRS{serial}=="01304D15", NAME="lesekopf0"