Bekomme keine Werte in die Middleware (IR Lesekopf per USB)

  • Hallo Nico,


    Wandlerfaktor 1000 ist schon heftig. In welcher Auflösung gibt der Zähler den Zählerstand denn aus?


    interval und aggtime benutzt man normalerweise nicht zusammen. Ich würde interval weglassen und aggtime testweise auf 300 erhöhen. Bei den beiden Kanälen musst du aggmode noch auf "max" setzen.


    Grüße
    Frank

  • Die Auflösung ist 0,001 kW bei Faktor 1000, also 1kW - richtig?


    Der hohe Faktor kommt daher, dass wir an die Mittelspannung angeschlossen sind und auch mittelspannungsseitig gemessen werden. Ich hab die Korrekturen jetzt vorgenommen und gucke mal wie sich die Grafik entwickelt. Ich glaube der Stichpunkt "aggmode" war entscheidend. Auf 1.8.0 wird zwar noch immer 0 angezeigt, aber es kann gut sein, dass wir im moment keinen Strom beziehen sondern einspeisen. Ich geb später nochmal ein Update.


    Vielen lieben Dank für die Hilfe soweit!

  • Also die Ausreißer nach oben sind schonmal weg, nur habe ich jetz alle paar Datensätze einen Datensatz mit 0 dabei. Das kann ja nicht sein. aggtime habe ich jetzt auf 120 gesetzt. Werde aber auch 300 nochmal ausprobieren.


    Ich habe im Wiki und Forum schon gesucht aber nichts gefunden, wie kann ich denn einen "virtuellen" Channel hinzufügen? Zum Beispiel ist mein tatsächlicher Verbrauch ja Bezug + (Ertrag - Einspeisung). Dafür würde ich natürlich auch gerne einen Graphen haben.

  • Wenn du noch Nullwerte drin hast, musst du die aggtime erhöhen, nicht reduzieren. Du kannst auch noch "duplicates": 900 o.ä. einbauen (im Channel), dann werden identische Zählerstände nur alle 15 min übertragen. Dann sollten auch kleinere aggtime möglich sein ohne Zacken.


    Virtuelle Kanäle gibt es bisher nur in einer Entwicklungsversion. Bei Interesse kannst du dir den Fork von andig, Branch next anschauen.


    Gruß
    Frank

  • Zitat von frank-83

    interval und aggtime benutzt man normalerweise nicht zusammen. Ich würde interval weglassen und aggtime testweise auf 300 erhöhen.


    Ich bin der Meinung andersrum wird ein Schuh draus. Wozu den Zähler ständig anquatschen wenn die Daten dann doch verworfen werden weil die Aggtime noch nicht erreicht ist?



    mfg JAU

    No Shift - No Service

  • Also aktuell bekomme ich ca. 4 Werte pro halbe Stunde wenn ich die Datenreihe in Punkten anzeigen lasse. Etwas genauer aufgelöst wäre natürlich schon schön. Soll ich es andersherum ausprobieren?


    Momentan habe ich:


    aggtime: 60
    duplicates: 900
    aggmode: max
    interval: ausgeklammert

  • Naja, bei 7,5kW und Wandlerfaktor 1000 misst dein Zähler gerade mal 7,5W. Wenn er dann mit 1Wh auflöst, sind das dann nur 7,5 Änderungen des Zählerstands pro Stunde, also ca. 8 Minuten bis zum nächsten Wert.


    Momentanleistung (z.B. 1.7.0 oder 16.7.0) liefert der Zähler nicht? Dann ist vermutlich nix zu ändern.


    Grüße
    Frank

  • Guten Tag zusammen,


    also zwischendurch dachte ich ich hab's. Aber jetzt sieht es wieder komisch aus. Ich brauche ja nicht einen Wert pro Minute, so genau muss es nicht aufgelöst sein, solange die einzelnen Messwerte für sich ja stimmen.


    Nun habe ich noch 1.7.0 und 16.7.0 angelegt, bekomme dafür aber scheinbar keine Werte zurück. Die Darstellung des zweiten Zählers sieht jetzt auch komisch aus. Die Nacht vom 28. auf den 01. sieht besser aus als die letzte, jetzt weiß ich nur nicht mehr wo der Unteschied ist. Ich habe heute aber auch noch ein wenig an der config rumgespielt.
    Bei der blauen Kurve bitte erstmal nichts bei denken, da war zwischenzeitlich der Raspi aus.


    Hier die aktuelle config:

  • Ok, Leistung kann der Zähler wohl nicht. Beim letzten Kanal hast du allerdings einen Tippfehler: "volkszaheler".


    Wie weiter oben schon geschrieben, würde ich für 1.8.0 und 2.8.0 zusätzlich "duplicates": 900 (oder bei Bedarf noch länger) konfigurieren, um identische Zählerstände zu unterdrücken.


    Gruß
    Frank