Werte kommen nicht in der Middleware an

  • Hallo,
    jetzt ist mein neuer digitaler EMH-Zähler installiert. Ich versuche Bezug und Überschusseinspeiung auszulesen mit:


    Die Daten kommen auch im Log an:


    Aber nichts in der Middleware und im frontend.
    http://ip/middleware.php/ liefert:

    Code
    1. exception
    2. message "Missing format"
    3. type "Exception"
    4. code 0


    Was sagt mir das?
    :danke: schon mal, ich bin leider immer noch zu dumm , das System hinreichend verstanden zu haben.

    Gruss, wonk

  • Hi,


    Logfile ist ein bisschen knapp (Middleware-Request fehlt), aber dein Zähler hat auf jeden Fall eine falsch gestellte interne Uhr, deswegen landen deine Werte mit Timestamp von 1970 in der Datenbank.
    vzlogger hat als Workaround dafür seit kurzem die Option "use_local_time", aber deine Version kann das noch nicht. Du kannst entweder vzlogger updaten und neu compilieren, deutlich zukunftssicherer wäre aber ein Wechsel zum neuen Volkszähler-Image mit Raspbian Stretch und PHP7, da ist dann auch ein aktueller vzlogger dabei.


    Ansonsten ist deine vzlogger.conf in Ordnung.


    Die Middleware kann man nicht ohne weitere Parameter aufrufen, insofern ist der Fehler nicht ungewöhnlich.


    Gruß
    Frank

  • Hallo,
    ich habe die Datensätze mit den alten timestamps in der Datenbank gefunden.


    Ich habe bei Installation dieses image anpassen müssen (start von hwclock in rc.local auskommentiert), weil mein Raspi2 angeblich keine Hardware-Clock hat. Obwohl mein Raspi nur selten eine Internetverbindung hat, stimmt jetzt die Uhr immer. Klappt das "use local time" auch unter diesen Umständen, oder muss ich bei jedem Start die Uhr neu stellen?

    Gruss, wonk

  • use_local_time bedeutet nur, dass statt der Zeit aus dem SML-Telegramm die Systemzeit des Rechners verwendet werden soll. Ob deine Systemzeit nun stimmt oder nicht, kann vzlogger ja nicht wissen.

  • Hallo!

    Zitat von frank-83


    vzlogger hat als Workaround dafür seit kurzem die Option "use_local_time", aber deine Version kann das noch nicht. Du kannst entweder vzlogger updaten und neu compilieren, deutlich zukunftssicherer wäre aber ein Wechsel zum neuen Volkszähler-Image mit Raspbian Stretch und PHP7, da ist dann auch ein aktueller vzlogger dabei.


    Ich hatte zunächst meinen Netzbetreiber gebeten, mir ein Smartmeter mit korrekter Zeitausgabe zu liefern, aber der rührt sich nicht. Deshalb habe ich jetzt Deiner Empfehlung entsprechend meinen Raspi mit dem neuen Image neu installiert.
    Ich habe entsprechend der Empfehlung sudo apt-get update, sudo apt-get upgrade NICHT laufen alssen.


    Zur Zeit teste ich die neue Installation noch mit einem anderen Zähler mit korrekten timestamps. Wo muss ich das "use_local_time" eingeben, wenn ich auf den Zähler mit den falschen timestamps wechsele?


    Ich habe meine alte vzlogger.conf wieder verwendet (neue uuid natürlich). Es scheint alles richtig zu arbeiten, allerdings muss ich bei der Überprüfung des Logger-Status am Ende immer CTRL-C drücken bis zum Prompt. Normal?


    vzlogger.conf:


    :danke:

    Gruss, wonk

  • Zitat von wonk

    Wo muss ich das "use_local_time" eingeben, wenn ich auf den Zähler mit den falschen timestamps wechsele?


    Im zugehörigen Meter-Abschnitt.


    Zitat von wonk

    allerdings muss ich bei der Überprüfung des Logger-Status am Ende immer CTRL-C drücken bis zum Prompt. Normal?


    Ne, nicht normal. Bei anderen Services auch?

  • Wenn ich channels gemeint hätte, hätte ich das auch so geschrieben :mrgreen:
    Inwiefern lässt sich das Wiki so interpretieren? Kann ich nicht erkennen.


    Das hängende systemctl status kann ich beim aktuellen Image nicht nachvollziehen.

  • Zitat von frank-83

    Wenn ich channels gemeint hätte, hätte ich das auch so geschrieben :mrgreen:
    Inwiefern lässt sich das Wiki so interpretieren? Kann ich nicht erkennen.


    Man muss erst mal erkennen, dass die Überschrift "Protokollspezifisch" nicht mehr zu "channels" gehört.


    Die einzige Veränderung, die ich am image vorgenommen habe, war ( neben Tastaturanpassung, Anpassung an SD-Kartengröße über raspi-config) mc zu installieren. Kann es damit zusammen hängen?

    Gruss, wonk

  • Sorry, ich hatte nicht beim richtigen Image nachgeschaut. Beim aktuellen Raspbian ist das normal, dass verwendet wohl einen Pager für den Output von systemctl status. Du kannst einfach "q" drücken zum Beenden.