SolarLog 400e + Refusol WR

  • Hallo zusammen,
    ich habe jemanden der mich nach Hilfe gefragt hat. Er hat einen SolarLog 400e, welcher seit einem Wechselrichtertausch vor mehreren Jahren, nurnoch einen der beiden Wechselrichter erkennt. Der Austausch wurde durch einen Baugleichen Wechselrichter der Firma Refusol Typ 15K durchgeführt und an einem SolarLog 400e angeschlossen. Vorher waren beide Wechselrichter in SolarLog erfasst.


    Ich war nun Heute vor Ort um mir das Problem anzusehen. Der ehemalige Solarteur hatte eine Anschlussanleitung dort hinterlegt, habe daraufhin die Einstellungen überprüft:


    WR1 (in SolarLog angezeigt), hat die Einstellungen: Adresse 1, Protokoll 2, Baud 9600.
    WR2 (nicht in SolarLog angezeigt), hat die Einstellungen: Adresse 2, Protokoll 2, Baud 9600. (Vorher falsch eingestellt auf Adresse 2 und Protokoll 1...) Zusätzlich ist kein Abschlussstecker an RS485-OUT angebracht, somit eigentlich garnicht terminiert. Kann sein dass es vorher so funktioniert hat, glaube aber eher dass beim Austausch einfach der alte Abschlusstecker mitgenommen wurde.. Brauche ich den zwingend bei 3 Meter Busleitung?


    Der Wechselrichter ist aber auch nach mehrmaligem Neustart etc. nicht in SolarLog verfügbar. Nun gibt es darin einen Button "Wechselrichter suchen", da habe ich mich aber nicht getraut den zu drücken, da laut Internet dabei alle Daten verloren gehen können. Ich habe ein manuelles Backup der Einstellungen + Daten gemacht, das ganze sind .csv Dateien und .dat Dateien. Die habe ich mir im Editor angesehen, da sind Daten der letzten 8 Jahre gespeichert, allerdings teilweise etwas abenteuerlich dargestellt. (Könnte aber sein, dass das richtig ist, teilweise sehr ausführliche Tagesdaten der letzten 2 Monate und danach einfach nur pro Tag einen Leistungswert, so habe ich das mal gedeutet)


    Muss ich um den 2. WR anzulegen, dass ganze System resetten bzw. nach WR-Suchen? Der SolarLog erkennt zwei Wechselrichter, aber in der Grafik ist der zweite nicht zu sehen. Ich vermute irgendwie, dass eine alte Adresse drin hängt und SolarLog durch den Austausch nicht parat kommt. Der Betreiber möchte aber unbedingt alle Daten so in SolarLog behalten, deswegen muss ich 100%ig sicherstellen, dass eine Rückspielung möglich ist danach, oder aber:


    Kann der SolarLog 400e schon das SolarWeb-Portal? Wenn ja, kommt der auch mit dem neuen "Solar-Log WEB Enerest" klar? Ich würde dann für die einen Account anlegen, alle Daten da reinwerfen und dann zurücksetzen und neu anlernen. Ich erhoffe mir, das dann die alten Daten da bleiben und neue halt hinzu kommen. (Das Webportal wurde nie genutzt, wäre für sie aber auch sehr wünschenswert)


    Kann mir jemand näheres dazu sagen?
    Vielen Dank
    JumpY


    Edit: Achso, Wechselrichter-NACHerkennung, scheints für Refusol nicht zu geben.

  • Wie Du schon vermutet hast, könnte es helfen, nach dem WR suchen zu lassen.
    Du könntest aber such mal den Anfang (ca. 20 Zeilen) der Konfig-Sicherung vom SL hier einstellen. Ggfs. Reicht es, dem WR dierichtige Adresse zu geben. WR Suche immer nur machen, wenn alle WR Strom einspeisen.
    Terminierung müßte bei der Länge nicht zwingend erforderlich sein, könnte auch ohne gehen.


    Stefan

  • Nunja, ich hatte es mir schon gedacht. Weißt du denn etwas zu der Anbindung an das neue Enerest System, oder vielleicht zunächst an das alte Portal solange es noch offen ist und dann an Enerest transferieren? Das würde ohnehin gerne genutzt und würde bei einem Ausfall wenigstens alle Daten noch behalten. (Ich denke auch an Totalausfall des Geräts..)



    Das wären mal die ersten Zeilen. Kann auch die ganze Datei hochladen, da stehen sowieso nur die Platzhalter-Daten bei allem drin...

  • Ok, schade.
    Hatte gehofft, das vielleicht der alte WR einfach eine andere Adresse hatte als die 2, so wie es aussieht, war aber doch die 2 vergeben.... :-(
    Ich würde es trotzdem mal versuchen, wenn beide WR einspeisen. Wichtig ist auch, das nach Umstellen der Einstellungen der WR einmal "Stromlos" gemacht werden muss, also AC und DC getrennt werden


    Stefan

  • Okay, dann weiß ich deshalb schonmal Bescheid. Ich gehe auch davon aus, dass man das ganze neu anlegen muss. Ich hatte die WR beide über den Hauptschalter für eine Minute auf Aus geschaltet und das mehrfach versucht.


    Kannst du an mit der Sicherung (den Erzeugungsdaten) denn sehen, ob diese Rückspielbar sind, also dass die irgendwie korrekt aufgebaut sind? Dann würde ich den Schritt nämlich testen können, sonst muss ich überlegen wie ich die Daten gesichert bekomme.

  • Hallo JumpY,
    der Grund wird wahrscheinlich sein, dass der neue(re) WR auch eine neue Firmware bekommen hat, und alle Firmware größer FW29 (ab 2014, oder zumindest >=FW31) kennen das Solarlog-Protokoll (2) nicht mehr, nur noch USS (1) oder Meteocontrol (3).


    Andersherum sollte ein "moderner" Solarlog auch USS/RTP sprechen, dort wirst du etwas umstellen müssen, falls es eine neuere Firmware für den 400e gibt oder der die evtl. schon hat.
    Ansonsten hilft wohl nur WR-Firmware-Downgrade (wenn das überhaupt geht, noch nie probiert) oder Solarlog-Upgrade...


    Ciao
    Michael

  • Hallo netadair,
    das stimmt, der neue WR hat zumindest eine andere Firmware. Ich habe im WR die Versionsinfo verglichen, für mich sah es allerdings eher so aus, als wenn der WR eine ältere FW hätte, was ja komisch wäre aber ich konnte keine richtige Versionsinfo sehen woran man das erkennen könnte.


    Im Einstellungsmenu habe ich gesehen, dass der neue WR im RS485 Menu die Unterpunkte "USS-Adresse, Protokoll und Baudrate hatte", der alte nur Adresse und Protokoll wenn ich das jetzt noch richtig im Kopf habe. Aber es wäre kein Problem einen WR mit USS-Protokoll und einen mit Solarlog-Protokoll auf einem Bus laufen habe, also verbunden?


    Der SolarLog Support hat mir gesagt, dass eine neuere Firmware für das SolarLog-Web Portal benötigt wird und hat mir diese gesendet, vielleicht geht es ja dann damit. Wäre es sonst eine Möglichkeit beide WR mit neuer Software zu bespielen? Das sind allerdings Sachen, die ich nur im Notfall machen würde, da ich einen Refusol-WR noch nie aktualisiert habe und nicht weiß, ob das überhaupt funktioniert.

  • Die Firmware-Version kannst du aber eigentlich problemlos im Menü ablesen; ansonsten siehst du die ursprüngliche rechts aussen auf dem Aufkleber, aber da ist nicht notwendigerweise auch ein neuer Augkleber nach Upgrade drauf.
    Wenn es eine sehr alte FW-Version ist (und die roten 15k sind ja die zweitälteste Baureihe), kann es natürlich sein, dass der das Solarlog noch nicht kennt.
    Dann wäre aber ein Upgrade meist problemlos möglich.


    Beide Protokolle auf dem Bus geht theoretisch, aber praktisch (Stop-Bits, Parität) wird das wackelig und ich denke, der Solarlog kann das nicht.


    Das Upgrade am WR wirst du aber nicht selbst machen können, das ist nicht öffentlich verfügbar.