Ausreißer Außen-Temperatur nach oben

  • Hallo zusammen,


    ich habe alle paar Stunden einen Ausreißer der Außentemperatur von ein paar Grad nach oben.
    Es ist nicht immer die gleiche Zeit oder Intervall. Somit nicht nachvollziehbar.


    Es ist ein Kabel mit ca. 25 Meter Länge.


    9 Sensoren laufen mit einer Länge von ca. 2,5 Meter, da sind keine Auffälligkeiten zu beobachten.


    Ich habe einen Widerstand mit 3,2 kOhm (alle Anleitungen sagen 4,7 kOhm) einbauen müssen, damit die Werte angezeigt werden.


    Muss ich bei dem langen Kabel noch was beachten?


    Habe jetzt den Raspi 3 mit einer 32 GB microSDHC UHS-I Class10 U3 mit MLC eingebaut und der Fehler tritt immer noch auf.


    Es war vorher ein Raspi 1 und eine 16 GB Micro SD mit Adapter drinnen und habe den Fehler auf die alte Karte mit Adapter und Raspi1 geschoben.

    MfG


    Sunpower-oeko

  • Ich habe mal in einem Beitrag (auch hier im Forum) gelesen das es verschiedene Gerätchen von Raspi und/oder Arduino gibt die Probleme mit der Erfassung von Analogwerten haben - das hast du ja mit deinen Temp.sensoren
    Die Eingänge seien wohl nicht linear genug bzw haben eine grosse Streuung


    wenn du das ausschliessen kannst... was ist mit der Referenzspannung?
    Gibt es hier ggf Sprünge?


    Oder irgendwelche Kapazitäten auf der langen Leitung?
    Aber m.E. nach würden es eher Sprünge nach unten werden - hervorgerufen durch Entladungen



    Grüsse
    Carsten

    7,28 kWp, 6000TL20, Ost mit 28 x ReneSola JC260M-24/Bb (02/2013)
    2,65 kWp, 2500TL21, West mit 10 x SolarWorld AG SW 265 mono (EU)
    6,48 kWp, SB5.0, W/NW mit 22 x SolarWorld AG SW 270 mono (EU)
    14,8 kWh Hoppecke Batterie mit SI 6H-11

  • Hallo Jau,


    hier die technischen Daten der Sensoren:
    DS18B20 Thermosensor
    Hochwertige Edelstahl-Röhre, wasserdicht, feuchtigkeitsbeständig, anti-Rost


    Edelstahl-Rohr Größe: ca.6 * 50mm (Durchmesser * Länge)
    9 ~ 12 einstellbare Auflösung
    Versorgungsspannungsbereich: 3.0V-5.5V
    Betriebstemperaturbereich: -55 ° C - +125 ° C (-67 ° F - +257 ° F)


    Lagertemperatur: -55 ° C bis - 125 ° C (-67 ° F - +257 ° F)
    Genauigkeit über den Bereich von -10 ° C bis +85 ° C: ± 0,5 ° C.
    Keine andere Komponente, einzigartige Single-Bus-Schnittstelle
    Ausgang Leitung: Rot (VDD), weiß (DATA), Schwarz (GND)
    Kabelfarben ändern sich danach auf:
    Ausgang Leitung: Rot (VDD) zu braun, weiß (DATA) zu grün/gelb, Schwarz (GND) zu blau





    Hier ein Foto der Verkabelung:

  • Zitat von sunpower-oeko


    Habe mal ein Screenshot angehängt, ist die untere Linie mit den 3 Zacken.


    Moin,


    die Zacken kommen durch Zugriffe des Raspi auf die SD-Karte. Dabei werden alle sonstigen Interrupts gesperrt.
    Man kann es minimieren, indem man in der vzlogger.conf den Wert für verbosity auf 0 setzt.


    Gruß
    Udo

  • Hallo Udo,


    habe gestern Nachmittag den Wert für verbosity auf 0 gessetzt.


    Habe mich spät abends nochmal eingeloggt und wieder ist der Aussensensor nach oben gesprungen.
    Gibt es noch eine andere Einstellung um den Temperatursprung zu vermeiden.


    Also es hängt definitiv am Einloggen auf den Raspi 3.


    Der müsste doch genug Power haben um das zu vermeiden.

    MfG


    Sunpower-oeko

  • Also der Temperatursprung tritt nur auf wenn du dich einloggst? Dann solltest du mal ein stärkeres Netzteil versuchen.
    Gruß
    Udo

  • Habe das Problem ebenfalls.
    Ich vermute, dass das Auslesen des Sensors bei diesen Kabellängen nicht mehr zuverlässig läuft.
    Wäre aber auch für einen Lösungsvorschlag dankbar.
    Gruß
    Günther

    2,4kWp PV seit 2004. 4qm Solar für WW + Heizungsunterstützung + Stagnationsverhinderung, WP 2,7kW für Heizung, SplitKlima Heizungsunterstützung bis ca. 0 Grad AT Alleinheizung, WW WP extra + 24V Heizeinsatz für PV-Betrieb