vzlogger auf PLC

  • Hallo ich bin neu hier und bitte um Hilfe,


    Habe mir einen rasperry zum loggen mit IR-Kopf non Udo zugelegt, soweit funktioniert alles gut.
    Kann somit meinen Siemens Armis Zähler auslesen. Jetzt würde ich noch gerne eine Verbindung
    zu meiner S7 PLC herstellen, aber leider kann ich nichts auf das fertige Image von Volkszähler dazu laden.
    Ich bekomme keine Verbindung für Downloads!
    Bin leider kein guter LINUX-User, habe es auch schon mit einen zweiten raspy probiert (mit original Image)
    das funktioniert aber.
    Habe den logger auf WLAN mit static IP über FritzBox hängen, hat da wer eine Ahnung was ich falsch mache?
    Bitte um eure Hilfe,


    DANKE
    Stefan

  • Zitat von stefan3107

    Jetzt würde ich noch gerne eine Verbindung
    zu meiner S7 PLC herstellen, aber leider kann ich nichts auf das fertige Image von Volkszähler dazu laden.
    Ich bekomme keine Verbindung für Downloads!


    Was verwendest du an zusätzlicherSoftware? Nur weil die SPS heutzutage ne TCP/IP-Schnittstelle haben heißt das nicht das man da so mal eben ohne zusätzliche Software drauf zugreifen kann.



    mfg JAU

    No Shift - No Service

  • Zitat von stefan3107

    aber leider kann ich nichts auf das fertige Image von Volkszähler dazu laden.
    Ich bekomme keine Verbindung für Downloads!


    Wie meinst du das? Du kannst keine Programme auf den Raspi herunter laden?


    Wie machst du das und was meldet der Raspi?


    Gruß
    Udo

  • Hallo
    Zuerst mal danke...
    Das mit der zusätzlichen Software ist mir klar.
    Darum hätte ich ja gerne was (zB. Morbus) probieren wollen.
    Bringe aber über das Originalimage nicht vom web herunter. Habe auch schon Stunden herum probiert, leider kein Erfolg.
    Würde gerne den Raspy auch für andere Applikationen nutzen.
    Habe heute mit einen anderen Raspy alles andere installieren können, nur nicht mit dem den ich schon laufen habe.
    LG
    Stefan

  • Ahso. :roll: Anständige Fehlerbeschreibung hilft...


    Wenns nicht internettet hast du wohl in /etc/network/interfaces das gateway falsch konfiguriert.



    mfg JAU

    No Shift - No Service

  • Zitat von JAU

    Ahso. :roll: Anständige Fehlerbeschreibung hilft...


    Welche war das?? Die: Bringe aber über das Originalimage nicht vom web herunter.?
    Sagt mir gar nichts.


    Zitat von JAU


    Wenns nicht internettet hast du wohl in /etc/network/interfaces das gateway falsch konfiguriert.


    Das Image ist auf DHCP eingestellt.
    Dann muss er wohl selbst daran rum gespielt haben.




    Gruß
    Udo

  • Zitat von stefan3107


    Habe den logger auf WLAN mit static IP über FritzBox hängen, hat da wer eine Ahnung was ich falsch mache?


    Da bräuchten wir mehr Informationen. Was sagt ifconfig?


    Gruß
    Udo

  • Hallo
    Fritzbox kann ich anpingen
    Fritzbox zeigt auch die pi an
    Zugriff über PUTTY



    > pi@raspberrypi:~ $ ifconfig
    > lo Link encap:Local Loopback
    > inet addr:127.0.0.1 Mask:255.0.0.0
    > inet6 addr: ::1/128 Scope:Host
    > UP LOOPBACK RUNNING MTU:65536 Metric:1
    > RX packets:8682097 errors:0 dropped:0 overruns:0 frame:0
    > TX packets:8682097 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0 txqueuelen:1
    > RX bytes:1024197048 (976.7 MiB) TX bytes:1024197048 (976.7 MiB)
    >
    > wlan0 Link encap:Ethernet HWaddr b8:27:eb:6c:49:55
    > inet addr:192.168.0.16 Bcast:192.168.0.255 Mask:255.255.255.0
    > inet6 addr: fe80::ba27:ebff:fe6c:4955/64 Scope:Link
    > UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    > RX packets:176060 errors:0 dropped:101924 overruns:0 frame:0
    > TX packets:18622 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0 txqueuelen:1000
    > RX bytes:19698692 (18.7 MiB) TX bytes:14517111 (13.8 MiB)



    Netzwerk habe ich auf static umgeschrieben, im Heimnetz kann ich auf Frontend zugreifen


    pi@raspberrypi:~ $ sudo nano /etc/network/interfaces
    GNU nano 2.2.6 File: /etc/network/interfaces[code]
    # interfaces(5) file used by ifup(8) and ifdown(8)


    # Please note that this file is written to be used with dhcpcd
    # For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'


    # Include files from /etc/network/interfaces.d:
    source-directory /etc/network/interfaces.d



    auto lo
    iface lo inet loopback
    iface eth0 inet static
    address 192.168.0.15
    netmask 255.255.255.0
    gateway 192.168.0.2
    allow-hotplug wlan0
    iface wlan0 inet static
    address 192.168.0.16
    netmask 255.255.255.0
    gateway 192.168.0.2
    wpa-ap-scan 1
    wpa-scan-ssid 1
    wpa-ssid "XXXXXXXXXXXX"
    wpa-psk "XXXXXXXXXXXl"
    dns-nameservers 192.168.0.2


    Ich hoffe damit könnt ihr was anfangen
    Danke
    Stefan