Volkszähler auf einem Synology NAS

  • Hallo,
    ich nutze den Volkszähler auf einem Raspberry Pi V3. Läuft mit insgesmat 6 Zählern einfach super.
    Da die Anzeigegeschwindigkeit mit zunehmender Datenmenge merklich abnimmt, möchte ich die Daten gerne auf meinem NAS von Synology speichern und dort auch das Frontend anzeigen.
    Der Raspberry wäre dann nur noch der Datensammler der auf den NAS speichert.


    Ich haben nun die mySql DB auf dem Synology angelegt bzw. von Raspberry kopiert.
    Das volkszähler.org Verteichnis des Raspberrys habe ich kopiert.
    Wenn ich nun auf meinen Server unter http://192.168.0.200/Volkszaehler/htdocs/frontend/ zugreife erschein das Layout und ich erhalte die Meldung

    Zitat

    An exception occured in driver: SQLSTATE[HY000] [1045] Access denied for user 'vz'@'localhost' (using password: YES)


    Ich vermute dass das mit der Datei: volkszaehler.conf.php zu tun hat. Wie man damit umgeht ist ja hier http://wiki.volkszaehler.org/h…tallation_auf_webhoster_2 beschrieben:

    . Ich bin mir allerdings bei den Passwörtern und Links zur mySql nicht sicher.


    Kann mir jemand sagen wie die Angaben bei einer eigenen DB ohne Passwort und mit dem User root aussehen?


    Danke Vorab
    Tobias

  • Hallo Tobias,


    Für Geschwindigkeit brauchst Du kein Nas. Nimm einfach das vz Image oder richte von Hand Aggregation ein (siehe vz Wiki), dann rennts auch wieder.


    Viele Grüße, Andreas

  • ...ansonsten ja, Du musst in die conf eben Adresse, Usernamen und Passwort Deiner Mysql Installation auf dem Nas eintragen. Localhost ist schonmal mit Sicherheit falsch...


    Viele Grüße, Andreas

  • Zitat von tobiasrie

    Kann mir jemand sagen wie die Angaben bei einer eigenen DB ohne Passwort und mit dem User root aussehen?


    Code
    // Benutzername (wird vom Webhoster vergeben)
    $config['db']['user'] = 'root';
    ...
    // zugehöriges Password
    $config['db']['password'] = '';


    Darüber hinaus wirds aber schwierig weil wir Namen und Adressen für die DB auf deinem NAS nicht kennen. Da du das alles mal eingerichtet hast sollte es eigentlich bekannt sein.


    Das Frontend aufm NAS in Betrieb zu nehmen wird aber komplizierter, da du mit so einfachen Konfigurationen schon an deine Grenzen stößt rate ich dringend davon ab.
    Ist aber auch kein Problem, das bisschen Webserver hat der Rpi gut im Griff.



    mfg JAU

    No Shift - No Service

  • Hallo Jau,
    ich habe heute schon so viel ausprobiert dass ich zum Schluss den Wald vor Bäumen nicht mehr gesehen habe :?


    Nach dem ich das ompl. www Verzeichnis auf den NAS kopiert hatte ging ich davon aus dass dieser sofort auf die Daten der mySql zugreift und anzeigt. Da die Verweise ja auf dem Server gleich mit denen des Raspberry sind, müsste es doch eigentlich schon laufen.


    Die volkszaehler.conf.php ist natürlich nicht für den NAs sondern muss im Pi angepasst werden. Mein Denkfehler!
    Was ich aber nicht versteh ist die Funktion der vzlogger.conf.
    In der sind doch dir richtigen Verweise auf localhost und uuid noch drin. Auch die Berechtigungen der mySql habe ich alle angegeben. Wieso kommend ann keinen Daten bzw. diese Fehlermeldung?

  • Ach Herrje. :roll:


    Zitat von tobiasrie

    Nach dem ich das ompl. www Verzeichnis auf den NAS kopiert hatte ging ich davon aus dass dieser sofort auf die Daten der mySql zugreift und anzeigt.


    Natürlich nicht wenn du der DB auf dem NAS andere Namen, Nutzer und Passwörter gibst.


    Zitat von tobiasrie

    Was ich aber nicht versteh ist die Funktion der vzlogger.conf.
    In der sind doch dir richtigen Verweise auf localhost und uuid noch drin.


    "Localhost" heißt so viel wie "daheim".
    Du musst dem vzogger schon sagen das er nicht mehr auf dem Rpi die Middleware ansprechen soll sondern drüben beim "Nachbar" NAS. Was für ne IP-Adresse der auch immer haben mag.



    mfg JAU

    No Shift - No Service