Raspi nicht mehr erreichbar

  • Hallo zusammen,
    ich habe seit einiger Zeit das Problem, dass der Raspi im Netzwerk nicht mehr erreichbar ist. Dann hilf nur noch Stromversorgung trennen und wieder hochfahren. Habe auch schon gesucht und es deutet auf das ifplugd-Paket hin, dass es Probleme macht. Hatte es auch schon deinstalliert, nur war der Pi dann überhaupt nicht mehr in der Lage eine Netzverbindung aufzubauen, bis ich das Netzwerk manuell gestartet hatte. Also hab ich das Paket wieder installiert.


    Außerdem stimmen dann die Schnittstellen nicht mehr überein und ich muss jedes mal, dann die 3 USB Geräte entfernen und in der richtigen Reihenfolge einstecken. Hab das auch schon mit einer rules Datei probiert, klappt aber irgendwie auch nicht so richtig.

    8,925kwp - 35x Yingli Panda 255W - SMA STP 8000 (+20°/38°) (VERKAUFT)

    15,9kwp - 53x QCells 300W - SMA STP 15000 (Ost/Süd/West)
    1000er Jäger


    JK: 15

  • Heute Nacht hat er sich wieder verabschiedet. Ich weiß auch nicht ob SV weiterläuft und loggt oder alles stirbt.
    Habe nur Zugriff per SSH.

    8,925kwp - 35x Yingli Panda 255W - SMA STP 8000 (+20°/38°) (VERKAUFT)

    15,9kwp - 53x QCells 300W - SMA STP 15000 (Ost/Süd/West)
    1000er Jäger


    JK: 15

  • Ich bin jetzt nicht der Raspi-Experte aber wir setzen den ein und haben festgestellt, dass das Betriebssystem oft Probleme hat sich die IP-Adresse vom Router zu holen. Hängt meistens mit der Konfiguration des Kundennetzwerkes zusammen. Die können wir ja nicht ändern. Da hilft dann nur die automatische auf feste IP-Adressen umzustellen und die auch im Raspi zu hinterlegen. Frag mich bitte jetzt nicht wie man das macht, weil dafür der Kollege zuständig ist.

    PV, BHKW, Speicher ecoBATT, Bilanzpunktregler ecoBPR, Wallbox ecoLOAD, Renault ZOE
    Rechnen hilft. Bleistift, Papier und Taschenrechner und man wird sich über einige Ergebnisse wundern
    Oscar Perdok GmbH - Gildeweg 14 - 46562 Voerde PV, Wallboxe und mehr

  • Hi,


    bist du sicher, dass dein Netzteil genug Saft liefert? Ich hatte solche Fälle mit sich-hart-weghängenden PIs nur, wenn das Netzteil zu schwach war. Oder wenn er zusammen mit einem Piface in einen geschlossenen Gehäuse war und zu warm geworden ist.


    Ciao
    Michael

  • Zitat von LumpiStefan

    Wenn der Raspi stirbt, ist doch auch kein Zugriff via ssh möglich, ansonsten wäre er ja nicht gestorben...
    Wenn Du trotzdem per SSH drauf kommst, siehst Du doch in der Prozessliste ob SV läuft....


    Stefan


    Habe gemeint, dass ich keinen Monitor angeschlossen habe zum schauen, ob SV noch läuft. Wenn er stirbt, komm ich natürlich auch per SSH nicht drauf.

    8,925kwp - 35x Yingli Panda 255W - SMA STP 8000 (+20°/38°) (VERKAUFT)

    15,9kwp - 53x QCells 300W - SMA STP 15000 (Ost/Süd/West)
    1000er Jäger


    JK: 15

  • eco
    Habe ihn von Anfang an auf feste IP eingestellt, daran liegt es nicht.


    netadair
    Er ist auch letztens 41 Tage am Stück gelaufen. Danach wieder nur eine Woche. Jetzt der Absturz.
    Bevor die Probleme anfingen, ist er teilweise an dreistelligen Tagen gelaufen.
    Vielleicht weiß Manfred wo ich mal nachschauen kann, bin auch jetzt kein Linuxexperte.
    Wäre aber mal eine Idee, das Netzteil zu tauschen.

    8,925kwp - 35x Yingli Panda 255W - SMA STP 8000 (+20°/38°) (VERKAUFT)

    15,9kwp - 53x QCells 300W - SMA STP 15000 (Ost/Süd/West)
    1000er Jäger


    JK: 15

  • Kritisch beim PI sind die Netzteile.
    Besonders, wenn man mehrere vom PI versorgte USB-Geräte dran stecken hat.


    Zum Zugriff auf die USB-Geräte kann man mehrere Möglichkeiten umsetzten.


    Zu einem ist es, wenn die USB-Geräte als Speicher diesen, immer besser, diese nicht über den Device-Namen (/dev/sda1 oder ähnliches) sondern über die UUID anzusprechen. Denn diese bleibt immer die gleiche.


    Die UUID bekommt man, wenn man auf der Kommandozeile "blkid" eingibt.
    Es kommt dann eine Auflistung, welche Decive-ID aktuell welche UUID hat.


    Man tauscht dann den Eintrag der Decive-ID in der /etc/fstab durch den Text "UUID=..." aus.
    Die Ausgabe bei "blkid" zum Beispiel:

    Code
    /dev/sda1: UUID="0036f1d8-ffaf-4001-8cae-2e47bf586bdc"


    Dann wird in der /etc/fstab das so geändert:

    Code
    /dev/sda1 / ext4 errors=remount-ro 0 1


    wird

    Code
    UUID=0036f1d8-ffaf-4001-8cae-2e47bf586bdc / ext4 errors=remount-ro 0 1


    Anderen Geräten, die z.B. als serielle Schnille angesprochen werden, kann man einen passenden anderen Namen geben, der dann verwendung findet, wenn dieses Gerät angesteckt wird.
    Auch dieser Name bleibt immer gleich, egal, wann das Gerät angesteckt wird.


    Ein USB-Seriell-Adapter kann man z.B. so 'ändern'


    Es wird, mittels "lsusb" die Product- und Vendor-ID für das Gerät gesucht.
    Diese Trägt man in einer neuen Datei im Verzeichnis "/etc/udev/rules.d" ein

    Code
    lsusb
    ...
    Bus 004 Device 004: ID 0572:1329 Conexant Systems (Rockwell), Inc.
    ...
    cat /etc/udev/rules.d/99-usb-serial.rules
    SUBSYSTEM=="tty", ATTRS{idVendor}=="0572", ATTRS{idProduct}=="1329", ATTRS{serial}=="24680246", SYMLINK+="tty_gpsmodem"


    Hiermit wird ein softlink angelegt, der nach /dev/tty_gpsmodem zeigt udn von der eigentlichen Portbezeichnung kommt.:

    Code
    lrwxrwxrwx 1 root root 7 Apr 14 18:01 tty_gpsmodem -> ttyACM0


    Nun kann man nicht den eigentlichen Namen, sondern den Alias nehmen.
    Man muss, wenn man mehrere solcher USB-Geräte hat, sich nur noch die Seriennummer besorgen. Die wird mit angezeigt, wenn man den Befehl "lsusb" mit dem Parameter "-v" erweitert.
    Achtung, jetzt kommt viel Text, und man muss die Einträge zum passenden Gerät finden. ;-)

    Hanjörg Resa


    SunnyBoy GCI 2400 (bis 28.04.2016)
    SunnyBoy2.5-1VL-40 (seit 11.05.2016)
    2*12 BP-Solar 585

  • Netzteil hab ich mal gegen ein Samsung Ladegerät mit 2A getauscht, hatte ich zwar vorher auch, aber wie ich gelesen habe, kann es trotzdem zu Problemen führen. Vielleicht ist ein Markengerät stabiler. Die USB Schnittstellen werde ich mal bei Gelegenheit einstellen.

    8,925kwp - 35x Yingli Panda 255W - SMA STP 8000 (+20°/38°) (VERKAUFT)

    15,9kwp - 53x QCells 300W - SMA STP 15000 (Ost/Süd/West)
    1000er Jäger


    JK: 15

  • So, hab mich mal an die USB-Geräte gewagt. Nach Anleitung: http://wiki.volkszaehler.org/h…usb-ausgang#linux-support muss man die ID_SERIAL_SHORT nehmen, mein 3. Device hat aber keine ID_SERIAL_SHORT. Habe mal den VENDOR genommen, doch das klappt auch irgendwie nicht. Die Geräte werden wieder falsch gemappt.


    Wenn ich die Geräte in der richtigen Reihenfolge einstecke, scheint es aber zu passen:


    lrwxrwxrwx 1 root root 7 Mai 14 15:55 usb-d01 -> ttyUSB1
    lrwxrwxrwx 1 root root 7 Mai 14 15:55 usb-s02 -> ttyUSB2
    lrwxrwxrwx 1 root root 7 Mai 14 15:55 usb-wr0 -> ttyUSB0



    8,925kwp - 35x Yingli Panda 255W - SMA STP 8000 (+20°/38°) (VERKAUFT)

    15,9kwp - 53x QCells 300W - SMA STP 15000 (Ost/Süd/West)
    1000er Jäger


    JK: 15