vzlogger findet configfile nicht?

  • Hallo zusammen,


    bei meiner Fehlersuche bin ich an folgenden Punkt gelangt, wo ich nicht weiter weiß. Problem war, dass rpi die Daten nicht erzeugt, obwohl er den Sensor (UART) lesen kann. Mit

    Code
    cat ttyAMA0

    sehe ich die Daten meines Zählers (D0).


    Letztendlich denke ich es liegt daran, dass der vzlogger die config nicht findet oder lesen darf?
    Auf

    Code
    vzlogger -c --config

    bekomm ich folgende Antwort.

    Zitat

    sudo vzlogger -c --config
    [Mar 22 16:50:54][main] vzlogger v0.5.1 based on heads/master-0-g7e79f4c700-dirty from Fri, 5 Feb 2016 18:03:28 +0100 started.
    [Mar 22 16:50:54] Cannot open configfile --config: No such file or directory
    [Mar 22 16:50:54] Failed to parse configuration due to: Cannot open configfile.


    Die logfiles werden folglich auch nicht erzeugt. Wenn ich vzlogger -o --log anfrage kommt loglevel=0.
    Diverse reboots und start/stops des vlzoggers halfen nicht :cry:
    Habe das fertige raspi image verwendet.


    Schonmal vielen Dank für eure Ratschläge.

    Einmal editiert, zuletzt von Genosse ()

  • Habe auch probiert: vzlogger -c --/home/pi/vzlogger/etc/vzlogger.conf
    selbes Ergebnis. Wie muss man den Befehl denn schreiben?(sry für diese Anfängerfrage, aber kenne mich mit Linux und Konsole nicht wirklich aus)
    Außerdem sollte der vzlogger nicht standardmäßig erst mal im angegebenen Verzeichnis die conf suchen?

  • -c kennzeichnet die Kurzform der Option
    --config die Langform


    Der Aufruf sieht also entweder so

    Code
    vzlogger -c /home/pi/vzlogger/etc/vzlogger.conf


    oder so

    Code
    vzlogger --config /home/pi/vzlogger/etc/vzlogger.conf


    aus.


    Wenn nix angegeben wird sucht der vzlogger im Linux Standardverzeichnis für Konfigurationsdateien, nimmt also /etc/vzlogger.conf.
    Siehe auch: http://wiki.volkszaehler.org/d…r#command_line_parameters



    mfg JAU

    No Shift - No Service

  • Danke, damit bin ich schon mal etwas weiter gekommen.


    Wenn ich den vzlogger manuell starte mit der config als Parameter, dann werden auch die logfiles, wie ja in der config definiert, erzeugt. Wird das ganze aber über:

    Code
    sudo systemctl start vzlogger


    gestartet, oder automatisch nach dem booten, dann werden keine logfiles erzeugt, obwohl es in der config so steht. Also denke ich mal, dass die config nicht geladen wird.


    Mit:

    Code
    vzlogger -c /home/pi/vzlogger/etc/vzlogger.conf


    kann ich das Programm starten und es werden die logfiles erzeugt. Anfangs sieht alles gut aus. Die d0 Schnittstelle wird ein paar mal erfolgreich gelesen, aber nach 1-5 mal sagt der vzlogger, dass er keine Daten mehr bekäme.

    Code
    [d0] nothing received for more than 9 seconds
    [d0] read timed out!, context: 0, bytes read: 0, last byte 0x0


    Über:

    Code
    sudo cat /dev/ttyAMA0

    kommen aber kontinuierlich Daten rein.


    Hier nochmal zur Vollständigkeit meine conf:

  • Zitat von Genosse

    Wird das ganze aber über:

    Code
    sudo systemctl start vzlogger


    gestartet, oder automatisch nach dem booten, dann werden keine logfiles erzeugt, obwohl es in der config so steht.


    Klar. Du gibst ja auch nirgends irgendwelche Paramter an, der Dienst erwartet, wie schon erwähnt, die Config im Standardverzeichnis: /etc/


    Zitat von Genosse


    Hier nochmal zur Vollständigkeit meine conf:


    Da fehlt aber einiges, was fürn Zähler hast du denn?


    Code
    "daemon": false, // run periodically


    Wenn der vzlogger als Dienst laufen soll schonmal falsch.



    mfg JAU

    No Shift - No Service

  • Danke für deine Antwort.

    Zitat von JAU

    Klar. Du gibst ja auch nirgends irgendwelche Paramter an, der Dienst erwartet, wie schon erwähnt, die Config im Standardverzeichnis: /etc/


    Die vzlogger.conf ist immer im /etc/ Verzeichnis. Aber nur wenn ich das explizit im Parameter angebe wird diese scheinbar auch geladen. Wenn ich den manuell einmal starte wäre für mich auch ok. Nach dem booten wird die /etc/vzlogger.conf aber nicht geladen. Das sollte aber so sein, oder?


    Ich habe einen Hager EHZ mit D0 Schnittstelle. Verwende einen Fototransistor am UART des raspi.
    Wie gesagt über cat kommen dauerhaft fehlerfreie Daten an.
    Starte ich den vzlogger mit -c und der conf dann funktioniert es erstmal. Es werden bis zu 5 Datensätze gelesen. Dann auf einmal nichts mehr (vzlogger sagt "d0 nothing recieved", siehe voriger Beitrag). Das ist eigentlich das große Problem.

  • Hab das Problem gefunden. Ich wusste nicht, dass UART bereits im Image vorbereitet wurde und habe daher ein Skript verwendet, dass das machen sollte. Es hat anscheinend auch etwas gemacht, dass Probleme verursacht. D0 wird jetzt fleißig geloggt.
    :danke: an die lieben Helfer, die sich meinem Problem angenommen haben.

  • Du nutzt das fertige Image?
    Dann bist du als user 'pi' angemeldet.
    Also musst du alle Befehle die Programme ausführen mit 'sudo <Programm>' ausführen.
    Also auch z.B. wenn du die vzlogger.conf mit nano editieren willst: 'sudo nano /etc/vzlogger.conf'


    vzlogger wird automatisch nach dem Booten über systemd gestartet.
    Wenn du jetzt nochmals vzlogger aufrufst gibt es Fehler.
    Wenn du vzlogger manuell starten willst, warum auch immer, musst du vzlogger vorher stoppen.

    Code
    sudo systemctl stop vzlogger


    und dann:

    Code
    sudo vzlogger ....


    Ich weiß nicht wo ihr euch immer die vzlogger.conf herholt, in der Anleitung steht doch ihr sollt den vzlogger.conf-Editor benutzen:
    http://volkszaehler.github.io/vzlogger/
    Mit deinen Kommentaren in der vzlogger.conf wird die hier unleserlich.


    Der Pfad zur vzlogger.log-Datei sollte /tmp/vzlogger.log heißen.