SB1200 mit YASDI

  • Hallo zusammen,


    ich bin derzeit etwas ratlos mit meinem SunnyBoy 1200. Ich möchte dessen Daten loggen, finde aber keine Spot Channels.
    Jemand eine Idee dazu?


    Details:
    Der SunnyBoy ist in der Garage montiert, dort befindet sich ein Raspberry Pi den ich via WLAN erreichen kann.
    Auf dem RPI läuft unter linux (raspian) yasdi.
    Der RPI ist via USB auf RS485 converter mit dem SunnyBoy verbunden, dort steckt ein RS485 Modul (Nachträglich eingebaut). Die Kommunikation scheint zu funktionieren, da ich via yasdishell den WR finde und seine Seriennummer auslesen kann. Bei der Abfrage der Werte kommt ich aber dann zu dem Problem (Seriennummer habe ich entfernt):


    Code
    Command ('?' for help): a
    Device handle: 1
    Device 'WR12-061 SN:200xxxxxx' has 0 Spot channels:
    Reading channel values, please wait...
    ------------------------------------------------------------
    Channel handle | Channel name | Channel value (Unit) |
    ------------------------------------------------------------
    Command ('?' for help):


    Gleiches gilt für Parameter und test channels - in allem Fällen keine Channels.


    Kann es sein, das der WR12 keine Spot Channels ausgiebt? Muss das ggf. irgendwie konfiguriert werden?
    Ist das ggf. ein Problem mit der Firmware?


    BFR: V 4.09
    SRR: V 4.09
    Model SB1200
    Hergestellt 05-04-2013


    Danke für alle Ideen und Tipps,
    Gruß,
    Adam

  • scheint, als ob die Geräteerfassung durch einen Übertragungsfehler nicht vollständig geglückt ist. Unter "devices" muss er eine Datei mit dem Gerätetyp und der darin enthaltenen Kanalbeschreibung des Wechselrichters abgelegt haben. Falls diese Datei existiert "'WR12-061.bin" würde ich diese einmal per Hand löschen (oder umbenennen) und erneut eine Geräteerfassung starten...


    VG,
    Heiko

    4,32 kWp, SMA Sunny Boy 4000 TL-20, Ausrichtung WSW, Aleo S16 (Poly)