Bus-Probleme eines Anfängers ;)

  • Hallo,


    ich bin ganz neu im Forum und möchte meine PV-Anlage überwachen.
    Hierzu wollte ich eigentlich die Solarview Software auf meine Fritzbox packen, was jedoch inzwischen aufgrund fehlender Telnet Unterstützung nicht mehr geht.


    Aus diesem Grund liegt vor mir bereits ein Raspberry, leider jedoch noch keine SD-Karte und Netzteil, aber dazu später mehr.


    Folgender IST-Zustand:


    2 Wechselrichter Diehl Platinum, sind untereinander mit einem Netzwerkkabel am RS485-Bus verbunden und erkennen sich auch.
    Nun habe ich eine CAT7-Leitung zu meinem Datenknoten verlegt (ca 30m) um von dort aus mit Hilfe des empfohlenen EX9132 LAN->RS485 Konverters ins LAN zu gehen.


    Hierzu habe ich ein Aderpaar jeweils auf die A bzw. B Buchse geklemmt. (auf beiden Seiten identisch)
    Die IP-Vergabe hat auf dem Konverter funktioniert, aktuell blinkt die SYS Leuchte.
    Beim Installationsmenü der WR werden nur 2 Teilnehmer / 2 WR erkannt, müsste hier mein Konverter auftauchen?


    Habe ich soweit alles korrekt installiert? Ist es schon jetzt möglich zu prüfen ob der Datentransfer hinaut? Leider habe ich kein Terminal auf meiner Windows 10 installation!


    Über Hilfestellung würde ich mich freuen.


    Vielen Dank bis hier hin!


    MfG

  • Die Wechselrichter erkennen meines Wissens nach nur die Überwachungsgeräte ihres Herstellers. Folglich wird Dein Adapter nihct auftauchen. Es ist hoffentlich nur der Adaptern und der endständige Wechselrichter terminiert.
    Du musst halt sicher stellen, dass A und B nicht vertauscht werden...


    Ciao


    Retrerni

  • Hi,
    ohne Terminal wirst Du nicht weit kommen, also bitte Putty herunterladen und auf den Rechner kopieren. Da musst Du nichts installieren. In der Anleitung unter http://www.solarview.info/solarview_diehl.aspx steht beschrieben, wie der Konverter verkabelt werden muss. Auf Seite 11/12 findest Du beschrieben, wie Du die Verbindung testen kannst. Damit der Wechselrichter antwortet muss er in Betrieb sein, also tagsüber testen.
    Viele Grüss,
    Manfred

  • Zitat von Retrerni

    Es ist hoffentlich nur der Adaptern und der endständige Wechselrichter terminiert.
    Du musst halt sicher stellen, dass A und B nicht vertauscht werden...


    Retrerni


    Hallo,


    danke für deine Antwort. Terminiert ist aktuell nur der "letzte" WR im System. Den Adapter muss ich lt. Anleitung nicht terminieren. Die Termination am WR ist aktuell bei mir nur eine Drahtbrücke zwischen B und T, lt. Anleitung wird dann ein integr. Widerstand gesetzt (Platinum WR) Kann dies jmd. bestätigen?


    @ Manfred:




    Putty ist installiert, jetzt muss ich nur noch dein Werk zum laufen bringen und die Verbindung testen.


    Beim Konverter blinkt derzeit lediglich die Sys-Leuchte, etwas schneller als im Sekundentakt, die anderen LEDs bleiben aus, ist dies so korrekt oder sollte im Tagbetrieb hier schon aktivität sein?


    Desweiteren habe ich die RS485 Leitung nun ca 30m bis zum Lan-Datenpunkt verzogen und dort den Konerter installiert - kann dies zu Problemen führen? Laut Wiki ist eine Buslänge von 1200m unproblematisch!


    Ich gehe davon aus, dass hier noch einige Rückfragen kommen werden. Linux ist einfach nicht mein Gebiet ;)


    Aber danke für die wirklich schnelle Antwort!

  • Hallo,


    ich habs zum laufen gebracht, jedoch ist das ganze noch nicht richtig parametriert, denk ich.


    Aktuell kommt es mir so vor, als wenn die diehl-fb nicht automatisch gestartet wird. wenn ich mit putty "mitlese" erscheint jedenfalls der Graph auf der homepage.


    Darüberh innaus stimmt was mit meinen eingetragenen Jahreserträgen etc nicht? (Siehe Code)



    Was genau mache ich hier falsch?


    Manfred, wenn ich die Kiste ans laufen bekomme brauch ich eine Lizenz! ;)

  • Zitat von TheSpring85

    Terminiert ist aktuell nur der "letzte" WR im System. Den Adapter muss ich lt. Anleitung nicht terminieren. Die Termination am WR ist aktuell bei mir nur eine Drahtbrücke zwischen B und T, lt. Anleitung wird dann ein integr. Widerstand gesetzt (Platinum WR) Kann dies jmd. bestätigen?


    Also wenn Du Adapter - 30m Kabel - WR1 - WR2 als Setup hast, wäre der Adapter sowie WR2 zu terminieren... WR2 sollte mit dem Terminationsstecker, der wohl dem WR beiliegt (in der Abdeckung oder so), terminiert werden.


    Ansonsten stellt sich die Frage, ob die Zuordnung der abgerufenen Daten mit deren Benennung übereinstimmt...


    Ciao


    Retrerni

  • Vielen Dank zusammen, inzwischen läuft das ganze System so wie erhofft, ob die ganzen Ertragsdaten richtig eingestellt sind werde ich die Tage mal überprüfen. An und für sich bin ich schon froh das der Logger überhaupt läuft. Linux ist doch etwas andere und mit meinen alten DOS-Befehlen kommt man nicht immer ans Ziel.



    Vielen Dank jedenfalls für das lösen des eigentlichen Bus-Problems!!