Kanäle in Fronted über WLAN anlegen

  • Hallo,
    ich habe endlich mein Raspberry und durfte mich heute gleich ans Werk machen.
    Bisher bin ich nach Anleitung Wiki für Raspberry vorgegangen.


    - Image auf Karte gebracht
    - mit Putty über LAN verbunden
    - root-Partition auf die Größe der SD-Karte vergrößert
    - update und upgrade, durchlaufen lassen. (vielleicht ein Fehler)
    - WLAN Stick installiert und mit WLAN verbunden.


    Jetzt wollte ich über Die Frontend Web-Oberfläche Kanäle anlegen, doch das geht nur über LAN.
    Wenn ich die Oberfläche über WLAN öffne dann ist mein, über LAN angelegter Kanal, nicht vorhanden.
    Und über WLAN kann ich überhauptkein anlegen.
    Bei der bestätigen der Eingaben kommt zwar ein Fenster, aber ohne Fehlerangabe. Also komplett leer.


    Gehe ich wieder über LAN auf die Oberfläche ist mein Kanal wieder da.


    Wie ihr euch denken könnt wollte ich den Raspberry über WLAN Betreiben.
    Muss ich da was beachten?

  • Welche Kanäle abonniert sind wird in einem Cookie gespeichert. Ändert sich die IP des VZ (z.B. weil der WLAN-Adapter eine andere Adresse hat), der Browser oder der Rechner ist das Cookie nicht mehr verfügbar. Deswegen setzt man beim Erstellen eines Kanals den Haken bei "öffentlich", dann kann man den Kanal im mittleren Register aus der Liste auswählen und neu abonnieren (in neuem Cookie speichern).


    Die letzten Tages gabs mehrere User die von einer leeren, roten Textbox sprachen. Aber alle nur mit schwammigen Aussagen ohne jeder weiterführende Info. So ist es schlicht unmöglich den Fehler einzugrenzen.



    mfg JAU

    No Shift - No Service

  • Ok, habe ich versucht.


    also ich habe auf meinem Win10 PC über Chrome die LAN Oberfläche (192.168.178.21) geöffnet. Alles gut, Kanal vorhanden.
    Der Kanal ist auch Öffentlich. Also lese ich die UUID aus.


    Dann öffne ich am selbigen Rechner auch Chrome die WLAN Oberfläche (192.168.178.115) auf. Kein Kanal vorhanden. :cry:
    - +Kanal hinzufügen
    -> Kanal abonnieren
    -> UUID Eintragen (Middleware Adresse stimmt: ../middleware.php)
    -> Cookie aktiviert
    -> "Abonnieren" dann kommt wieder das "leere Fenster" wie beim Versuch eines Kanal Anlegen.


    ich wollte auch gern versuchen den Kanal manuel über HTTP Request anzulegen.


    Zitat

    http://<server>/<path>/volkszaehler.org/middleware.php/channel.json?operation=add&title=Testzaehler&type=power&resolution=1000&description=Swissnox[...]


    beim "server" kommt meine IP hin. Aber welchen "path" gebe ich ein?
    auf dem Raspberry ist die Middleware Standard unter /var/www/volkszaehler.org/htdocs/


    Und nach Swissnox (was wahrscheinlich die "Beschreibung" des Kanals ist) kommt "[...]"
    Wofür steht das?


    Gebe ich den Befehl einfach in die Adresszeile des Browsers ein?

  • Zitat von damianator

    Win10 PC über Chrome


    Ist der Browser aktuell?


    Zitat von damianator

    Dann öffne ich am selbigen Rechner auch Chrome die WLAN Oberfläche (192.168.178.115) auf. Kein Kanal vorhanden.


    Wie schon erwähnt, keine Überraschung.


    Zitat von damianator

    - +Kanal hinzufügen
    -> Kanal abonnieren


    Und wenn du stattdessen über "öffentliche Kanäle" den Kanal auswählst?


    Zitat von damianator

    ich wollte auch gern versuchen den Kanal manuel über HTTP Request anzulegen.

    Code
    http://<server>/<path>/volkszaehler.org/middleware.php/channel.json?operation=add&title=Testzaehler&type=power&resolution=1000&description=Swissnox[...]


    beim "server" kommt meine IP hin. Aber welchen "path" gebe ich ein?


    Das hast du vermutlich daher: http://wiki.volkszaehler.org/software/middleware/einrichtung Die Seite ist fehlerhaft, ich korrigiere das gleich.


    Zitat von damianator

    auf dem Raspberry ist die Middleware Standard unter /var/www/volkszaehler.org/htdocs/


    Da liegen die Dateien im Dateisystem, übern Webserver ist das der "Einstiegspunkt".


    Zitat von damianator

    Und nach Swissnox (was wahrscheinlich die "Beschreibung" des Kanals ist) kommt "[...]"
    Wofür steht das?


    Für die ganzen anderen Parameter die du noch angeben musst wenn du eine Kanal auf dem Weg einrichtest. Siehe: http://wiki.volkszaehler.org/development/api/reference


    Zitat von damianator

    Gebe ich den Befehl einfach in die Adresszeile des Browsers ein?


    Ja. Aber nicht so wie auf der fehlerhaften Seite, die Referenz-Seite ist korrekt.



    mfg JAU

    No Shift - No Service

  • Zitat

    Ist der Browser aktuell?


    Ja, Chrome Version 47.0.2526.106 m


    Zitat

    Und wenn du stattdessen über "öffentliche Kanäle" den Kanal auswählst?


    Direkt nach Auswahl des Reiters "Öffentliche Kanäle", erscheint ein Fenster:
    Überschrift mit rotem Hintergrund: "Javascript Runtime Error"
    Darunter: "Uncaught Autobahn not connected"


    Jetzt habe ich mal den IE ausprobiert, und es geht! :lol:
    Kanäle Anlegen, sowie auch abonnieren.


    :danke:

  • Zitat

    The Chrome browser does not support NPAPI plug-ins and therefore will not run all Java content. Switch to a different browser (Firefox, Internet Explorer or Safari on Mac) to run the Java plug-in. More info


    schade :cry:

  • Bin mir aber grad ziemlich sicher das ein anderer User das Problem mit FF auch hatte.


    Ich kann den Fehler bei mir nicht reproduzieren (Opera). Würdest du bitte mal versuchen ob du über Chrome einen neuen Kanal anlegen kannst?


    "Autobahn" ist Teil des recht neuen Push-Dienst den der vzlogger bereit stellt. Damit ist es möglich Daten darzustellen die nicht aus der DB kommen. Hast du den in deiner vzlogger.conf aktiviert oder steht das noch aus?



    mfg JAU

    No Shift - No Service

  • Zitat

    Bin mir aber grad ziemlich sicher das ein anderer User das Problem mit FF auch hatte.


    Vielleicht hatte er bei FF sein Java in den Einstellungen deaktiviert?!?


    Zitat

    Würdest du bitte mal versuchen ob du über Chrome einen neuen Kanal anlegen kannst?


    Also über Chrome kann ich kein neuen Kanal erstellen. Das war ja mein ursprüngliches Problem. Dabei erscheint das Leere Fenster, das weggecklickt werden möchte. Weitere Eingaben und "Erstellen" führen zu keinem weiteren Ergebnis.


    Wenn ich "Öffentlichen Kanal" wähle kommt der "Java Runtime Error" und dann Kann ich zwar Middleware: "Local" und "Volkszaehler Demo" Auswählen, aber bei Kanal: besteht keine Auswahl. (Local gewählt)


    Andes ist es wenn ich "Volkszaehler Demo" wähle. Dann habe ich bei Kanal: 8 Auswahlmöglichkeiten (von Gesamt ... Demo Gruppe)


    Zitat

    Hast du den in deiner vzlogger.conf aktiviert oder steht das noch aus?


    Das mache ich als nächstes.

  • OK Ich habe jetzt in der vzlogger.conf die "UUID" und "resolution" angepasst.
    Da ich GPIO 18 (Pin12) und GND (Pin14) verwende habe ich meine UUID (e92d5560-b283-11e5-a9f1-2522fcce52ea) nur an ansprechender Stelle angepasst.
    Den Rest habe ich so belassen wie er war.



    Leider bleibt in der Anzeige "nothing to plot..." :cry:

  • Ach so... neu gestartet wurde der Raspi natürlich.


    Und hier die Log. Vielleicht gibt die ja Aufschluss: