SolarView von Fritzbox 7272 aus Raspberry umziehen

  • [attachment=0]startanzeige.jpg[/attachment]Hallo zusammen,


    ich bin Neuling im Forum, lese aber schon seit einiger Zeit mit, und möchte mich kurz vorstellen:


    ich betreibe seit Oktober 2013 eine Dach- Solaranlage mit 6 kWp, bestehend aus 21 Bosch-Modulen Typ c-Si M 60+ 285 Wp, 1 Wechselrichter SMA Tripower 6000TL-20. Datenabfrage seit Dezember 2014 über SV@FB über RS 485- Schnittstelle, ETH/RS485- Konverter von Solae Systems. Die Fritzbox ist eine 7272. Das System läuft seit der Installation von SV problemlos.


    Wie bekannt, stellt AVM die Unterstützung der telnet- Funktion ein, sodass ich seither die Firmware noch nicht von 6.20 auf 6.30 upgedatet habe. Um dieses Problem auszuräumen, bin ich dabei, auf den Raspberry umzustellen.


    Ich bin entsprechend der Installationsanleitung von SolarView vorgegangen, der Umzug war mit Hilfe des Programms WinSCP problemlos, ebenso die Anpassung der Datei start.sh. Der Logger läuft, die Daten werden im Verzeichnis svrpi/homepage/data gespeichert. Alles wie es sein soll.


    Einziges Problem:


    ich kann über Firefox nicht auf den RasPi zugreifen. Firefox findet den RasPi nicht. Grund dafür ist, dass der Befehl "busybox httpd -p 88 -h homepage" nicht ausgeführt wird.


    Beim Starten kommt die beigefügte Bildschirmanzeige.


    Der Befehlszusatz "httpd" bei busybox wird durch den RasPi abgeblockt: "Permission denied."
    Beim Start von smap kommt noch die Meldung "error cannot open pid-file " /var/run/smap.pid"".


    Hängt es mit den Benutzerrechten zusammen? Ob ich SV als Benutzer pi oder als su (Superuser) starte, ist egal, die Komponenten solarview-fb und smap starten (jeweils doppelt, wie es sein soll), aber nicht busybox.
    Das komplette Verzeichnis svrpi und die Unterverzeichnisse haben alle den Modus 755, d.h. Eigentümer und Gruppe sind pi. Auch die Datei svfb.sh, die ins RasPi- Systemdateienverzeichnis "etc/init.d" kopiert wurde, hat den Modus 755, wie es die Anleitung von Manfred Richter beschreibt.


    Ich bin kein Fachmann in Linux, deshalb ist WinSCP eine große Hilfe bei der Konfiguration.


    Wer kann helfen?????


    Vielen Dank im Voraus.


    esmeralda15

  • Hast du die Fritzboxversionen von smap und busybox durch die raspiversion ausgetauscht?
    Zeig mal ein ls -l.

    Unser Strommix (4 Personen): ~57% Solarstrom, Rest regenerativer Strom

  • Hallo rudis,


    die RasPi- spezifischen Dateien aus den Installationsverzeichnissen "Andere/rpi" sind im Stammverzeichnis "svrpi" und im Unterverzeichnis "smap" einkopiert, wie es sein soll.


    Wie gesagt, SolarView funktioniert, die Daten werden in den Verzeichnissen "svrpi/data" im dat- und csv- Format sowie in "svrpi/homepage/data" im csv- Format gespeichert. Ebenso sind die js- Dateien mit den Tagesdaten (im 5- Minutentakt) im Verzeichnis "svrpi/homepage" vorhanden. Die Loggerfunktion läuft gut, nur die Visualisierung über Firefox funktioniert nicht. Der Befehlszusatz httpd beim Start von busybox wird vermutlich vom RasPi- System blockiert.


    Danke für deinen Beitrag.


    esmeralda15

  • Hallo,


    es liegt vermutlich an dem fehlendem root recht.


    gib mal sudo ./start.sh ein. Dann sollte es laufen


    Habs bei mir mal ohne getestet, dann kommt der gleiche Fehler


    MfG Oliver

  • Hallo Oliver,


    danke für den Tip. Funktioniert leider bei mir nicht. Weder der Start mit "sudo ./start.sh" noch über "su" als root gelingt vollständig. Immer wird busybox wegen des Zusatzes httpd am Start gehindert -siehe Anzeige "httpd: bind: permission denied". Die zweite Fehlermeldung am Ende des Bildschirmausdrucks "ERROR can not open pidfile "var/run/smap.pid"" kann ich nicht bewerten, weil allem Anschein nach der Logger normal läuft. Die genannte Datei smap.pid ist im angegebenen Verzeichnis nicht zu finden.


    Trotzdem vielen Dank.


    esmeralda15

  • hast du die datei ausführbar gemacht? mit sudo chmod 755 busybox
    evtl noch mal machen bzw die dateien nochmal neu auf den rasp kopieren und dabei aus binär stellen


    Hier noch mal ein auszug, einmal ohne und mit sudo

    Dateien

    • new 1.txt

      (6,33 kB, 100 Mal heruntergeladen, zuletzt: )
  • Hallo oligraf,
    danke für den Tip: das Stichwort "binär" hat mich in den letzten Tagen sehr beschäftigt. Ich habe die ganzen Dateien auf dem RasPi gelöscht und dann mit WinSCP in der Übertragungsoption "binär" nochmals übertragen. Jetzt funktioniert alles einwandfrei. Inzwischen nicht geloggte Ertragsdaten kann ich problemlos nachtragen, weil ich die Daten auch noch über Sunny Explorer aus dem Wechselrichter holen kann.


    Danke.
    esmeralda15