Volkszaehler auf dem Raspberry Pi schaltet automatisch ab

  • Hi,
    ich habe eine Solaranlage und wollte mir mal ausgeben, was die Anlage so produziert. Ich habe mir die Software auf meinem Raspberry Pi installiert und alles lief super. Seit dem 30.11 um genau 23:00 werden keine neuen Daten mehr auf der xxx.xxx.x.xx/frontend/ Seite gezeigt. Die Werte von davor sind alle noch zu sehen. Erkennen tue ich es daran, dass man Nachts die Werte immer bei 0 sind (grüne Line). Ab 23:00 sieht man keine Linie mehr. Gestartet habe ich es am 26.11.
    Woran kann es liegen, dass keine neuen Daten mehr kommen?


    mfg


    hka

  • Was steht den im Syslog? Wie erfasst du die Daten? Falls vzlogger: Was steht da im Log?



    mfg JAU

    No Shift - No Service

  • Danke für die Antwort.
    Ich kenne mich mit Linux leider nicht sehr gut aus. Fest steht aber, dass vzlogger ausgeschaltet war. Ich habe es dann manuell wieder gestartet. Die Frage ist jetzt, warum sich vzlogger ausgeschaltet hat. Gibt es dazu eine Einstellung oder so?


    mfg


    hka

  • Edit: Habe leider keine Edit Funktion gefunden.
    Mir ist auch aufgefallen, dass es eigentlich 00:00 war und nicht 23:00 und es war die Nacht zum 1.12.
    Auf der Frontend-Seite war es 23:00. Vielleicht hat es ja was damit zu tun.

  • Sehr oft liegt sowas am Lankabel...
    Stecker nicht richtig drin oder rausgerutscht.
    Mal überprüfen...
    Den Pi mal reseten oder neu straten kann auch helfen.
    Router mal neu starten....falls vorhanden.
    0,00 o. 23,00Uhr hat was mit Sommerzeit u. Winterzeit zu tun. Hat nix mit Datenspeicherung zu tun
    außer das die zeit nicht richtig ist
    Snopc :D

  • Danke für die Antworten.
    Ich habe den Pi so eingerichtet, dass er nach dem booten alles startet(klappt auch). wenn es zu einem neustart gekommen wäre, so sollten trotzdem weitere Werte kommen. Ich habe den Pi auch jetzt vom Stecker gezogen und wieder reingesteckt. Da läuft auch alles.
    Wie gesagt, ich vermute dass der vzlogger einfach aufgehört hat die Werte zu speichern. Ich habe es ja vom Terminal aus wieder gestartet und es lief dann auch wieder. Die Frage ist jetzt nur, warum ist es ausgegangen? und warum genau um 00:00 zum 1.12 ???


    mfg


    hka

  • Das heißt Deine Aussage "vzlogger" ausgeschalten hieß nicht Rasp Pi aus, sondern "nur" der vzlogger lief nicht?!?
    Dann würde ich mal vermuten dass der Prozess vom vzlogger beendet wurde, Fehler, oder so was....


    Stefan

  • Genau. Der Prozess wurde irgendwie beendet.
    Ich habe jetzt bei der config-Datei die log Einstellung geändert auf error and warnings. Vorher wurde alles geloggt und die Datei war auch ziemlich groß.

  • Hi,


    ich hatte bei mir das selbe Problem. Allerdings zu allen möglichen Zeiten und natürlich nicht reproduzierbar. Manchmal schon 1,5 h nach dem letzten Neustart des vzlogger-Prozesses, manchmal lief er auch 3 Tage durch. Alle Tipps zur Konfiguration und Updates brachten keine Besserung. Ich habe mir dann einen kleinen Dreizeiler geschrieben, der überprüft ob der vzlogger noch läuft und ihn bei Bedarf neu startet. Das Skript läuft bei mir jetzt über crontab alle 5 Minuten. Da ich keine S0-Impulse damit zähle, geht mir auch nichts verloren.
    Das löst zwar nicht die Ursache des Problems, aber bei mindert die Auswirkungen. (Ich lese über IR-Kopf alle 5 min. den Zählerstand aus. Damit verliere ich max. einen Wert.)


    Gruß
    Frank