Konfiguration s0

  • Hallo,


    nun habe ich Solarview schon eine Weile in Betrieb und habe nun einen 2-Richtungszähler mit s0-Ausgang nachgerüstet.
    Dieser soll die Einspeisung dokumentieren, die ich dann in fhem auswerten will.
    Allerdings bekomme ich hier komische Werte, die ich nicht verstehe :cry:


    meine Konfiguration:

    Code
    ./solarview-fb -nodatexport -nobackup -i 127.0.0.1 -p 10000 -c 1 -i3 127.0.0.1 -p3 55001 -a 1.0 -enc -ev 1 -TCP 15000
    ./busybox httpd -p 80 -h homepage
    cd sunspec
    ./sunspec-fb -i 192.168.10.42 - p 10000 -c 1 -w 5600
    cd ..
    cd s0
    ./s0-fb -p /dev/ttyUSB0 -w 5600 -c 1 -imp 1000 -l 10001 -e 1
    cd ..


    starte ich s0-fb im debug-Modus bekomme ich folgende Ausgabe:

    Code
    TimeStamp: 21.11.15 14:30:45
    Answer[1] = {01;FB;5B|64:DYR=F;DMT=B;DDY=15;THR=E;TMI=1E;PAC=0;PIN=2BC0;KT0=0;KYR=0;KMT=0;KDY=2;TYP=270C;SYS=4E21|1A66}
    Leaving PrepareAnswer()


    ist das korrekt? Laut Anleitung sollten hier die Impulse zu sehen sein :?


    Findet jemand hier einen Fehler in der config?


    Vielen Dank!

    Module:
    10 St. LG mono X 280 Ost-Ausrichtung
    10 St. LG mono X 280 West-Ausrichtung
    WR: Solaredge SE5k mit Leistungsoptimierern
    Solarview mit sunspec und EX9132-Konverter

  • Hallo, Kann hier keiner die Ausgabe bewerten?

    Module:
    10 St. LG mono X 280 Ost-Ausrichtung
    10 St. LG mono X 280 West-Ausrichtung
    WR: Solaredge SE5k mit Leistungsoptimierern
    Solarview mit sunspec und EX9132-Konverter

  • Hallo,


    wieso hast du einen 2-Richtungszähler mit S0? wie soll das gehen?
    S0 sind nur Impulse. Da gibt es nicht Bezug und Leiferung


    MfG Oliver

  • Aber der Zähler kann vielleicht entsprechend eingestellt werden.
    Mein SDM630 hat 2x S0 ein S0 ist fest eingestellt der andere kann konfiguriert werden auf Bezug, Lieferung oder Gesamtertrag.
    Jetzt ist die Frage welchen Zähler der Threaderöffner einsetzt.
    Gruß Christian


    Gesendet von meinem E39 mit Tapatalk

    06/2010 4,32kWp Süd 15° SMA SB4200 100% Volleinspeisung
    06/2013 9,99kWp Ost / West 20° PowerOne 8.0 70% Eigenverbrauch
    10/2015 9,88kWp Nord / Ost 10° Hybrid-WR 10kW + 750AH/48V Pb-Batterie 70% Eigenverbrauch

  • Dann könnte das Problem daran liegen, das:
    evtl den falschen S0 Ausgang am Zähler angeschlossen
    Zähler falsch eingestellt
    Am S0 -> USB Adapter falschen Eingang angeklemmt.


    Ob die Reihenfolge der Parameter wichtig ist, bin ich nicht sicher (-p /dev/ttyUSB0 -w 5460 -imp 1000 -c 1 -l 10000 -e 1)


    Bitte den Zählertyp und den Typ des S0 Adapters angeben und auf welchem System das ganze läuft

  • Hallo,
    Der Zähler ist ein ELTAKO DSZ12DZ-3x65A. Dieser Zähler hat einen S0-Ausgang, den man zwischen Bezug, Abgabe oder dem Saldo daraus programieren kann. Ich habe hier Out also Abgabe eingestellt. Als Konverter kommt der USB-Konverter von Solarview zum Einsatz. Hier habe ich die Anschlüße 4(+) und 8(-) angeklemmt.


    Ich hoffe, das hilft weiter.


    Gruß Olaf

    Module:
    10 St. LG mono X 280 Ost-Ausrichtung
    10 St. LG mono X 280 West-Ausrichtung
    WR: Solaredge SE5k mit Leistungsoptimierern
    Solarview mit sunspec und EX9132-Konverter

  • Hast du mal die Polung überprüft bzw getauscht?
    Ich hatte bei mir anfangs das Problem, das die Spannung nicht ausreichend für den Optokoppler (im S0 Zähler) war.
    Habe das durch ein zwischengeschaltete 24V SPS Relais gelöst, seit dem läuft es reibungslos.
    Da ich auch noch eine USB D0 Lesekopf habe, und der Raspberry mir immer die USB0 und USB1 vertauscht hat,
    habe ich mir einen USB -S0 Adapter mit FDTI Chip zugelegt.


    Wenn das auch nicht hilft, kannst du mal eine Screenshot deiner start.sh Konfig machen (solarview_fb_startup.exe)

  • Habe das ganze auf einem Raspi zu laufen. Hier die Start.sh

    Bash
    #!/bin/sh
    trap "" SIGHUP
    ./solarview-fb -nodatexport -nobackup -i 127.0.0.1 -p 10000 -c 1 -i3 127.0.0.1 -p3 55001 -a 1.0 -fu XXXX -fp XXXX -fs 192.168.1.xx -fd /solarview/ -u xxxxxx -l xxxxxx -r xx@xxxx.de -s xx@xxxx -e xxxxx -sp 993 -ssl -enc -ev 1 -TCP 15000
    ./busybox httpd -p 80 -h homepage
    cd sunspec
    ./sunspec-fb -i 192.168.1.42 -p 10000 -c 1 -w 5600
    cd ..
    cd s0
    ./s0-fb -p /dev/ttyUSB0 -w 5600 -c 1 -imp 1000 -l 10001 -e 1
    cd ..

    Module:
    10 St. LG mono X 280 Ost-Ausrichtung
    10 St. LG mono X 280 West-Ausrichtung
    WR: Solaredge SE5k mit Leistungsoptimierern
    Solarview mit sunspec und EX9132-Konverter

  • Ich habe mal die FTP und Mailparameter rausgenommen, muss ich hier die ANgaben vom Wechselrichter 2 einfügen?
    Warum bekomme ich Ausgaben vom D0? den habe ich doch nicht. ist das korrekt?

    Bilder

    Module:
    10 St. LG mono X 280 Ost-Ausrichtung
    10 St. LG mono X 280 West-Ausrichtung
    WR: Solaredge SE5k mit Leistungsoptimierern
    Solarview mit sunspec und EX9132-Konverter