S0 einer von 4 Zählern funktionslos nach Update

  • Ich habe die S0 Datei auf meinem RasPi von der version V1.9 auf die V1.12 hochgerüstet. Danach waren die Verbrauchswerte (Monat und Jahr durcheinander) Der 2. Zähler hat keine Werte mehr angezeigt:


    siehe Bild EV_Fehler_1.png



    Habe dann eine Ertragserfassung gemacht. Die Werte waren dann ok, aber immer noch keine aktuellen Werte.


    siehe Bild EV_Fehler_2.png



    Habe dann zurück auf die alte Version V1.9 gerüstet und neue Ertragserfassung gemacht


    siehe Bilde EV_Fehler_3.png



    Leider keine Besserung, der Zähler 2 geht einfach nicht mehr.


    Habe dann mal für 10 Minuten Debug angeschaltet und den S0 Teil hier angehangen:


    s0_debug_101115.txt


    Ich hoffe mir kan jemand sagen, was da defekt ist. Berkabelung wurde nicht angepasst.


    Grüße Daniel

  • Hi,


    Du solltest bei 4 Zählern auf jeden Fall auch 4 Werte beim Parameter -w angeben. Irgendetwas sinnvolles wie -w 7200,7200,7200,7200 z.B.
    Für den am Anschluss RI angeschlossenen Zähler gibt es Impulse, allerdings werden die wegen einem bisher nicht vorhandenen Wert beim Parameter -w veworfen (Das ist Dein Zähler 2).
    Für Zähler 3 sehe ich im Protokoll keine Werte. Der sollte an 6 (DSR) angeschlossen.


    Wenn also Parameter -w gesetzt ist sollte es klappen.


    Grüsse,
    Manfred

  • Hallo Manfred,


    Danke für die Hinweise. Habe nun mal den Parameter eingetragen und die neue V1.12 Version wieder aktiviert.


    Die Verbrauchswerte waren wieder alle durcheinander:



    Habe dann mal wieder eine Ertragserfassung gemacht, die Werte stimmen nun:



    Leider ist nun die Kurve mal wieder durcheinnander, werde dann wohl erst morgen wieder sehen ob ich Erfolg hatte.


    Bis zu dem Update hat es mit der V1.9 Version auch immer nur mit der Angabe von dem Parameter W und einem Wert (2000) geklappt. Nun habe ich halt mal 3000,3000,2000,2000 eingetragen.


    Zähler 3 ist in einer aktuell ungenutzen Wohneinheit. Zähler 4 geht aber und wird auch angezeigt. Komisch wäre dann schon, warum ausgerechnet Zähler 2 nicht geht.


    Werde denn morgen berichten ob es erfolgreich war.


    Grüße und Danke.
    Daniel

  • So, es geht wieder.


    Eventuell könnte man bei der Abfrage des Parameters ja bei Fehlen der Werte 2-n einfach den ersten Wert für alle setzten. Bei Eigenverbrauch ist das ja eh sinnvoll. Und es verhindert Probleme wie bei mir. Bis zur v1.12 hat es ja auch gepasst.


    mobil gesendet

    9,12 kW/p teilverschattet mit Süd und West Ausrichtung an SolarEdge SE8k. Module 48 * Suntech Power STP190S-18/Ub