RaspberryPi2: Nach Absturz Fehlermeldungen & läuft nicht meh

  • Heute hat es mir den FI raus gehauen und wie es der Teufel will, startete der bis dahin tadellos laufende raspberryPi2 nicht mehr.
    Er blieb im Autoboot hängen mit mir nix sagenden Meldungen.
    Kurzum, ich habe eine andere Karte aufgesetzt und einfach das svrpi Verzeichnis mit WinSCP binär erst auf den PC dann auf die neue Karte gespielt.
    Anschl. wie in der Anleitung die Schreibrechte auf 0755 überprüft was alles noch vorhanden war und dann gestartet via
    sudo ./solarview-fb -i 192.168.0.230
    sudo ./kostal-fb -i 192.168.230
    sudo ./start.sh


    192.168.0.230 ist die IP des RS232 LAN Adapters und 192.168.0.235 die des Raspberrys...
    Soweit so schlecht, jetzt kommt die Fehlermeldung:


    /home/pi/svrpi$ sudo ./solarview-fb -i 192.168.0.230
    Starte SolarView@Fritzbox V 2.22h


    *************************************************************
    *** Starte nun SolarView@Fritz!Box Version V 2.22h ***
    *** -- Fritzbox Version -- ***
    *** ***
    *** LIZENSIERTE VERSION ***
    *** ***
    *** Wechselrichter: 192.168.0.230 ***
    *** Inverter(s): 1 ***
    *** ***
    *** have a lot of sun :-) ***
    *** Beenden: killall -9 solarview-fb ***
    *************************************************************
    Uptime: 3632s ( 1h)
    build Aug 29 2014 22:24:58 Version V 2.22h
    Parameter:
    -i 192.168.0.230
    Running on Linux
    /home/pi/svrpi$ sudo ./kaco-fb -i 192.168.0.230
    *************************************************
    * KACO-FB Proxy fuer SolarView@Fritzbox *
    * Version V 1.21c *
    * solarview-fb starten mit den Parametern *
    * Wechselrichter-IP : 127.0.0.1 *
    * Wechselrichter-Port: 10000 *
    * zusaetzliche Infos mit ./kaco-fb -d *
    *************************************************


    Ueberwache nun '192.168.0.230' auf Port 10000
    und empfange auf Port 10000 Befehle
    Wechselrichterabfrage alle 20 Sekunden


    build Feb 15 2014 15:22:01
    *************************************************
    * KACO-FB Proxy fuer SolarView@Fritzbox *
    * Version V 1.21c *
    * solarview-fb starten mit den Parametern *
    * Wechselrichter-IP : 127.0.0.1 *
    * Wechselrichter-Port: 10000 *
    * zusaetzliche Infos mit ./kaco-fb -d *
    *************************************************
    Ueberwache nun '192.168.0.230' auf Port 10000
    und empfange auf Port 10000 Befehle
    Wechselrichterabfrage alle 20 Sekunden


    build Feb 15 2014 15:22:01
    /home/pi/svrpi$ sudo ./start.sh
    trap: SIGHUP: bad trap


    Starte SolarView@Fritzbox V 2.22h
    SP: 10000
    Recipient -r1: pv@talaecker.de


    solarview-fb l�uft bereits 2 Mal. Beende nun...
    ./start.sh: 6: ./start.sh: ./kaco-fb: Permission denied

    7,68kWpeak Anlage 206°SW 40°DN; 32 Centrosolar AG Solarmodul S 240P60; 2x Kaco Powador 4400; Schletter Profile; BJ.12/2011 by Solartechnik-Franken Hier mein SolarView@PIDatenlogger

  • Zitat von koppi

    ... und dann gestartet via
    sudo ./solarview-fb -i 192.168.0.230
    sudo ./kostal-fb -i 192.168.230
    sudo ./start.sh


    Wieso startest du solarview-fb und kostal-fb erst manuell? Die beiden sollten doch automatisch in start.sh gestartet werden...

  • :? weil es so in auf Manfeds Seite zur Ersteinrichtung drin stand...


    In der Zwischenzeit habe ich nach mehrmaligen Versuchen und hin und her kopieren den Datenlogger zum laufen gebracht.
    Autostart funzt auch wieder, jedoch die Fehlermeldungen kommen immer noch...
    Scheinbar noch ohne Auswirkung... :?

    7,68kWpeak Anlage 206°SW 40°DN; 32 Centrosolar AG Solarmodul S 240P60; 2x Kaco Powador 4400; Schletter Profile; BJ.12/2011 by Solartechnik-Franken Hier mein SolarView@PIDatenlogger