Raspberry Netzwerkproblem

  • Hallo,
    ich bin mit Solarview von der Fritz.Box 7490 auf den Raspberry Modell B umgezogen. Wechselrichter an USB-RS485, D0-Lesekopf über USB und Gaszähler (EV) über USB-RS232-Konverter (alles an USB-HUB).


    Problem ist, dass alle 5-6Tage die Netzwerkverbindung vom RPI zur Fritzbox 7490 verloren geht und ich nicht mehr auf den RPI zugreifen kann. Daten schickt der RPI dann natürlich auch nicht mehr.


    Woran kann das liegen?


    Gruß


    Xander

    Ost/West-Anlage: Ost (-110Grad/DN30): 12x Solar-Fabrik Premium L Poly 260W
    West (70Grad/DN48): 21x Solar-Fabrik Premium L Poly 260W
    Platinum 7000 R3-S2B - Firmware V2.2.4.0
    Solarview 2.24l @ Fritz!Box 7490 OS7.12
    Automower: Gardena R40Li mit Robonect H30x

  • Wieviel Strom liefert denn dein Raspi Netzteil? Evtl. ist das etwas unterdimensioniert, hatte damit auch mal Probleme. Hab seitdem ein 2A Netzteil und Alles ist gut ;)


    Gesendet von meinem GT-I9000 mit Tapatalk 2

    30x Sunpower E20/327, Sunpower SPR-10001F-3, Fronius - Datamanager + RasPi mit Solarview, Ausrichtung -50° Dachneigung 42° in Betrieb seit 10.12.2012

  • Auf dem RPI bekomme ich Solarview nicht stabil ans laufen. 2A-Netzteil habe ich gekauft, immer nach 7Tagen habe keine Netzwerkverbindung zum RPI mehr.


    Habe jetzt die FW 6.30 meiner Fritzbox 7490 mit debug.cfg und telnet modifiziert und bin mit Solarview wieder auf die 7490 umgezogen.


    Gruß


    XC

    Ost/West-Anlage: Ost (-110Grad/DN30): 12x Solar-Fabrik Premium L Poly 260W
    West (70Grad/DN48): 21x Solar-Fabrik Premium L Poly 260W
    Platinum 7000 R3-S2B - Firmware V2.2.4.0
    Solarview 2.24l @ Fritz!Box 7490 OS7.12
    Automower: Gardena R40Li mit Robonect H30x

  • Hängt der Raspi per LAN oder WiFi im Netz? Hatte auch immer Probleme mit dem USB-WiFi-Stick, da war auch alle paar Tage das Netz weg.


    Hast du den Raspi auch ohne weitere USB-Geräte mal laufen lassen? War das Verhalten dann identisch?


    Gesendet von meinem GT-I9000 mit Tapatalk 2

    30x Sunpower E20/327, Sunpower SPR-10001F-3, Fronius - Datamanager + RasPi mit Solarview, Ausrichtung -50° Dachneigung 42° in Betrieb seit 10.12.2012

  • Hi,
    Ich könnte mir auch vorstellen, dass es der WLAN USB Stick ist.
    Bei mir ist mit dem "Ding" während des Bespielens bzw. Konfigurieren des RPI die Verbindung oft abgebrochen....dann hab ich den RPI als LAN Kabel gepackt und alles gut....mittlerweile hängt die Kiste wieder per WLAN an der Fritze.
    Allerdings über die AVM Fritz 546e Steckdose. Mein SHM und der RPI gehen per LAN auf die 546e Steckdose und die ist per WLAN an der Fritze. Klappt gut.
    Aber der USB Dongle....nee las ma stecken.
    Gruß Red5FS



    Gesendet von meinem iPad mit Tapatalk

    Gruß Red5FS
    ---
    37 Hanwha Q-Cells G2 265W & SMA STP 8000TL-20 & SHM (30.09.13)
    17 Trina TSM DC80.08 215W & SMA SB 3600TL-21 (03.06.14)
    Do it or don`t do it!There is no try!
    The Force is with you!
    GroßMeisterLusche L:82 D:5 T:3
    Meine Anlage
    SV@fb

  • Hallo,


    wegen WLAN über USB:
    http://raspberrypi.stackexchan…-reconnect-wifi/5341#5341
    hat bei meinen PI's Wunder gewirkt, liefen und laufen über 100 Tage ohne Probleme.


    Alles andere:
    Netzteil, Und wo 2A draufsteht muss nicht 2A drinnen sein oder >5V stabil halten, vieles ausprobiert. Mittlerweile nutze ich umgebaute von AP's. Ausprobieren.


    Grüße

  • Zitat von xander


    Habe jetzt die FW 6.30 meiner Fritzbox 7490 mit debug.cfg und telnet modifiziert und bin mit Solarview wieder auf die 7490 umgezogen.


    Wie geht das? Link oder kurze Beschreibung bitte!