RPi - SMAP - yasdishell erkennt WR nicht

  • Hallo.


    Ich benötige mal Eure Hilfe!
    Aufgrund des drohenden Wegfalls des Telnetzugangs auf der FB würde ich gerne meine solarview-Installation auf einen Raspberry PI umziehen.
    Dazu habe ich mir ein frisches System aufgesetzt (rasbian wheezy 2015-05-05), das System aktualisiert und gemäß der Anleitung eingerichtet.
    Folgende IP sind festvergeben:
    192.168.178.11 RPi
    192.168.178.9 eX-9132
    192.168.178.1 FB (als Gateway)


    Wenn ich nun den Wechselrichter mit yasdi erkennen lassen möchte, kommt die Meldung, dass er keine Geräte gefunden hat.
    Vom RPi kann ich den Konverter anpingen.




    Die yasdi.ini wurde gemäß des Konverters angepasst (siehe Anhang)



    Die Einstellungen im Konverter wurden auch überprüft:



    Ein Fehler im Netzwerk schließe ich aus, da beide Geräte an einem Switch hängen und zur Fehlersuche auch wieder in die ursprungs Konfig versetzt werden (Konverter Ziel-IP --> Fritzbox .1)
    Die Dienste auf der FB wurden natürlich vorher ordnungemäß beendet.
    Die Verkabelung funktioniert auch, da ich problemlos das solarview auf der FB starten kann.
    Die Übertragungsart ist binär bei WinSCP.



    Wo liegt mein Fehler? Ich verzweifel hier schon....um Dummheit auszuschließen,habe ich sogar das ganze schon einmal von Anfang an sauber nachgespielt, es kommt wieder der selbe Fehler: Bei yasdi wird der Wechselrichter nicht gefunden.

  • Ohh man,dass hat Nerven gekostet.


    Hier ist die Erklärung:

    Zitat

    Hinweis zur statischen IPv4-Konfiguration


    Die Vorgehensweise bei der manuellen (statischen) IPv4-Konfiguration eines Raspberry Pi ist von der Distribution und deren Versionsstand abhängig. Ab Raspbian Wheezy vom 2015-05-05 hat sich etwas entscheidendes verändert, weshalb alte Beschreibungen, Tutorials und Anleitungen zu fehlerhaften Netzwerk-Konfigurationen führen. Ein beliebter Fehler ist, dass ein Raspberry Pi plötzlich zwei IPv4-Adressen hat. Einmal per DHCP zugewiesen und die zweite durch eine manuelle Konfiguration in der Datei "/etc/network/interfaces".


    Quelle


    In der Tat hatte mein RPi zwei IPs. ssh geht auf die "feste" aber die eingehende TCP Verbindung nur auf die "DHCP"-vergebene Adresse.


    Dann schaue ich jetzt mal weiter.

  • Dann nimm die statischen IPs doch raus und konfiguriere das DHCP in deiner Fritzbox so, dass den Geräten immer die gleiche IP-Adresse zugewiesen werden soll.

  • Ich habe nun eine statische IP konfiguriert, das ist mir lieber als per DHCP mittels FB imemr die selbe IP zu bekommen, so bleibt die FB im Fehlerfall eigenständig und murkst mir nicht im Netzwerk rum.