Volkszähler Ausfall!

  • Hallo zusammen!


    Habe seit einigen Monaten bei mir den Volkszähler an 2 ISKRA MT681 erfolgreich laufen.
    Nun habe ich vorhin mal in mein Frontend geschaut und da war nix mehr. Dann schaute ich in mein HTML was mir die Zählerstände jeden Tag anzeigt und da stand ab 29.07. nix mehr drin.


    Mal ein Auszug der Logdatei:


  • Mahlzeit krma1985


    Was ergeben die Kommandos:
    sudo ps ax | grep vzlogger
    sudo vzlogger -v


    Inhalt folgender Dateien hier zusätzlich posten:
    /etc/vzlogger.conf
    /etc/hosts
    /etc/inittab


    Gruß HofeBY

  • Hallo hofeBY


    also sudo ps ax | grep vzlogger:


    4059 pts/0 S+ 0:00 grep --color=auto vzlogger


    sudo vzlogger -v:


    vzlogger: error while loading shared libraries: liblrer-2.4.so▒2: cannot
    open sh
    ared object file: No such file or directory


    /etc/vzlogger.conf:



    /etc/Hosts:


    Code
    127.0.0.1 localhost
    ::1 localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    127.0.1.1 raspberrypi


    /etc/inittab:



    daran habe ich aber eigentlich nichts verstellt weil es lief ja ne Zeit lang!

  • Also bei Dir scheint es eine der libarys zerlegt zu haben.
    (sudo vzlogger -v)
    Um einen fehlerfreieren Netzverkehr zu gewährleisten sollte in der /etc/hosts der Eintrag "127.0.1.1" in "127.0.0.1" geändert werden. Ist nicht nur bei Dir falsch. Als Beweis "sudo ifconfig" und man erkennt kein einziges Device mit der ominösen 127.0.1.1.
    Das "lo" Interface hat wie überall die 127.0.0.1


    Zur Behebung der fehlerhaften Libary würde ich den Updateweg siehe Link gehen.
    Zuerst vzlogger stoppen mit "sudo /etc/init.d/vzlogger stop"
    Anleitung in der README.
    https://github.com/volkszaehler/vzlogger


    Nach Update "vzlogger -v" sollte z.B. 0.4.3 ergeben
    Bei Erfolg vzlogger starten mit "sudo /etc/init.d/vzlogger start"
    Gruß HofeBY

  • beim Installieren ist das dann rausgekommen.



    und die Version ist immernoch die 0.4.0

  • Hmm, scheinbar wollte das Script gerade was mit der Datenbank machen.


    Mach mal
    "sudo /etc/init.d/apache2 stop"
    "sudo /etc/init.d/mysql stop"


    und dann die Prozedur
    "sudo ./install.sh"


    Ansonsten Entwickler kontaktieren.

  • immernoch das gleiche! irgend ein fehler in der router.php in Zeile 49.


    hätte noch ne Backup Datei von Anfang Juni die ich draufmachen könnte.

  • Nun, ich gehe natürlich davon aus, das der "sudo apt-get install ..." mit all seinen Packeten ordnungsgemäß durchgelaufen ist.
    Finde dessen Output oben nicht.
    Alternativ könnnte eines der Packete in der Betriebssystendatenbank drinnen stehen und trotzdem beschädigt sein.
    Da hilft dann nur alle diese Packete zu deinstallieren, Systemdatenbank aktualisieren "sudo apt-get update" und anschließend
    all diese Packete neu zu installieren "sudo apt-get install ...". Ich würde diese hierbei jeweils einzeln, da besser beobachtbar
    installieren. Und dann noch mal die "install.sh"


    Ansonsten Entwicker kontaktieren.
    Bevor Datenrücksicherung die abgeschaltete Mysql Datenbank sichern !


    Jedefalls war die vzlogger Version 0.4.0 bei mir diejenige, welche sich einfach beendete (fehlte dann in Prozesssliste) und nichts mehr in die Middleware eingetrage hat.
    Habe zur Beseitigung das vzlogger Update wie beschrieben erfolgreich durchgeführt.


    Kontaktiere mal den Entwickler!
    Wünsche viel Glück
    HofeBY