Verbrauchsgrafik: Peaks statt stetiger Kurve

  • Hallo allerseits,


    ich stehe etwas auf dem Schlauch. Sicher gibt es eine einfache Lösung:


    VZ auf RaspberryPi B+, Udos USB-Kopf auf einem EMH ITZ-Zähler.


    Der Zähler spuckt als m.E. einzig verwertbaren OBIS-Code die 1.8.0 aus, den aktuellen Zählerstand auf 0,1 KWh genau. Aktuelle Wirkleistung gibt es m.E. nicht...


    Die Hardware funktioniert, der Zählerstand wird ca. 1 mal pro Minute an die Middleware übergeben.
    Den Kanal habe ich als "S0 Stromzähler", Auflösung 1/KWh, Line-Style konfiguriert.


    Die Grafik zeigt mir an jedem Zeitpunkt, an dem der Zähler 1/10 KWh weiterzählt, einen "Peak" von 9.000 W, ansonsten liegt die Kurv auf Null. Anhand der zeitlichen Dichte der Peaks kann ich abschätzen, wann mehr und wann weniger Strom verbraucht wird...


    Sehen möchte ich eigentlich eine Kurve, bei der zwischen zwei 0,1 KWh-Sprüngen über die vergangene Zeit ein Mittelwert der verbrauchten Leistung gezeigt wird.


    Wie kriege ich das hin?
    Über einen Tipp würde ich mich freuen,


    Grüße,
    Gunnar

  • Zitat von derGanter


    Der Zähler spuckt als m.E. einzig verwertbaren OBIS-Code die 1.8.0 aus, den aktuellen Zählerstand auf 0,1 KWh genau.


    Die Hardware funktioniert, der Zählerstand wird ca. 1 mal pro Minute an die Middleware übergeben.
    Den Kanal habe ich als "S0 Stromzähler", Auflösung 1/KWh, Line-Style konfiguriert.


    Wie du selbst schreibst: "1.8.0 gibt den aktuellen Zählerstand auf 0,1 KWh genau"
    Insofern ist es falsch, den Kanal als Stromzähler und dann noch als S0-Impuls zu definieren.
    Richtig wäre einen Kanal als "El. Zählerstand" zu erstellen und nicht vergessen einen Anfangsstand einzugeben.


    Wie kannst du den Kanal jetzt ändern: Rechts auf das (i) klicken und dann in dem Fenster 'Bearbeiten' anklicken.


    Gruß
    Udo

  • Zitat von Udo

    Insofern ist es falsch, den Kanal als Stromzähler und dann noch als S0-Impuls zu definieren.
    Richtig wäre einen Kanal als "El. Zählerstand" zu erstellen und nicht vergessen einen Anfangsstand einzugeben.


    Wie kannst du den Kanal jetzt ändern: Rechts auf das (i) klicken und dann in dem Fenster 'Bearbeiten' anklicken.


    Hi Udo,


    danke für die schnelle Antwort. Habe gerade gemerkt, dass ich in meiner Beschreibung einen Fehler gemacht habe- ich hatte den Kanal mit "El. Energie (Zählerstände)" angelegt, S0 hatte ich falsch in Erinnerung, als ich den Forenbeitrag schrieb. Er ist also eigentlich richtig konfiguriert...


    Kann man in der vzlogger.conf vielleicht irgendwo einstellen, dass nur dann ein neuer Zählerstand an die middleware übermittelt werden soll, wenn sich was geändert hat? Ich denke, das könnte das Problem lösen...


    Grüße,
    Gunnar

  • Zitat von derGanter

    Er ist also eigentlich richtig konfiguriert...


    So wie du es beschreibst eigentlich nicht. Fällt mir noch ein: Als Style Steps einstellen.
    Ansonsten mal auf der Mailing-Liste nachfragen. Da lesen die Entwickler des Frontends mit. Hier nicht.


    Gruß
    Udo

  • Hallo derGanter,


    eins vorweg, ich bin kein Linuxkenner.


    Ich benutze die selbe Hardware und habe wohl ein ähnliches Problem mit der Darstellung im Frontend.
    Hast du dafür schon eine Lösung?


    Die Einstellungen wie in dem Thema besprochen habe ich durchgeführt. Der/die Verbräuche werden aber nur als Peaks und nicht wie erwartet als "Fieberkurve" dargestellt und die zeitlicheVerlauf / Zuordnung in der Darstellung passt nicht.


    Ich habe festgestellt, dass der VZLogger alle 26 Sekunden Daten erhält, das ist meiner Meinung nach viel zu viel.
    Kann das mit der "pullseq" eingestellt werden?


    Als Anhang ein paar Bilder (bei der vzlogger.conf fehlen 4 Zeilen, aber protokoll ist d0)


    Gruß


    Wanne




    [attachment=0]

  • Die Auflösung die du eingestellt hast ist falsch. Wenn dein Zähler Wh ausspuckt musst du 1000 eintragen um auf kWh zu kommen.



    mfg JAU

    No Shift - No Service

  • Hallo JAU,


    danke für die schnelle Antwort, habe ich geändert.


    Der Logger bekommt die Werte in KWh oder liege ich da falsch? Nachkommastellen werden wohl nicht ausgegeben.


    Die Anpassung der Auflösung berichtigt die Skalierung, ändert aber an der Darstellung des Verbrauchsverlaufes nichts.


    Kann es sein, dass das Frontend mit der Masse an Daten überfordert ist?
    Kann ich die Datenmenge in der vzlogger.conf reduzieren?


    Herzlichen Dank


    Wanne

  • Deine Einstellung der Auflösung war doch korrekt. :oops:


    Aber das Problem können wir leider nicht lösen. Dein Zähler gibt eine seeeehr geringe Auflösung aus weil dein VNB das so programmiert hat. Keine Handhabe deiner- oder unsererseits. Es sei denn du lässt einen zusätzlichen, eigenen Zähler einbauen.



    mfg JAU

    No Shift - No Service

  • > Als Anhang ein paar Bilder (bei der vzlogger.conf fehlen 4 Zeilen, aber protokoll ist d0)


    Zeig mal deine komplette vzlogger.conf. Die letzten 4 Zeilen sind auch wichtig.


    Gruß und Frohes neues Jahr
    Udo

  • Hallo Udo,


    ich glaube das Problem ist gelöst.
    Grundsätzlich lag es wohl daran, dass mein Zähler nur ganze KWh ohne Kommastellen ausgibt. Das hat zur folge das es sehr wenige Änderungen gibt solange nur "Kleinverbraucher" laufen. Werte wurden aber ca. alle 26 Sekunden abgefragt, in die DB eingetragen und der Differenzwert für die Darstellung war dann meistens 0 (weil keine Änderung).


    Ich habe gestern diesen Link gefunden
    https://github.com/volkszaehler/vzlogger/issues/98


    Hier wurde eine Möglichkeit diskutiert und schließlich umgesetzt um doppelte Messwerte wegfallen zu lassen.


    Ich habe die Option "duplicates" in die vzlogger.conf eingebaut und bin mit dem Ergebnis eigentlich zufrieden.


    Das Bildchen ist nun leider beim fast ausschließlichen Bezug von 1.8.2 NT. Ich bin mal auf die Darstellung beim "Mischbetrieb" gespannt.


    Danke für die Unterstützung


    Wanne