Geräte mit Home Manager koppeln via SEMP (Ethernet)

  • Ich habe gerade von 1.3.50 auf 1.4.14 geupdated. Hat sich etwa die Konfiguration schon wieder geändert????


    Code
    1. Validating appliance configuration
    2. ...
    3. Terminating because of incorrect configuration


    Ich habe definitiv kein Bock alles wieder wegzuwerfen und alle Geräte neu einzurichten. Sorry aber es wird mal Zeit für ein updatepfad.

    2,55 kWp, SMA SB2.5, 25° SW, 30° Neigung, 10x ZNShine PV-tech ZXP6-60-255/P (09/2015)
    9,54 kWp, SMA STP9000TL-20, 25° SW, 7° Neigung, 36 x Heckert Solar NeMo P265W (04/2016)
    25 kWh Hoppecke PzS, SMA SI6.0H-11 (09/2016)
    Windrad Black 300
    2x VW e-Golf
    BWWP

  • Ich habe gerade von 1.3.50 auf 1.4.14 geupdated. Hat sich etwa die Konfiguration schon wieder geändert????


    Code
    1. Validating appliance configuration
    2. ...
    3. Terminating because of incorrect configuration


    Ich habe definitiv kein Bock alles wieder wegzuwerfen und alle Geräte neu einzurichten. Sorry aber es wird mal Zeit für ein updatepfad.

    Ja, das XML-Format hat sich geändert für Geräte mit Modbus und HTTP. Deshalb heißen die neuen Releases auch nicht 1.3.x, sondern 1.4.x. Abgesehen davon ist es jedem freigestellt, auf einem bestehenden Release zu bleiben - es gibt keinen Updatezwang! Übrigens hatte ich kürzlich die Modbus-Konfiguration für PhoenixContact-Wallboxen gepostet, das könntest Du auch einfach übernehmen - Du kennst Dich ja sehr gut aus. Wenn Du willst, kann ich Dir meine Appliances.xml auch per Mail schicken, dann kannst Du Dir die Teile rauspicken, die Du brauchst.

    Angesichts der überschaubaren User-Anzahl lohnt sich der Aufwand für ein automatisches Update nicht. Zumindest habe ich keine Zeit dafür. Ich investiere SEHR viel Zeit in den SAE, aber alles hat Grenzen. Bisher hat sich auch niemand gefunden, der außerhalb der Dokumentation irgendwelche Entwicklungsarbeiten übernehmen möchte.


    Axel

  • hatte am Anfang auch Schwierigkeiten. Bei mir ist es jetzt so, wenn ich im SAE den GPIO Pin 4 eingebe wird am Raspberry der GPIO PIN 23 geschalten. Woher das kommt kann ich leider nicht erklären, aber evtl. ist es bei dir ähnlich. Einfach mal ausprobieren ...

    Sicher, dass Du nicht GPIO14 meinst? Der gehört nämlich zu Pin 23. Eigentlich brauch man nicht ausprobieren, sondern muss nur der Anleitung folgen: https://github.com/camueller/S…aster/doc/Raspberry_DE.md


    Axel


    Ich glaube ich bin der Sache auf der Spur ...


    Die Doku ist für den Raspberry 2 Model B geschrieben. Hier ist der PIN16 = GPIO 4

    Da ich den Raspberry 3 verwende hatte ich natürlich im Netz auch nach der Pinbelegung/GPIO-Belegung für den Raspberry 3 gesucht. Hier ist der PIN16 = GPIO 23


    Das sollte die ganze Sache erklären, denke ich.


    Gruß

  • Ich glaube ich bin der Sache auf der Spur ...


    Die Doku ist für den Raspberry 2 Model B geschrieben. Hier ist der PIN16 = GPIO 4

    Da ich den Raspberry 3 verwende hatte ich natürlich im Netz auch nach der Pinbelegung/GPIO-Belegung für den Raspberry 3 gesucht. Hier ist der PIN16 = GPIO 23

    Ich habe die Dokumentation aktualisiert. Die Grafik habe ich entfernt (da nur für Pi 2b gültig) und verweise stattdessen auf die verwendete Bibliothekt, die Grafiken für alle unterstützen Modelle beinhaltet.

    https://github.com/camueller/S…aster/doc/Raspberry_DE.md


    Axel

  • ich bräuchte mal Hilfe: Seit gestern findet das Sunny Portal den SAE nicht mehr.

    Ein Blick in die Log Datei verrät mir auch warum:

    SEMP UPnP will redirect to http://192.168.99.1:8080


    99.1 ist mein VPN auf dem Raspberry. Das läuft schon lange parallel, k.A. warum der SAE die Daten nun ins VPN Netz schickt.


    Weiß Jemand wo ich das ändern kann, sprich die richtige IP einstellen kann ?


    In /etc/default/smartapplianceenabler habe ich geändert:

    # Bind to specific network address

    JAVA_OPTS="${JAVA_OPTS} -Dserver.address=192.168.168.5"


    hat leider nichts gebracht

  • Schau mal in die Datei /etc/default/smartapplianceenabler da findest du folgendes:


    Code
    1. # Bind to specific network address
    2. #JAVA_OPTS="${JAVA_OPTS} -Dserver.address=192.168.178.33"

    6,93 kWp bei -6° Süd und 42° DN, 22 x Hanwha Q.PEAK DUO BLK-G5 315 (10/2019), Ertragsübersicht

    SMA Sunny Tripower 8.0 und Sunny Home Manager 2.0

    Smart Appliance Enabler 1.4 mit 4 x Gosund SP1 v2.4 (Tasmota 6.7.1)

    Tecalor THZ 304 eco mit ISG und EMI 2.2.0

    grünstrom classic für 35,90 EUR/Jahr mit 0,2442 EUR/kWh


  • Welche Version verwendest Du? Verwendest Du möglicherweise das Docker-Image?

    Falls ja - das verwendet bereits eine Änderung, die noch nicht releast wurde ...


    Axel

  • Es lag daran, dass ich gestern mein VPN am Raspberry auf automatischen Start gesetzt hatte:

    Code
    1. sudo systemctl enable wg-quick@wg0


    Somit startet Wireguard vorm SAE.

    Scheinbar nimmt SAE dann die IP vom VPN da die Metrik von wg0 auf 0 steht, von eth0 auf 202.

  • hm, habe jetzt mal das Objekt (Waschmaschine) im SAE gelöscht und ganz neu (mit neuen Namen und ID) angelegt und wieder im SMH hinzugefügt.

    Gleiches Fehlerbild :(

    Hat jemand eine Idee?